[2.0] Homescreen tests are failing (MarionetteException: Element has not been pressed)

RESOLVED DUPLICATE of bug 1028640

Status

Firefox OS
Gaia::UI Tests
P1
normal
RESOLVED DUPLICATE of bug 1028640
3 years ago
3 years ago

People

(Reporter: AndreiH, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Tests started failing

http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Aurora/job/b2g.flame.mozilla-aurora.ui.smoketest/28/HTML_Report/

Manually everything is ok.

TracebacK:

Traceback (most recent call last):
  File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/marionette_test.py", line 170, in run
    testMethod()
  File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_edit_mode.py", line 20, in test_access_and_leave_edit_mode
    self.homescreen.activate_edit_mode()
  File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/app.py", line 52, in activate_edit_mode
    wait(1).\
  File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/marionette.py", line 385, in perform
    self.current_id = self.marionette._send_message('actionChain', 'value', chain=self.action_chain, nextId=self.current_id)
  File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/decorators.py", line 35, in _
    return func(*args, **kwargs)
  File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/marionette.py", line 633, in _send_message
    self._handle_error(response)
  File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/marionette.py", line 704, in _handle_error
    raise MarionetteException(message=message, status=status, stacktrace=stacktrace)
MarionetteException: MarionetteException: Element has not been pressed
(Reporter)

Comment 1

3 years ago
Created attachment 8444386 [details]
Screenshot.png
(Reporter)

Updated

3 years ago
Priority: -- → P1

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1028640
You need to log in before you can comment on or make changes to this bug.