Closed Bug 1029194 Opened 6 years ago Closed 6 years ago

[Vertical Homescreen] App icon is not updated until a phone restart

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 1029280
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: jlorenzo, Unassigned)

Details

(Keywords: regression, Whiteboard: [systemsfe])

STR
1. Get http://mozilla.github.io/qa-testcase-data/webapi/apps/smallappcachepreload.manifest and host it on your own HTTP server
2. Install the app by pointing to your self-hosted manifest via you browser
3. To simulate an app update, in the the mini-manifest, modify:
"appcache_path": "*value*" to "appcache_path": "http://mozilla.github.io/qa-testcase-data/webapi/apps/largeappcachepreload." 
"icons": {*value*} to "icons": { "126": "your_new_icon_path.png"
4. Check for new version and wait until the notification pop.
5. Update the app.
6. Wait for the app to be downloaded.
7. Go back to the homescreen.

Actual result
The app is updated but not its icon, until a phone restart.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Not blocking because we've shipped with this problem before, even though it did work at one point.
Blocks: vertical-home-next
No longer blocks: 1015336
No longer blocks: vertical-home-next
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1029280
You need to log in before you can comment on or make changes to this bug.