[Calendar] Tag marker says stationary as you scroll in calendar event

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Calendar
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: tchung, Assigned: evanxd)

Tracking

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [priority], [p=1], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
When specifying a calendar event and scrolling through the details, you can see that the calendar tag dot follows you.

see screencast.  Follow the Blue Dot!:  http://youtu.be/PhI3kY2Wc6M

I havent checked if this is a regression yet or not.   Filing for now.

Repro:
1) install 2.0 aurora build on Flame (20140623000201)
2) add a google calendar event (have a tag marker indicating the account type)
3) open event and scroll through it
4) Verify the tag marker stays stationary as the rest of the page pans

Expected:
- tag marker doesnt stay stationary why you pan

Actual:
- follow the blue dot!
(Reporter)

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
I think either Evan or Miller would be a good candidate here.
Flags: needinfo?(mmedeiros)
Flags: needinfo?(evanxd)
Assignee: nobody → mmedeiros
Flags: needinfo?(mmedeiros)
Flags: needinfo?(evanxd)
(Assignee)

Comment 2

3 years ago
Created attachment 8445725 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/20964

Hi Miller,

I already have a patch for the issue.

This issue is caused by the visual refresh work.
So I think I should fix the bug.

Could you help to review the patch?
Thanks.
(Assignee)

Updated

3 years ago
Attachment #8445725 - Flags: review?(mmedeiros)
(Assignee)

Updated

3 years ago
Assignee: mmedeiros → evanxd
Is there a way that a test can be written to protect this behavior in the future?
Comment on attachment 8445725 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/20964

Fixes the problem with minimal changes, I like it. Thanks!
Attachment #8445725 - Flags: review?(mmedeiros) → review+
Gareth, we could write a test for it, but it would need to create an event description large enough to be displayed through multiple lines (right now we don't keep the line breaks - see Bug 1030146)... If we consider the amount of work required, the likelihood of a test catching this kind of regression and the potential for intermittent failures I don't think we should do it.
(Assignee)

Comment 6

3 years ago
I would like to have tests for the layout of Calendar.

But it is not easy to write tests for the layout(e.g. some elements are at the right position) of an app. I tried to figure out an way to have tests for layout issues in Bug 993276.
(Assignee)

Comment 7

3 years ago
Thanks for Miller's review.
(Assignee)

Comment 8

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/87a7746568ac5708e828026160c0732ba252300f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
(Assignee)

Updated

3 years ago
status-b2g-v2.1: affected → ---
(Assignee)

Updated

3 years ago
Whiteboard: [priority], [p=1]
Target Milestone: --- → 2.0 S5 (4july)
v2.0: https://github.com/mozilla-b2g/gaia/commit/251552f9561c422b15d341501d8786ec1fc3c6d1
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: --- → fixed

Updated

3 years ago
Duplicate of this bug: 1028526
[Environment]
Gaia      0910be495385d90acdeaddbeaf1fba315aff57b0
Gecko     https://hg.mozilla.org/mozilla-central/rev/7883d8e9f210
BuildID   20140715160202
Version   33.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[Result]
Pass
Status: RESOLVED → VERIFIED

Comment 12

3 years ago
Created attachment 8531830 [details]
VIDEO0120.mp4

This issue has been successfully verified on Flame 2.0:
Gaia-Rev        3aa0797c111a40e36f722722309668de3d469181
Gecko-Rev       93efc8b4155f0a4a50eaad19acbb95ec24139e63
Build-ID        20141204050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2

This issue has been successfully verified on Flame 2.1:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0
Device-Name     flame
FW-Release      4.4.2

Updated

3 years ago
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.