newlines in keyboard corrupt input

RESOLVED DUPLICATE of bug 1015541

Status

RESOLVED DUPLICATE of bug 1015541
4 years ago
4 years ago

People

(Reporter: ladamski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Assuming spell correction is on:

STR #1:

Type "one" on line 1, hit return
On line 2, type "twwo" which will be corrected to "two"
Select end of line 1 (i.e just past "one"), and hit backspace

Line 1 will turn into "twwo" and all subsequent input corrupted and unusable

STR 21:
Type "one" on line 1, hit return
On line 2, type "two", hit return
Select end of line 1, hit backspace, then type "e" again and hit space
Instead of "one" it gets corrected to "tower"

I've run into this issue in email, SMS, moz notes app, etc so its not app specific.
(Reporter)

Comment 1

4 years ago
Build: Aurora 20140623000201
blocking-b2g: --- → 2.0+
(In reply to Lucas Adamski [:ladamski] (plz needinfo) from comment #1)
> Build: Aurora 20140623000201

I assume you mean non, not a plus. qawanted to reproduce on v1.3/v1.4. Should not block if this is not a regression.
blocking-b2g: 2.0+ → 2.0?
status-b2g-v1.3: --- → ?
status-b2g-v1.4: --- → ?
Keywords: qawanted
(Reporter)

Comment 3

4 years ago
Keyboard is unusable with this bug, I don't see how it cannot be a blocker.
Duplicate of bug 1015541.

Does not occur on 1.3, does on 1.4.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1015541
(In reply to Lucas Adamski [:ladamski] (plz needinfo) from comment #3)
> Keyboard is unusable with this bug, I don't see how it cannot be a blocker.

You can't just set the blocker field for bugs. Need to be addressed by qa and triage.

Anyway, bug 1015541 has 1.4+ already.
status-b2g-v1.3: ? → ---
status-b2g-v1.4: ? → ---
Lucas,

As Jan mentioned, bug 1015541 is a v1.4+ blocker, so guess we could handle this issue at the same time with that bug.
Thanks for filing this.
blocking-b2g: 2.0? → ---

Updated

4 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.