If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox parses JSON responses to clickable tree in devtools and can't be stopped

RESOLVED DUPLICATE of bug 859138

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 859138
3 years ago
3 years ago

People

(Reporter: sil-persona, Unassigned)

Tracking

30 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140608211622

Steps to reproduce:

Visit any page which makes an XHR which returns JSON.
In the devtools, select that XHR under the Network tab.
See on the right details of the request and response.
Switch to the Response tab of the request details and observe that the JSON has been parsed into a convenient clickable tree.
Try and find a way to get at the actual JSON, so it can be cut-and-pasted.


Actual results:

There is no way to stop Firefox parsing a JSON Response into a clickable tree.


Expected results:

There should be a way to toggle between the raw response and the parsed tree.

Note: it is possible to get at the raw response by turning on Net logging in the console and "Log request and response bodies", clicking the same request there, and then viewing the response body therein. However, this is a non-obvious approach.
We're on it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859138
You need to log in before you can comment on or make changes to this bug.