Closed Bug 1029730 Opened 6 years ago Closed 6 years ago

(vertical-homescreen) Search field width changes slightly when invoked

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: pla, Assigned: crdlc)

References

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, [ft:systemsfe][systemsfe])

Attachments

(3 files)

The search field pill shape currently shrinks when the user taps on it to invoke it.  The search field should stay exactly the same as on homescreen.

PLEASE NOTE:

I'm going to needinfo Eric Pang to make sure this is correct and that nothing intentional has changed with Search.  Please wait for Eric's 'OK' before proceeding to fix this bug.
Eric - can you just 'OK' this if it looks correct?  I talked to Przemek and he said that when you guys spec'd Search, you asked for the search field to stay the same as homescreen in terms of size, positioning, etc.
Flags: needinfo?(epang)
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Blocks: vertical-home-next
No longer blocks: vertical-homescreen
(In reply to Peter La from comment #1)
> Eric - can you just 'OK' this if it looks correct?  I talked to Przemek and
> he said that when you guys spec'd Search, you asked for the search field to
> stay the same as homescreen in terms of size, positioning, etc.

Hi Peter, that's correct it should match the homescreen. Thanks!
Flags: needinfo?(epang)
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Github pull request
Fixed the issue, many thanks for your time Dale
Attachment #8447006 - Flags: review?(dale)
Comment on attachment 8447006 [details]
Github pull request

Good eyes :) I couldnt notice the difference until I looked very hard
Attachment #8447006 - Flags: review?(dale) → review+
Me neither :) But overlapping both screenshots I could see it. My eyes are not so good hahaha

(In reply to Dale Harvey (:daleharvey) from comment #4)
> Comment on attachment 8447006 [details]
> Github pull request
> 
> Good eyes :) I couldnt notice the difference until I looked very hard
Merged in master:

https://github.com/crdlc/gaia/commit/c487ce5e7fde1dfc44f820349ec614bb4e5df344
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8447006 [details]
Github pull request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: text fields are a bit different in rocketbar and vertical home
[Testing completed]: added two pixels to the text field in the rocket bar to fit both in CSS
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]: no
Attachment #8447006 - Flags: approval-gaia-v2.0?(bbajaj)
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → All
Target Milestone: --- → 2.0 S5 (4july)
Comment on attachment 8447006 [details]
Github pull request

low risk css changes, looks good to land.
Attachment #8447006 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Attached image 008.png
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141202000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2

This issue has been successfully verified on Flame 2.1:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141202001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.