If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent Shutdown | application crashed [@ mozilla::FramePropertyTable::Get(nsIFrame const*, mozilla::FramePropertyDescriptor const*, bool*)]

RESOLVED DUPLICATE of bug 1010666

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 1010666
3 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash})

Trunk
x86_64
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=42367722&tree=Mozilla-Inbound

Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test crashtest on 2014-06-24 09:46:15 PDT for push ebac3a17de53
slave: t-snow-r4-0058

09:58:42     INFO -  REFTEST TEST-START | Shutdown
09:58:42     INFO -  --DOCSHELL 0x11ba64800 == 8 [pid = 946] [id = 71]
09:58:42     INFO -  --DOCSHELL 0x120791800 == 7 [pid = 946] [id = 2]
09:58:42     INFO -  --DOCSHELL 0x1287e3800 == 6 [pid = 946] [id = 262]
09:58:42     INFO -  [946] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/slave/m-in-osx64-d-00000000000000000/build/dom/events/ContentEventHandler.cpp, line 110
09:58:42     INFO -  --DOCSHELL 0x1213bf000 == 5 [pid = 946] [id = 3]
09:58:42     INFO -  --DOCSHELL 0x11bf4d000 == 4 [pid = 946] [id = 1]
09:58:42     INFO -  1896484032[10032e1a0]: Shutting down SCTP
09:58:42     INFO -  --DOCSHELL 0x120588000 == 3 [pid = 946] [id = 72]
09:58:42     INFO -  --DOCSHELL 0x129c92000 == 2 [pid = 946] [id = 261]
09:58:42     INFO -  --DOMWINDOW == 133 (0x129e3b000) [pid = 946] [serial = 5870] [outer = 0x1299c8000] [url = about:neterror?e=fileNotFound&u=file%3A///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/foo&c=windows-1252&f=regular&d=Firefox%20can%27t%20find%20the%20file%20at%20/builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/foo.]
09:58:42     INFO -  --DOMWINDOW == 132 (0x129a5bc00) [pid = 946] [serial = 5869] [outer = 0x1299c8000] [url = about:blank]
09:58:42     INFO -  --DOMWINDOW == 131 (0x1299c9000) [pid = 946] [serial = 5868] [outer = 0x129867000] [url = about:neterror?e=fileNotFound&u=file%3A///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/foo&c=windows-1252&f=regular&d=Firefox%20can%27t%20find%20the%20file%20at%20/builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/foo.]
09:58:42     INFO -  --DOMWINDOW == 130 (0x129904000) [pid = 946] [serial = 5866] [outer = 0x129867000] [url = about:blank]
09:58:42     INFO -  --DOMWINDOW == 129 (0x12753f800) [pid = 946] [serial = 5788] [outer = 0x0] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/image/test/crashtests/delaytest.html?523528-2.gif]
09:58:42     INFO -  --DOMWINDOW == 128 (0x12693dc00) [pid = 946] [serial = 5786] [outer = 0x0] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/image/test/crashtests/delaytest.html?523528-1.gif]
09:58:42     INFO -  --DOMWINDOW == 127 (0x12e0bd400) [pid = 946] [serial = 5768] [outer = 0x0] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/image/test/crashtests/ownerdiscard.html]
09:58:42     INFO -  --DOMWINDOW == 126 (0x11b603400) [pid = 946] [serial = 5941] [outer = 0x0] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/555462-iframe.html]
09:58:42     INFO -  --DOMWINDOW == 125 (0x127a21800) [pid = 946] [serial = 5942] [outer = 0x0] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/555462-iframe.html]
09:58:42     INFO -  --DOCSHELL 0x128bd7800 == 1 [pid = 946] [id = 314]
09:58:42     INFO -  --DOMWINDOW == 124 (0x129d20400) [pid = 946] [serial = 5898] [outer = 0x0] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/299036-1.html]
09:58:42     INFO -  --DOMWINDOW == 123 (0x12a340c00) [pid = 946] [serial = 5910] [outer = 0x0] [url = data:text/html,<script>parent.done()</script>]
09:58:42     INFO -  --DOMWINDOW == 122 (0x129a5e400) [pid = 946] [serial = 5909] [outer = 0x0] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/445171-1-inner.svg]
09:58:42     INFO -  --DOMWINDOW == 121 (0x12b26f000) [pid = 946] [serial = 5940] [outer = 0x0] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/555462-iframe.html]
09:58:42     INFO -  --DOMWINDOW == 120 (0x12b4ee400) [pid = 946] [serial = 5957] [outer = 0x12b4eb000] [url = about:blank]
09:58:42     INFO -  --DOMWINDOW == 119 (0x128749c00) [pid = 946] [serial = 6000] [outer = 0x12990a400] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/widget/cocoa/crashtests/373122-1-inner.html]
09:58:42     INFO -  --DOMWINDOW == 118 (0x129e30000) [pid = 946] [serial = 5989] [outer = 0x1299c8c00] [url = about:blank]
09:58:42     INFO -  --DOMWINDOW == 117 (0x12abef800) [pid = 946] [serial = 5977] [outer = 0x12abee400] [url = data:text/html,Q]
09:58:42     INFO -  --DOMWINDOW == 116 (0x127ab4c00) [pid = 946] [serial = 6026] [outer = 0x127a1f400] [url = file:///builds/slave/talos-slave/test/build/tests/reftest/tests/widget/crashtests/303901-1.html?]
09:58:42     INFO -  --DOMWINDOW == 115 (0x127db8400) [pid = 946] [serial = 6028] [outer = 0x129907800] [url = about:blank]
09:58:42     INFO -  --DOMWINDOW == 114 (0x129867000) [pid = 946] [serial = 5865] [outer = 0x0] [url = about:neterror?e=fileNotFound&u=file%3A///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/foo&c=windows-1252&f=regular&d=Firefox%20can%27t%20find%20the%20file%20at%20/builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/foo.]
09:58:42     INFO -  --DOMWINDOW == 113 (0x1299c8000) [pid = 946] [serial = 5867] [outer = 0x0] [url = about:neterror?e=fileNotFound&u=file%3A///builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/foo&c=windows-1252&f=regular&d=Firefox%20can%27t%20find%20the%20file%20at%20/builds/slave/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/foo.]
09:58:42     INFO -  [946] WARNING: NS_ENSURE_TRUE(mTextInputHandler) failed: file /builds/slave/m-in-osx64-d-00000000000000000/build/widget/cocoa/nsChildView.mm, line 5525
09:58:46     INFO -  [959] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-in-osx64-d-00000000000000000/build/ipc/glue/MessageChannel.cpp, line 1532
09:58:46     INFO -  [959] ###!!! ASSERTION: Cannot call AnnotateCrashReport in child processes from non-main thread.: 'Error', file /builds/slave/m-in-osx64-d-00000000000000000/build/toolkit/crashreporter/nsExceptionHandler.cpp, line 1709
09:58:46     INFO -  NS_DebugBreak [xpcom/base/nsDebugImpl.cpp:418]
09:58:46     INFO -  mozilla::ipc::MessageChannel::OnChannelErrorFromLink() [ipc/glue/MessageChannel.cpp:1534]
09:58:46     INFO -  mozilla::ipc::ProcessLink::OnChannelError() [obj-firefox/dist/include/mozilla/Monitor.h:42]
09:58:46     INFO -  IPC::Channel::ChannelImpl::OnFileCanReadWithoutBlocking(int) [ipc/chromium/src/chrome/common/ipc_channel_posix.cc:856]
09:58:46     INFO -  event_base_loop [ipc/chromium/src/third_party/libevent/event.c:1355]
09:58:46     INFO -  base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) [ipc/chromium/src/base/message_pump_libevent.cc:332]
09:58:46     INFO -  MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:504]
09:58:46     INFO -  base::Thread::ThreadMain() [ipc/chromium/src/base/thread.cc:171]
09:58:46     INFO -  ThreadFunc [ipc/chromium/src/base/platform_thread_posix.cc:39]
09:58:46     INFO -  libSystem.B.dylib + 0x39fd6
09:58:46     INFO -  [959] ###!!! ASSERTION: Cannot call AnnotateCrashReport in child processes from non-main thread.: 'Error', file /builds/slave/m-in-osx64-d-00000000000000000/build/toolkit/crashreporter/nsExceptionHandler.cpp, line 1659
09:58:46     INFO -  NS_DebugBreak [obj-firefox/dist/include/nsTSubstring.h:95]
09:58:46     INFO -  mozilla::ipc::MessageChannel::OnChannelErrorFromLink() [ipc/glue/MessageChannel.cpp:1534]
09:58:46     INFO -  mozilla::ipc::ProcessLink::OnChannelError() [obj-firefox/dist/include/mozilla/Monitor.h:42]
09:58:46     INFO -  IPC::Channel::ChannelImpl::OnFileCanReadWithoutBlocking(int) [ipc/chromium/src/chrome/common/ipc_channel_posix.cc:856]
09:58:46     INFO -  event_base_loop [ipc/chromium/src/third_party/libevent/event.c:1355]
09:58:46     INFO -  base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) [ipc/chromium/src/base/message_pump_libevent.cc:332]
09:58:46     INFO -  MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:504]
09:58:46     INFO -  base::Thread::ThreadMain() [ipc/chromium/src/base/thread.cc:171]
09:58:46     INFO -  ThreadFunc [ipc/chromium/src/base/platform_thread_posix.cc:39]
09:58:46     INFO -  libSystem.B.dylib + 0x39fd6
09:58:46     INFO -  mozilla::ipc::ProcessLink::OnChannelError() [obj-firefox/dist/include/mozilla/Monitor.h:42]
09:58:46     INFO -  IPC::Channel::ChannelImpl::OnFileCanReadWithoutBlocking(int) [ipc/chromium/src/chrome/common/ipc_channel_posix.cc:856]
09:58:46     INFO -  event_base_loop [ipc/chromium/src/third_party/libevent/event.c:1355]
09:58:46     INFO -  base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) [ipc/chromium/src/base/message_pump_libevent.cc:332]
09:58:46     INFO -  MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:504]
09:58:46     INFO -  base::Thread::ThreadMain() [ipc/chromium/src/base/thread.cc:171]
09:58:46     INFO -  ThreadFunc [ipc/chromium/src/base/platform_thread_posix.cc:39]
09:58:46     INFO -  libSystem.B.dylib + 0x39fd6
09:58:46     INFO -  [959] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-in-osx64-d-00000000000000000/build/ipc/glue/MessageChannel.cpp, line 1532
09:58:46     INFO -  Hit MOZ_CRASH() at /builds/slave/m-in-osx64-d-00000000000000000/build/memory/mozalloc/mozalloc_abort.cpp:30
09:58:48     INFO -  TEST-INFO | Main app process: killed by SIGHUP
09:58:48  WARNING -  TEST-UNEXPECTED-FAIL | Shutdown | Exited with code 1 during test run
09:58:48     INFO -  INFO | automation.py | Application ran for: 0:10:50.408632
09:58:48     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/gp/gp6E0Yo7GAOF8RNmVxgKMU+++-k/-Tmp-/tmpgA3yGCpidlog
09:59:09  WARNING -  PROCESS-CRASH | Shutdown | application crashed [@ mozilla::FramePropertyTable::Get(nsIFrame const*, mozilla::FramePropertyDescriptor const*, bool*)]
09:59:09     INFO -  Crash dump filename: /var/folders/gp/gp6E0Yo7GAOF8RNmVxgKMU+++-k/-Tmp-/tmpYFmt19.mozrunner/minidumps/075B8990-797F-4ED3-A1AB-C23045C3C66C.dmp
09:59:09     INFO -  Operating system: Mac OS X
09:59:09     INFO -                    10.6.8 10K549
09:59:09     INFO -  CPU: amd64
09:59:09     INFO -       family 6 model 23 stepping 10
09:59:09     INFO -       2 CPUs
09:59:09     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
09:59:09     INFO -  Crash address: 0x56e00008
09:59:09     INFO -  Thread 0 (crashed)
09:59:09     INFO -   0  XUL!mozilla::FramePropertyTable::Get(nsIFrame const*, mozilla::FramePropertyDescriptor const*, bool*) [FramePropertyTable.h:ebac3a17de53 : 184 + 0x0]
09:59:09     INFO -      rbx = 0x0000000106b297d0   r12 = 0x000000015c56fd20
09:59:09     INFO -      r13 = 0x00000001213c90e0   r14 = 0x0000000000000000
09:59:09     INFO -      r15 = 0x00000001213c90e0   rip = 0x0000000103b08350
09:59:09     INFO -      rsp = 0x00007fff5fbfe0b0   rbp = 0x00007fff5fbfe0d0
09:59:09     INFO -      Found by: given as instruction pointer in context
09:59:09     INFO -   1  XUL!nsContainerFrame::DestroyFrom(nsIFrame*) [nsContainerFrame.cpp:ebac3a17de53 : 178 + 0x13]
09:59:09     INFO -      rbx = 0x000000015c56fd20   r12 = 0x000000011b7b0808
09:59:09     INFO -      r13 = 0x00000001213c90e0   r14 = 0x000000012bbd0450
09:59:09     INFO -      r15 = 0x000000015c56fd20   rip = 0x0000000103bbd04f
09:59:09     INFO -      rsp = 0x00007fff5fbfe0e0   rbp = 0x00007fff5fbfe110
09:59:09     INFO -      Found by: call frame info
09:59:09     INFO -   2  XUL!nsFrameList::DestroyFramesFrom(nsIFrame*) [nsFrameList.cpp:ebac3a17de53 : 54 + 0xb]
09:59:09     INFO -      rbx = 0x000000015c56fd20   r12 = 0x000000011b7b0808
09:59:09     INFO -      r13 = 0x00000001003a7338   r14 = 0x000000012bbd0450
09:59:09     INFO -      r15 = 0x000000012bbd1350   rip = 0x0000000103c126e7
09:59:09     INFO -      rsp = 0x00007fff5fbfe120   rbp = 0x00007fff5fbfe140
09:59:09     INFO -      Found by: call frame info
09:59:09     INFO -   3  XUL!nsContainerFrame::DestroyFrom(nsIFrame*) [nsContainerFrame.cpp:ebac3a17de53 : 201 + 0xb]
09:59:09     INFO -      rbx = 0x000000012bbd12f0   r12 = 0x000000011b7b0808
09:59:09     INFO -      r13 = 0x00000001003a7338   r14 = 0x000000012bbd0450
09:59:09     INFO -      r15 = 0x000000012bbd12f0   rip = 0x0000000103bbcfef
09:59:09     INFO -      rsp = 0x00007fff5fbfe150   rbp = 0x00007fff5fbfe180
09:59:09     INFO -      Found by: call frame info
09:59:09     INFO -   4  XUL!nsFrameList::DestroyFramesFrom(nsIFrame*) [nsFrameList.cpp:ebac3a17de53 : 54 + 0xb]
09:59:09     INFO -      rbx = 0x000000012bbd12f0   r12 = 0x000000011b7b0808
09:59:09     INFO -      r13 = 0x00000001003a7338   r14 = 0x000000012bbd0450
09:59:09     INFO -      r15 = 0x000000012bbd11e8   rip = 0x0000000103c126e7
09:59:09     INFO -      rsp = 0x00007fff5fbfe190   rbp = 0x00007fff5fbfe1b0
09:59:09     INFO -      Found by: call frame info
Created attachment 8447940 [details]
relevant part of the Full Log
SVGDocumentWrapper::DestroyViewer() in the stack might help limiting
the possible causes.
Severity: normal → critical
> 09:58:48     INFO -  TEST-INFO | Main app process: killed by SIGHUP

Maybe that is the cause?
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1010666
You need to log in before you can comment on or make changes to this bug.