Make contextmenu/menu telemetry more consistent

RESOLVED FIXED in Firefox 31

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: liuche, Assigned: liuche)

Tracking

(Blocks 1 bug)

Trunk
Firefox 33
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox31 fixed, firefox32 fixed, firefox33 fixed)

Details

Attachments

(1 attachment, 3 obsolete attachments)

* Add telemetry for paste and copyurl should always send an ACTION

* site_settings and subscribe should use the VERSION.SDK_INT check since they are on the Page menu for newer OS
mfinkle, you mentioned in bug 1007130 that you wanted to switch over the pasteandgo item to ACTION, but I think that gives us less information than LOAD_URL. If we do that, I would be inclined to update the TelemetryContract action to loadurl.2 (because we're removing pasteandgo from loadurl.1, and adding it to action.1).
Flags: needinfo?(mark.finkle)
Assignee: nobody → liuche
Status: NEW → ASSIGNED
(In reply to Chenxia Liu [:liuche] from comment #1)
> mfinkle, you mentioned in bug 1007130 that you wanted to switch over the
> pasteandgo item to ACTION, but I think that gives us less information than
> LOAD_URL. If we do that, I would be inclined to update the TelemetryContract
> action to loadurl.2 (because we're removing pasteandgo from loadurl.1, and
> adding it to action.1).

I would definitely keep the LOAD_URL event, but also add an ACTION too. We already have more than a few places where two or more telemetry probes are fired for the same situation.
Flags: needinfo?(mark.finkle)
I also added the telemetry for the action bar. This uses the titles of the action bar buttons, which are not really in the same format as our other probes. Have another patch that adds the probes in JS, which is less clean because you have to do it for ever item, but the extras are consistent with what we've been using.
Attachment #8445541 - Attachment is obsolete: true
Attachment #8446030 - Flags: review?(mark.finkle)
This patch makes it so we use extras like:
- "search" instead of "Google Search"
- "select_all" instead of "Select All"
- "call" instead of "Call"
& etc.
Attachment #8446040 - Flags: feedback?(mark.finkle)
Comment on attachment 8446040 [details] [diff] [review]
Optional part 2: Add actionbar probes in JS, not Java

I like this patch too.
Attachment #8446040 - Flags: feedback?(mark.finkle) → review+
Comment on attachment 8446030 [details] [diff] [review]
Patch: Add missing telemetry v2

Let's do the optional part too.
Attachment #8446030 - Flags: review?(mark.finkle) → review+
Target Milestone: --- → Firefox 33
[Approval Request Comment]
Bug caused by (feature/regressing bug #): Incomplete Telemetry from bug 1004889
User impact if declined: No telemetry on some menu items for Aurora and beta users
Testing completed (on m-c, etc.): local, baking on nightly
Risk to taking this patch (and alternatives if risky): very low, adding telemetry probes
String or IDL/UUID changes made by this patch: none

Carrying over r+ for combined patch.
Attachment #8446030 - Attachment is obsolete: true
Attachment #8446040 - Attachment is obsolete: true
Attachment #8446201 - Flags: review+
Attachment #8446201 - Flags: approval-mozilla-beta?
Attachment #8446201 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/9ef3bd020eed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attachment #8446201 - Flags: approval-mozilla-beta?
Attachment #8446201 - Flags: approval-mozilla-beta+
Attachment #8446201 - Flags: approval-mozilla-aurora?
Attachment #8446201 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.