Invalid behavior for address with URLs without TLD

RESOLVED DUPLICATE of bug 690307

Status

()

RESOLVED DUPLICATE of bug 690307
4 years ago
4 years ago

People

(Reporter: daziplqa, Unassigned)

Tracking

30 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

1. Open URL like this (no TLD and the link contains spaces)

http://my_internal_app_wihtout_tld/some url with space/

2. after the page opened, Come to address bar and try to press enter again.



Actual results:

Firefox will go to Google search instead of re-opening the page


Expected results:

Re-open the link again

Comment 1

4 years ago
I can reproduce this. The issue seems to be that we remove the protocol from the text in the location bar, and so you'd need to re-enter it all the time. This is clearly suboptimal.

Seems like we shouldn't remove the protocol in cases where we know that the defaulturifixup service will switch to doing a keyword search. Jared, does that seem right to you?
Status: UNCONFIRMED → NEW
Component: Untriaged → Location Bar
Ever confirmed: true
Flags: needinfo?(jaws)
Flags: firefox-backlog+
OS: Windows 7 → All
Hardware: x86_64 → All
See Also: → bug 693808
This seems like exposing an implementation detail to work around our fixup code. In bug 693808 there is discussion about creating a whitelist of domains that should not be directed to a search page. We should follow that approach instead.
Flags: needinfo?(jaws)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: firefox-backlog+
Resolution: --- → DUPLICATE
See Also: bug 693808
Duplicate of bug: 690307
You need to log in before you can comment on or make changes to this bug.