No crash/timeout information with mochitest on the B2G emulator

RESOLVED INVALID

Status

defect
RESOLVED INVALID
5 years ago
Last year

People

(Reporter: akachkach, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
Steps to reproduce:

* Apply these changes to mozilla-central (to add a timeout and a MOZ_CRASH): https://hg.mozilla.org/try/rev/5e610705e7b0
* Execute mochitests on the B2G emulator.

We don't get a stack trace and TEST-UNEXPECTED-FAIL messages like with other platforms, only a "Return code: 1" message. It seems like the "onTimeout" function in the ProcessHandler isn't executed.

Try push: https://tbpl.mozilla.org/?tree=Try&rev=5e610705e7b0
There is related work for Android, happening in bug 1027802.
See Also: → 1027802
This is probably the cause of my try run failure here, on the M14:

https://tbpl.mozilla.org/?tree=Try&rev=cf5129c94b32

One of the 3 failures in the log is highlighted (the "Return code: 1" line after the "ps") but the other two I have no idea about.  That might be two separate issues: the lack of the stack trace, and the two missing highlighted error lines.
Mass resolving of B2G mochitest bugs.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.