drop down select menus don't reposition when side tabs open

RESOLVED DUPLICATE of bug 110801

Status

()

Core
Layout: Form Controls
P2
normal
RESOLVED DUPLICATE of bug 110801
16 years ago
16 years ago

People

(Reporter: Chris Lea, Assigned: rods (gone))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011002
BuildID:    M0.9.4

If you go to a page with the sidebar collapsed, and you look at the selections
in a pulldown menu, then open the sidebar and look at the selections again, they
don't reposition. Meaning, they are painted where they were at first.

Reproducible: Always
Steps to Reproduce:
1. Go to www.cnn.com with your sidebar collapsed so you can't see any tabs.

2. Scroll down the page until you see the two selection drop downs on the left
hand side.

3. Click on one of them to see the choices, then click again to close the drop down.

4. Open up the sidebar so you can see the tabs.

5. Click on the dropdown menu again.

Actual Results:  The choices get painted in the sidebar.

Expected Results:  The choices should show up under the menu selector.

The exact opposite thing happens if you go to the page with the sidebar expanded
initially, and then close it. The choices get painted to the right of where
they're supposed to be.

I see the same behaviour at my.yahoo.com and newstoday.com.

Comment 1

16 years ago
Yessiree - I see the behavior, on Linux only. Probably a view positioning
problem? Over to form controls.
Assignee: attinasi → rods
Status: UNCONFIRMED → NEW
Component: Layout → HTML Form Controls
Ever confirmed: true
QA Contact: petersen → madhur
(Reporter)

Comment 2

16 years ago
Created attachment 52169 [details]
Simple testcase
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2
(Assignee)

Updated

16 years ago
Priority: -- → P2
Target Milestone: mozilla1.2 → Future

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 110801 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.