Intermittent TEST-UNEXPECTED-FAIL | browser_bug462673.js | application terminated with exit code 1 | PROCESS-CRASH | browser_bug462673.js | application crashed [@ GCGraphBuilder::AddNode(void*, nsCycleCollectionParticipant*)]

RESOLVED DUPLICATE of bug 1010666

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1010666
3 years ago
3 years ago

People

(Reporter: nigelb, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Rev4 MacOSX Snow Leopard 10.6 mozilla-central debug test mochitest-browser-chrome-1 on 2014-06-25 18:25:17 PDT for push 6401390a005d

slave: t-snow-r4-0058

https://tbpl.mozilla.org/php/getParsedLog.php?id=42488920&tree=Mozilla-Central

18:28:47     INFO -  Assertion failure: result->mParticipant == aParticipant (nsCycleCollectionParticipant shouldn't change!), at /builds/slave/m-cen-osx64-d-0000000000000000/build/xpcom/base/nsCycleCollector.cpp:2177
18:28:47     INFO -  GCGraphBuilder::NoteXPCOMChild(nsISupports*) [obj-firefox/dist/include/nsTSubstring.h:95]
18:28:47     INFO -  mozilla::dom::FragmentOrElement::cycleCollection::Traverse(void*, nsCycleCollectionTraversalCallback&) [content/base/src/FragmentOrElement.cpp:1872]
18:28:47     INFO -  GCGraphBuilder::Traverse(PtrInfo*) [xpcom/base/nsCycleCollector.cpp:2193]
18:28:47     INFO -  nsCycleCollector::MarkRoots(js::SliceBudget&) [obj-firefox/dist/include/nsAutoPtr.h:165]
18:28:47     INFO -  nsCycleCollector::Collect(ccType, js::SliceBudget&, nsICycleCollectorListener*) [obj-firefox/dist/include/js/SliceBudget.h:55]
18:28:47     INFO -  nsCycleCollector_collectSlice(long long) [obj-firefox/dist/include/GeckoProfilerImpl.h:370]
18:28:47     INFO -  nsJSContext::RunCycleCollectorSlice() [dom/base/nsJSEnvironment.cpp:1951]
18:28:47     INFO -  nsTimerImpl::Fire() [xpcom/threads/nsTimerImpl.cpp:634]
18:28:47     INFO -  nsTimerEvent::Run() [xpcom/threads/nsTimerImpl.cpp:711]
18:28:47     INFO -  nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:766]
18:28:47     INFO -  NS_ProcessPendingEvents(nsIThread*, unsigned int) [xpcom/glue/nsThreadUtils.cpp:210]
18:28:47     INFO -  nsBaseAppShell::NativeEventCallback() [widget/xpwidgets/nsBaseAppShell.cpp:99]
18:28:47     INFO -  nsAppShell::ProcessGeckoEvents(void*) [widget/cocoa/nsAppShell.mm:373]
18:28:47     INFO -  CoreFoundation + 0x4e2ad
18:28:47     INFO -  CoreFoundation + 0x4c5f9
18:28:47     INFO -  CoreFoundation + 0x4bdbf
18:28:47     INFO -  HIToolbox + 0x2e7ee
18:28:47     INFO -  HIToolbox + 0x2e5f3
18:28:47     INFO -  HIToolbox + 0x2e4ac
18:28:47     INFO -  AppKit + 0x43eb2
18:28:47     INFO -  -AppKit + 0x43801
18:28:47     INFO -  -[GeckoNSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] [widget/cocoa/nsAppShell.mm:127]
18:28:47     INFO -  -AppKit + 0x968f
18:28:47     INFO -  nsAppShell::Run() [obj-firefox/dist/include/nsCOMPtr.h:662]
18:28:47     INFO -  nsAppStartup::Run() [toolkit/components/startup/nsAppStartup.cpp:278]
18:28:47     INFO -  XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:4013]
18:28:47     INFO -  XREMain::XRE_main(int, char**, nsXREAppData const*) [toolkit/xre/nsAppRunner.cpp:4084]
18:28:47     INFO -  XRE_main [toolkit/xre/nsAppRunner.cpp:4298]
18:28:47     INFO -  main [browser/app/nsBrowserApp.cpp:282]
18:28:49     INFO -  TEST-INFO | Main app process: killed by SIGHUP
18:28:49  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug462673.js | application terminated with exit code 1
18:28:49     INFO -  INFO | runtests.py | Application ran for: 0:01:53.706308
18:28:49     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/gp/gp6E0Yo7GAOF8RNmVxgKMU+++-k/-Tmp-/tmpZMdO6vpidlog
18:29:10  WARNING -  PROCESS-CRASH | chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug462673.js | application crashed [@ GCGraphBuilder::AddNode(void*, nsCycleCollectionParticipant*)]
18:29:10     INFO -  Crash dump filename: /var/folders/gp/gp6E0Yo7GAOF8RNmVxgKMU+++-k/-Tmp-/tmpQanxbj.mozrunner/minidumps/26B087C7-A65F-4043-AA57-1B253D217845.dmp
18:29:10     INFO -  Operating system: Mac OS X
18:29:10     INFO -                    10.6.8 10K549
18:29:10     INFO -  CPU: amd64
18:29:10     INFO -       family 6 model 23 stepping 10
18:29:10     INFO -       2 CPUs
18:29:10     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
18:29:10     INFO -  Crash address: 0x0
18:29:10     INFO -  Thread 0 (crashed)
18:29:10     INFO -   0  XUL!GCGraphBuilder::AddNode(void*, nsCycleCollectionParticipant*) [nsCycleCollector.cpp:6401390a005d : 569 + 0x0]
18:29:10     INFO -      rbx = 0x00007fff710922f8   r12 = 0x00000001553419a0
18:29:10     INFO -      r13 = 0x0000000101c6e400   r14 = 0x0000000124976f80
18:29:10     INFO -      r15 = 0x0000000106b3e800   rip = 0x0000000101c5b638
18:29:10     INFO -      rsp = 0x00007fff5fbfc7b0   rbp = 0x00007fff5fbfc7d0
18:29:10     INFO -      Found by: given as instruction pointer in context
18:29:10     INFO -   1  XUL!GCGraphBuilder::NoteChild(void*, nsCycleCollectionParticipant*, nsCString) [nsCycleCollector.cpp:6401390a005d : 2092 + 0x4]
18:29:10     INFO -      rbx = 0x0000000121d5efc0   r12 = 0x00007fff5fbfc818
18:29:10     INFO -      r13 = 0x0000000101c6e400   r14 = 0x00007fff5fbfc818
18:29:10     INFO -      r15 = 0x0000000124976f80   rip = 0x0000000101c6e419
18:29:10     INFO -      rsp = 0x00007fff5fbfc7e0   rbp = 0x00007fff5fbfc800
18:29:10     INFO -      Found by: call frame info
18:29:10     INFO -   2  XUL!GCGraphBuilder::NoteXPCOMChild(nsISupports*) [nsCycleCollector.cpp:6401390a005d : 2284 + 0xe]
18:29:10     INFO -      rbx = 0x0000000124976f80   r12 = 0x00007fff5fbfc818
18:29:10     INFO -      r13 = 0x0000000101c6e400   r14 = 0x0000000121d5efc0
18:29:10     INFO -      r15 = 0x0000000106b3e800   rip = 0x0000000101c5bacb
18:29:10     INFO -      rsp = 0x00007fff5fbfc810   rbp = 0x00007fff5fbfc870
18:29:10     INFO -      Found by: call frame info
18:29:10     INFO -   3  XUL!mozilla::dom::FragmentOrElement::cycleCollection::Traverse(void*, nsCycleCollectionTraversalCallback&) [FragmentOrElement.cpp:6401390a005d : 1874 + 0x4]
18:29:10     INFO -      rbx = 0x0000000000000000   r12 = 0x0000000000000004
18:29:10     INFO -      r13 = 0x0000000121d5efc0   r14 = 0x00000001251b79c0
18:29:10     INFO -      r15 = 0x0000000105d5a04a   rip = 0x000000010346b15f
18:29:10     INFO -      rsp = 0x00007fff5fbfc880   rbp = 0x00007fff5fbfce20
18:29:10     INFO -      Found by: call frame info
18:29:10     INFO -   4  XUL!GCGraphBuilder::Traverse(PtrInfo*) [nsCycleCollector.cpp:6401390a005d : 2193 + 0xa]
18:29:10     INFO -      rbx = 0x0000000155443d88   r12 = 0x0000000107202000
18:29:10     INFO -      r13 = 0x0000000105ddaf68   r14 = 0x00007fff5fbfcef8
18:29:10     INFO -      r15 = 0x0000000155443d88   rip = 0x0000000101c5b67c
18:29:10     INFO -      rsp = 0x00007fff5fbfce30   rbp = 0x00007fff5fbfce40
18:29:10     INFO -      Found by: call frame info
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1010666
You need to log in before you can comment on or make changes to this bug.