Closed Bug 1030622 Opened 6 years ago Closed 1 year ago

Second search searches initial text with new hightlighting

Categories

(Firefox :: PDF Viewer, defect, P3)

30 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- verified

People

(Reporter: pepijndevos, Assigned: Snuffleupagus)

References

Details

(Keywords: regression, ux-consistency, Whiteboard: [pdfjs-c-ff-integration])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Open https://wiki.hexonet.net/images/0/01/DOMAIN_API_Reference.pdf
ctrl+f domain
select a word
ctrl+c ctrl+f


Actual results:

Pressing ctrl+g goes to the next occurrence of domain, with a highlight that is as long as the selected word.


Expected results:

It should have searched for the selected word.
Component: Untriaged → PDF Viewer
OS: Mac OS X → All
Hardware: x86 → All
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

Reproduced on latest Nightly 20140624030200, set as New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/a76c1f4c4112
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121017110913
Bad:
http://hg.mozilla.org/mozilla-central/rev/5142bbd4da12
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121017191029
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a76c1f4c4112&tochange=5142bbd4da12



Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e78db739d589
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121017121312
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d896a7f47e02
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121017123513
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e78db739d589&tochange=d896a7f47e02

Regressed by:
af98d67916ad	Ryan VanderMeulen — Bug 801280 - Update pdf.js to version 0.6.39. r=dtownsend
Blocks: 801280
Keywords: regression
Version: 30 Branch → 19 Branch
I'm sorry I cannot reproduce the issue with the STR in the comment 0. Please provide more detailed instructions. The regression windows does not look valid as well -- the bug adds support for PDF find support (before that viewer could only search only pages that are visible). Based on initially specified FF version 30 and vague STR, I can assume that we are talking about bug 1006714 (which will be fixed in FF32).
Flags: needinfo?(pepijndevos)
Version: 19 Branch → 30 Branch
This bug happened since Firefox19.
And reproduced on latest Nightly.
https://hg.mozilla.org/mozilla-central/rev/de8c0f0e74a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140728030201

Steps to reproduce:

1. Open https://wiki.hexonet.net/images/0/01/DOMAIN_API_Reference.pdf
2. Ctrl+f
3. Type 'domain' without quotation
   --- 'DOMAIN' is highlighted as expected
4. Select a word (e.g. API) by mouse drag
5. Ctrl+c to copy selected text to clipboard
6. Ctrl+f
   --- Now, clipboard text('API') copied into the find field
7. Ctrl+G to find next

Actual Results
Firefox trying to find "dom" instead the find field text "api"

Expected Results
Firefox should find "api" which is current text in the find field
Okay, I was trying to replicate the same steps on Mac OSX -- find bar does not work the same way there. Cmd+F shall just pull the previous search term.
Flags: needinfo?(pepijndevos)
Keywords: ux-consistency
TESTING
Linux Mint 17
Firefox for Ubuntu, 34.0a1 (2014-07-29)

Confirmed by following steps in Comment 4
Priority: -- → P3
Whiteboard: [pdfjs-c-ff-integration]
Status: NEW → RESOLVED
Closed: 1 year ago
Depends on: 1506596
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Assignee: nobody → jonas.jenwald
Flags: qe-verify+

I have managed to reproduce this issue using Firefox 62.0a1 (BuildId:20180606220131).

This issue is verified fixed using Firefox 65.0b9 (BuildId:20190107180200) on Windows 10 64bit and Ubuntu 16.04 64bit.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.