Closed Bug 1030623 Opened 7 years ago Closed 7 years ago

[Dialer] No space between text and border when Contact with long name and number matching hits

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 fixed, b2g-v2.1 affected)

VERIFIED FIXED
2.1 S1 (1aug)
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed
b2g-v2.1 --- affected

People

(Reporter: ericcc, Assigned: paco)

References

Details

Attachments

(5 files)

Attached image CallLogMatching.png
### STR
1. Have an entry with long name in Contacts.
2. Type the number in Dial pad until only 1 match comes up.

### Actual 
The space between screen border and text is too small, not the same width as on the left side.

### Reproduce rate
100% on v2.0
Not happening on v1.4

### Version
Flame v2.0 aurora 
Gaia      c478c43229883cee2afd09c6edb42d29a46cc500
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/8940337ccb5c
BuildID   20140625160200
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
t2m.sw.version=B1TC00011220
Attached image v1.4
blocking-b2g: --- → 2.1?
blocking-b2g: 2.1? → ---
Assignee: nobody → pacorampas
Attached file patch in github
Attachment #8458622 - Flags: review?(anthony)
Attachment #8458622 - Flags: review?(anthony) → review+
Target Milestone: --- → 2.0 S6 (18july)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Paco, please contact Mari Ángeles in case asking for approval to land the patch in v2.0 and v1.4 is needed ;) Thanks!
Flags: needinfo?(pacorampas)
Flags: needinfo?(oteo)
Ups, sorry! It seems it does not affect v1.4 and v2.0 is the only one affected ;)
Not feedback received yet about if it's too late for the approval to 2.0... let's try it, very small and css patch.
Flags: needinfo?(oteo)
Comment on attachment 8458622 [details] [review]
patch in github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Visual refresh
[User impact] if declined: incorrect UI
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): no risk
[String changes made]: none
Attachment #8458622 - Flags: approval-gaia-v2.0?
Flags: needinfo?(pacorampas)
FWIW, I'm ok uplifting this.
Attachment #8458622 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
(In reply to Germán Toro del Valle from comment #4)
> Landed in master:
> https://github.com/mozilla-b2g/gaia/commit/
> be4a76145a093e66bd70f4cfd8f82323a9a50a3c

Hi German, I still can reproduce this on v2.1, could you check that, thank you.

FAIL - Flame v2.1
Gaia      15c84c943e41ad834640a45e1e1c2ac804168af7
Gecko     https://hg.mozilla.org/mozilla-central/rev/30907d52c4c2
BuildID   20140723160203
Version   34.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC0001122

OK - Flame v2.0
Gaia      91986777d0942b63e37fbfeec19d69d6176d6d74
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/392054b2e899
BuildID   20140723160206
Version   32.0
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220
Flags: needinfo?(gtorodelvalle)
Attached image v2.1_Offcenter.png
When the text goes outside the edge, you can drag the upper part and move the whole screen.
https://www.youtube.com/watch?v=1x-7zmPZ8nQ
Passing the need-info to Paco since he proposed the patch which should have solved the issue ;) See comment 11, Paco, please.
Flags: needinfo?(gtorodelvalle) → needinfo?(pacorampas)
The issue isn't related with this bug. But I can fix it. I am opening other bug to fix it. Thanks Eric.
Flags: needinfo?(pacorampas)
Hi Paco, Is this patch working on v2.1?
https://github.com/mozilla-b2g/gaia/commit/be4a76145a093e66bd70f4cfd8f82323a9a50a3c
I still got something like the text goes outside the screen..
https://bugzilla.mozilla.org/attachment.cgi?id=8461344

(In reply to Paco Rampas [:paco] from comment #14)
> The issue isn't related with this bug. But I can fix it. I am opening other
> bug to fix it. Thanks Eric.
Flags: needinfo?(pacorampas)
The issue is still on master, but the issue that you comment isn't causing for this bug. I have opened and fix the horizontal overflow scroll on this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1043318

Could you check if the description of bug is ok?
Flags: needinfo?(pacorampas)
Thanks for checking, so the issue is still there, I just reopen this bug.
And as for the 1043318, if this 1030623 is fixed, maybe the side effort goes away.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See Also: → 1043318
(In reply to Eric Chang [:ericcc] [:echang] from comment #17)
> Thanks for checking, so the issue is still there, I just reopen this bug.
> And as for the 1043318, if this 1030623 is fixed, maybe the side effort goes
> away.

Hello, this bug 1043318 has solved the issue of comment 12. Could we close this bug?
setting qawanted, so Eric can verify it, thanks!
Keywords: qawanted
I'm not sure the Qa-wanted tag will get his attention. Unless you were asking us to verify it as well, I'd go with a NI instead.
Flags: needinfo?(echang)
Keywords: qawanted
Verified on flame v2.1
Gaia      19bf9795263e2ccc15d824a52ebf23c2670fa9b9
Gecko     https://hg.mozilla.org/mozilla-central/rev/7f81be7db528
BuildID   20140804160542
Version   34.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220
Flags: needinfo?(echang)
(In reply to Eric Chang [:ericcc] [:echang] from comment #21)
> Verified on flame v2.1
> Gaia      19bf9795263e2ccc15d824a52ebf23c2670fa9b9
> Gecko     https://hg.mozilla.org/mozilla-central/rev/7f81be7db528
> BuildID   20140804160542
> Version   34.0a1
> ro.build.version.incremental=109
> ro.build.date=Mon Jun 16 16:51:29 CST 2014
> B1TC00011220

Is it verified working as expected, or still not working? Can we close this bug?
Flags: needinfo?(echang)
changing state..
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(echang)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.