[Dialer] Text not aligned when matches are more than 1 if contact has long name

RESOLVED FIXED in 2.1 S4 (12sep)

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: echang, Assigned: jorgep)

Tracking

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 unaffected, b2g-v2.0 affected)

Details

(Whiteboard: [priority][planned-sprint][in-sprint=v2.1-S3])

Attachments

(5 attachments)

(Reporter)

Description

5 years ago
Created attachment 8446390 [details]
MatchingResults.png

### STR
1. Have an entry with long name in Contacts.
2. Have another entry with number that at least 3 digits are the same as in Step1.
3. Type the number in Dial pad, more than 2 contacts should show up.
4. Tap on the 3 dots.


### Actual 
Text not align.
See MatchingResults.png 

### Reproduce rate
100% on v2.0
Not happening if the contact's name is short on v2.0
see MatchingResultsShortName.png
Not happening on v1.4

### Version
Flame v2.0 aurora 
Gaia      c478c43229883cee2afd09c6edb42d29a46cc500
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/8940337ccb5c
BuildID   20140625160200
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
t2m.sw.version=B1TC00011220
(Reporter)

Comment 1

5 years ago
Created attachment 8446391 [details]
MatchingResultsShortName.png  v2.0
(Reporter)

Updated

5 years ago
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
(Reporter)

Comment 2

5 years ago
Created attachment 8446395 [details]
v1.4 not happening
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 2.1?
Blocks: 1036516
most-wanted but not blocking
blocking-b2g: 2.1? → backlog
Whiteboard: [priority]
(Assignee)

Updated

5 years ago
Assignee: nobody → jpruden92
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
Created attachment 8475827 [details]
[patch] Text not aligned when matches are more than 1 if contact has long name.png

Here is the result of the patch
(Assignee)

Comment 5

5 years ago
Created attachment 8475829 [details]
23077.html
Attachment #8475829 - Flags: review?(anthony)
(Assignee)

Updated

5 years ago
Target Milestone: --- → 2.1 S3 (29aug)
Whiteboard: [priority] → [priority][planned-sprint][in-sprint=v2.1-S3]
Target Milestone: 2.1 S3 (29aug) → 2.1 S4 (12sep)
Comment on attachment 8475829 [details]
23077.html

Sorry, this patch bitrotted since you wrote it because the code is now shared with the Emergency Call app. Can you rebase and check that it works well with ICE contacts?
Attachment #8475829 - Flags: review?(anthony)
(Assignee)

Comment 7

4 years ago
Comment on attachment 8475829 [details]
23077.html

Hello Anthony, I have uploaded the patch. Now it works with ICE contacts. Thanks!
Attachment #8475829 - Flags: review?(anthony)
Comment on attachment 8475829 [details]
23077.html

Thanks and sorry again for not reviewing this sooner.
Attachment #8475829 - Flags: review?(anthony) → review+
https://github.com/mozilla-b2g/gaia/commit/02af26b5d19d199c5a0b0cac23504970e4d10150
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.