The orange animation bar gets stuck when the pull to refresh action is performed slowly

RESOLVED WONTFIX

Status

()

Firefox for Android
General
P5
normal
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: Flaviu Cos, Assigned: mcomella)

Tracking

({reproducible})

Trunk
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox30 unaffected, firefox31 unaffected, firefox32 wontfix, firefox33 wontfix, firefox34 wontfix, firefox35 wontfix, firefox36 wontfix, firefox37 wontfix, firefox38 wontfix, firefox39 wontfix, firefox40 wontfix, firefox41 wontfix, firefox42 wontfix, firefox43 unaffected, fennec+)

Details

(Reporter)

Description

3 years ago
Environment: 
Device: Google Nexus 10 (Android 4.4.2);
Build: Nightly 33.0a1 (2014-06-25);

Steps to reproduce:
1. Install Wikipedia panel or Instagram panel;
2. Go to the installed panel;
3. Pull down to refresh;
4. Pull down slowly and release the tap when the orange bar starts to grow.

Expected result:
The update animation is successfully displayed.

Actual result:
The orange animation bar gets stuck when the pull to refresh action is performed slowly.

Notes:
Please check the video: http://youtu.be/66DIT9RyZH4
(Reporter)

Updated

3 years ago
status-firefox30: --- → unaffected
status-firefox31: --- → unaffected
status-firefox32: --- → affected
status-firefox33: --- → affected

Updated

3 years ago
tracking-fennec: --- → ?
Assignee: nobody → michael.l.comella
tracking-fennec: ? → 32+
Sounds a little edge case
(Assignee)

Comment 2

3 years ago
I could not reproduce this on my nexus 4 and I cannot consistently reproduce on my Galaxy Tab 3. Flaviu, do you have any additional suggestions on how to reproduce this?

Also, how frequently do you see this occur? Since it's so difficult to reproduce in my experience, I wonder if it's worth fixing.
Status: NEW → ASSIGNED
(Reporter)

Comment 3

3 years ago
It is easier to reproduce by pulling down slowly and just before you release the touch pull up just a bit.
It is reproducible 1 out of 10 tries.
FWIW, GeckoSwipeRefreshLayout has some fundamental red flags around touch even handling e.g. onTouchEvent() being directly called within onInterceptTouchEvent(), among other things. I'd probably revisit all the customizations done in the original SwipeRefreshLayout code.
tracking-fennec: 32+ → +
(Reporter)

Updated

3 years ago
status-firefox34: --- → affected
Saw this yesterday while simply trying to refresh one of my installed panels. I didn't do anything particular, just pulled down and it got stuck. Looks really bad.
Keywords: reproducible
(Reporter)

Updated

3 years ago
status-firefox35: --- → affected
status-firefox36: --- → affected
filter on [mass-p5]
Priority: -- → P5
(Reporter)

Updated

3 years ago
status-firefox37: --- → affected
(Reporter)

Updated

3 years ago
status-firefox38: --- → affected
(Reporter)

Updated

3 years ago
status-firefox39: --- → affected
(Reporter)

Updated

3 years ago
status-firefox40: --- → affected
(Assignee)

Comment 7

2 years ago
This may be fixed by bug 1183588, when we just use the new support library SwipeRefreshLayout directly, but otherwise I'm not actively working on this.
Assignee: michael.l.comella → nobody
Status: ASSIGNED → NEW
(Assignee)

Comment 8

2 years ago
Soft dep bug 1183588 to see if it's fixed by that bug.
Depends on: 1183588
(Assignee)

Comment 9

2 years ago
Flaviu, can you repro now that bug 1183588 has landed?
Flags: needinfo?(flaviu.cos)
(Reporter)

Comment 10

2 years ago
(In reply to Michael Comella (:mcomella) from comment #9)
> Flaviu, can you repro now that bug 1183588 has landed?

Can not reproduce this issue with the new pull-to-refresh Material Design.
Flags: needinfo?(flaviu.cos)
(Assignee)

Comment 11

2 years ago
Then I'm going to call this unaffected for 43 (when bug 1183588 landed) and WONTFIX otherwise – it's not worth spending the time to fix this in our other builds.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox32: affected → wontfix
status-firefox33: affected → wontfix
status-firefox34: affected → wontfix
status-firefox35: affected → wontfix
status-firefox36: affected → wontfix
status-firefox37: affected → wontfix
status-firefox38: affected → wontfix
status-firefox39: affected → wontfix
status-firefox40: affected → wontfix
status-firefox41: --- → wontfix
status-firefox42: --- → wontfix
status-firefox43: --- → unaffected
Resolution: --- → WONTFIX
(Assignee)

Comment 12

2 years ago
Assigning to myself so if this gets reopened, I'll pay more attention to it.
Assignee: nobody → michael.l.comella
You need to log in before you can comment on or make changes to this bug.