Schedule Android 4.0 Debug reftests and crashtests on all trunk trees and let them ride the trains

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gbrown, Assigned: kmoir)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

+++ This bug was initially created as a clone of Bug #996388 +++

More Android 4.0 Debug tests can now be run on trunk trees:

 - crashtests
 - all plain reftests, R1 ... R8
 - all robocop, rc1 ... rc5

(mochitest-gl, xpcshell and cppunit tests are still not green / not ready for trunk)
(Assignee)

Updated

3 years ago
Assignee: nobody → kmoir
A new robocop failure showed up in recent builds, so robocop is not ready for trunk.

All crashtests and plain reftests are still ready for trunk.
Summary: Schedule Android 4.0 Debug reftests, crashtests, and robocop tests on all trunk trees and let them ride the trains → Schedule Android 4.0 Debug reftests and crashtests on all trunk trees and let them ride the trains
(Assignee)

Comment 2

3 years ago
Created attachment 8458048 [details] [diff] [review]
bug1030753.patch

We don't need to limit by single test suites anymore so we can get rid of a lot of code. Limiting to 31 doesn't apply to branches that Android 4.0 tests run on anymore so we can remove the loop and make the tests specified the default, and then enable all for testing on cedar.
Attachment #8458048 - Flags: review?(pmoore)
(Assignee)

Comment 3

3 years ago
Created attachment 8458049 [details]
bug1030753builder.diff

builder diff
(Assignee)

Comment 4

3 years ago
gbrown: I didn't have time to work on this patch for a few weeks because I was working on the AWS for 2.3 bug.  In any case, the way I wrote this patch this morning is that I enabled the new test suites for all branches since this the old debug loop refers to 31 and all branches that run Android 4.0 tests are now 31 or higher. But should the new tests only be enabled on trunk?  Thought I would ask since this bug is three weeks old.
Flags: needinfo?(gbrown)
Yes, the new tests should only be enabled on trunk, otherwise some test failures will result.

For example, https://hg.mozilla.org/mozilla-central/rev/949639a7ffe8 prevents one such failure, and that just landed 2014-06-26.
Flags: needinfo?(gbrown)
(Assignee)

Comment 6

3 years ago
Comment on attachment 8458048 [details] [diff] [review]
bug1030753.patch

okay pete I have to refactor this so I'll cancel the review while I do that
Attachment #8458048 - Flags: review?(pmoore) → review-
(Assignee)

Updated

3 years ago
Attachment #8458048 - Flags: review-
(Assignee)

Comment 7

3 years ago
Created attachment 8458253 [details] [diff] [review]
bug1030753-2.patch

So this fixes the issue so only the new tests are enabled on trunk and ride the trains
Attachment #8458048 - Attachment is obsolete: true
Attachment #8458253 - Flags: review?(pmoore)
(Assignee)

Comment 8

3 years ago
Created attachment 8458254 [details]
bug1030753builder.diff

new builder diff
Attachment #8458049 - Attachment is obsolete: true
Hey Kim,

I'm really sorry, I haven't managed to do this review today. I can try to look at it on Monday, or if it is urgent, I won't be offended if you throw it to Callek.

Thanks for your patience!
Pete
Working on this now...
So test-masters.sh looks good, as an initial sanity test:

Checking 22 masters...
bm01-tests1-linux32 bm51-tests1-linux64 bm69-tests1-windows bm70-build1 bm75-try1 bm81-build_scheduler bm81-tests_scheduler bm88-tests1-tegra bm89-tests1-panda bm103-tests1-linux bm106-tests1-macosx bm109-tests1-windows bm01-tests1-linux32-universal bm51-tests1-linux64-universal bm69-tests1-windows-universal bm70-build1-universal bm75-try1-universal bm88-tests1-tegra-universal bm89-tests1-panda-universal bm103-tests1-linux-universal bm106-tests1-macosx-universal bm109-tests1-windows-universal
INFO  - creating "bm89-tests1-panda" master
INFO  - created  "bm89-tests1-panda" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm89-tests1-panda
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm89-tests1-panda-universal" master
INFO  - created  "bm89-tests1-panda-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm89-tests1-panda-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm88-tests1-tegra" master
INFO  - created  "bm88-tests1-tegra" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm88-tests1-tegra
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm88-tests1-tegra-universal" master
INFO  - created  "bm88-tests1-tegra-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm88-tests1-tegra-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm75-try1" master
INFO  - created  "bm75-try1" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm75-try1
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm75-try1-universal" master
INFO  - created  "bm75-try1-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm75-try1-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm103-tests1-linux-universal" master
INFO  - created  "bm103-tests1-linux-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm103-tests1-linux-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm103-tests1-linux" master
INFO  - created  "bm103-tests1-linux" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm103-tests1-linux
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm106-tests1-macosx" master
INFO  - created  "bm106-tests1-macosx" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm106-tests1-macosx
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm106-tests1-macosx-universal" master
INFO  - created  "bm106-tests1-macosx-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm106-tests1-macosx-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm81-build_scheduler" master
INFO  - created  "bm81-build_scheduler" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm81-build_scheduler
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm70-build1" master
INFO  - created  "bm70-build1" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm70-build1
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm70-build1-universal" master
INFO  - created  "bm70-build1-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm70-build1-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm01-tests1-linux32" master
INFO  - created  "bm01-tests1-linux32" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm01-tests1-linux32
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm01-tests1-linux32-universal" master
INFO  - created  "bm01-tests1-linux32-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm01-tests1-linux32-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm109-tests1-windows-universal" master
INFO  - created  "bm109-tests1-windows-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm109-tests1-windows-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm109-tests1-windows" master
INFO  - created  "bm109-tests1-windows" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm109-tests1-windows
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm69-tests1-windows-universal" master
INFO  - created  "bm69-tests1-windows-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm69-tests1-windows-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm69-tests1-windows" master
INFO  - created  "bm69-tests1-windows" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm69-tests1-windows
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm51-tests1-linux64" master
INFO  - created  "bm51-tests1-linux64" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm51-tests1-linux64
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm51-tests1-linux64-universal" master
INFO  - created  "bm51-tests1-linux64-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm51-tests1-linux64-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm81-tests_scheduler" master
INFO  - created  "bm81-tests_scheduler" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm81-tests_scheduler
INFO  - TEST-SUMMARY: 22 tested, 0 failed
test_builderPriority
  builderProrityTest
    test_branch_priority ...                                               [OK]
    test_l10n_always_last ...                                              [OK]
    test_release ...                                                       [OK]
    test_release_priority ...                                              [OK]
    test_request_priority ...                                              [OK]
    test_stablity ...                                                      [OK]
    test_timestamp_priority ...                                            [OK]

-------------------------------------------------------------------------------
Ran 7 tests in 0.037s

PASSED (successes=7)
test_slave_allocation
  SlaveCheck
    test_prod_vs_try ...                                                   [OK]
    test_stag_not_in_prod ...                                              [OK]

-------------------------------------------------------------------------------
Ran 2 tests in 0.009s

PASSED (successes=2)
test_builderPriority
  builderProrityTest
    test_branch_priority ...                                               [OK]
    test_l10n_always_last ...                                              [OK]
    test_release ...                                                       [OK]
    test_release_priority ...                                              [OK]
    test_request_priority ...                                              [OK]
    test_stablity ...                                                      [OK]
    test_timestamp_priority ...                                            [OK]

-------------------------------------------------------------------------------
Ran 7 tests in 0.026s

PASSED (successes=7)
test_slave_allocation
  SlaveCheck
    test_prod_vs_try ...                                                   [OK]
    test_stag_not_in_prod ...                                              [OK]

-------------------------------------------------------------------------------
Ran 2 tests in 0.005s

PASSED (successes=2)
Comment on attachment 8458253 [details] [diff] [review]
bug1030753-2.patch

Review of attachment 8458253 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Kim,

I exploded the config before and after applying your patch, and the following questions are based on this diff of results of before vs after.

1) I notice we have no changes for date, elm, fig, holly - but this looks correct to me - from the rest of the config they do not look like the other trunk branches, so I guess they are not trunk branches?

2) The following trees appear to have no changes:
     a) mozilla-aurora
     b) mozilla-release
     c) mozilla-central
     d) mozilla-beta
     e) cedar

Should these also now include crashtest and plain-reftest-{1..8} for platforms : android : panda_android : debug_unittest_suites?

3) mozilla-b2g28_v1_3 : platforms : android : panda_android : debug_unittest_suites appears to have the following now removed after this patch:

     a) robocop-{1..5}
     b) crashtest
     c) mochitest-gl
     d) xpcshell
     e) cppunit

4) mozilla-b2g30_v1_4 : platforms : android : panda_android : debug_unittest_suites appears to have the following now removed after this patch:

     a) robocop-{1..5}
     b) crashtest
     c) mochitest-gl
     d) plain-reftest-{1..8}
     e) xpcshell
     f) cppunit

I'm happy with the changes for the other trees (ash, b2g-inbound, cypress, fx-team, graphics, gum, jamun, larch, maple, mozilla-inbound, oak, try) that now include plain-reftest-{1..8} and crashtest under platforms : android : panda_android : debug_unittest_suites.

I'll leave at r? until you've had a chance to answer, as I'm not quite sure if they are expected or not.

Thanks!
Pete

::: mozilla-tests/mobile_config.py
@@ +746,5 @@
>      if suite[0].startswith('robocop'):
>          continue
>      ANDROID_PLAIN_UNITTEST_DICT['opt_unittest_suites'].append(suite)
>  
> +# bug 982799 limit the debug tests run on trunk branches

This comment appears to be about a different (closed) bug - did you mean to include it in this patch?
Hi Kim,

Just to be explicit; 3) and 4) above were not written as a question, but I should have written them as questions. In other words, were you expecting these changes to mozilla-b2g28_v1_3 : platforms : android : panda_android : debug_unittest_suites and mozilla-b2g30_v1_4 : platforms : android : panda_android : debug_unittest_suites ? I wondered if this was pollution from bug 982799 or was intended for this patch.

Thanks,
Pete
(Assignee)

Comment 14

3 years ago
1) Right they are project branches

2) Correct, riding the trains means that the tests will be first be enabled on mozilla-inbound and then the tests will be enabled on aurora, beta and release branches as the new version of gecko is merged into these branches.

3) and 4) There aren't any Android 4.0 Panda tests ever invoked on mozilla-b2g28_v1_3 or mozilla-b2g30_v1_4 because the build they run against isn't created on these branches.  These builders should actually be removed since they aren't used, I'll open a separate bug for this.

The comment refers to the old bug where I initially enabled debug tests, this bug just enables more tests.
(In reply to Kim Moir [:kmoir] from comment #14)
> 2) Correct, riding the trains means that the tests will be first be enabled
> on mozilla-inbound and then the tests will be enabled on aurora, beta and
> release branches as the new version of gecko is merged into these branches.

But what about:

>> 2) The following trees appear to have no changes:
>>     c) mozilla-central

That seems odd.
Sorry, I see -- it will go to m-c when m-i is merged -- no problem there.
Thanks Kim!

And just to double check a couple of things:

1) What about cedar from question 2) in comment 12?

2) These are the branches where the tests are now enabled - ash, b2g-inbound, cypress, fx-team, graphics, gum, jamun, larch, maple, mozilla-inbound, oak, try - can you just confirm that looks correct to you as the current full list of "trunk trees" on version 31+ ? (I ask because you said holly, fig etc are project branches - but I thought larch, maple etc are project branches too - so I wanted to make sure that "trunk trees" means exactly this list that has changes).

3) Strangely, when I run again, I hit a problem with test-masters.sh. To be transparent, I am running this script:

    https://raw.githubusercontent.com/petemoore/myscrapbook/8809eae5e0587f008e07623c5578cf7db5aa184d/run-test-masters.sh

from my home directory on dev-master1. The problem I am getting (now, not before in comment 11 - strangely my results are different now):

[pmoore@dev-master1.srv.releng.scl3.mozilla.com ~]$ ./run-test-masters.sh 
warning: hg.mozilla.org certificate with fingerprint af:27:b9:34:47:4e:e5:98:01:f6:83:2b:51:c9:aa:d8:df:fb:1a:27 not verified (check hostfingerprints or web.cacerts config setting)
destination directory: tools
requesting all changes
adding changesets
adding manifests
adding file changes
added 4786 changesets with 9699 changes to 1187 files
updating to branch default
548 files updated, 0 files merged, 0 files removed, 0 files unresolved
warning: hg.mozilla.org certificate with fingerprint af:27:b9:34:47:4e:e5:98:01:f6:83:2b:51:c9:aa:d8:df:fb:1a:27 not verified (check hostfingerprints or web.cacerts config setting)
destination directory: buildbot-configs
requesting all changes
adding changesets
adding manifests
adding file changes
added 10729 changesets with 20922 changes to 2636 files (+2 heads)
updating to branch default
524 files updated, 0 files merged, 0 files removed, 0 files unresolved
warning: hg.mozilla.org certificate with fingerprint af:27:b9:34:47:4e:e5:98:01:f6:83:2b:51:c9:aa:d8:df:fb:1a:27 not verified (check hostfingerprints or web.cacerts config setting)
destination directory: buildbotcustom
requesting all changes
adding changesets
adding manifests
adding file changes
added 3771 changesets with 4303 changes to 109 files (+2 heads)
updating to branch default
59 files updated, 0 files merged, 0 files removed, 0 files unresolved
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
101  4364  101  4364    0     0  31999      0 --:--:-- --:--:-- --:--:--  129k
patching file mozilla-tests/mobile_config.py
Checking 22 masters...
bm01-tests1-linux32 bm51-tests1-linux64 bm69-tests1-windows bm70-build1 bm75-try1 bm81-build_scheduler bm81-tests_scheduler bm88-tests1-tegra bm89-tests1-panda bm103-tests1-linux bm106-tests1-macosx bm109-tests1-windows bm01-tests1-linux32-universal bm51-tests1-linux64-universal bm69-tests1-windows-universal bm70-build1-universal bm75-try1-universal bm88-tests1-tegra-universal bm89-tests1-panda-universal bm103-tests1-linux-universal bm106-tests1-macosx-universal bm109-tests1-windows-universal
INFO  - creating "bm70-build1-universal" master
INFO  - created  "bm70-build1-universal" master, running checkconfig
ERROR - TEST-FAIL bm70-build1-universal failed to run checkconfig
INFO  - log for "bm70-build1-universal" is "/builds/buildbot/pmoore/test1/buildbot-configs/test-output/bm70-build1-universal-B3wmgK-checkconfig.log"
INFO  - TEST-SUMMARY: 22 tested, 1 failed
INFO  - FAILED-MASTER bm70-build1-universal, log: 'test-output/bm70-build1-universal-B3wmgK-checkconfig.log', dir: 'test-output/bm70-build1-universal-B3wmgK'
INFO  - creating "bm81-build_scheduler" master
INFO  - created  "bm81-build_scheduler" master, running checkconfig
ERROR - TEST-FAIL bm81-build_scheduler failed to run checkconfig
INFO  - log for "bm81-build_scheduler" is "/builds/buildbot/pmoore/test1/buildbot-configs/test-output/bm81-build_scheduler-jzTJ5y-checkconfig.log"
INFO  - TEST-SUMMARY: 22 tested, 1 failed
INFO  - FAILED-MASTER bm81-build_scheduler, log: 'test-output/bm81-build_scheduler-jzTJ5y-checkconfig.log', dir: 'test-output/bm81-build_scheduler-jzTJ5y'
INFO  - creating "bm75-try1" master
INFO  - created  "bm75-try1" master, running checkconfig
ERROR - TEST-FAIL bm75-try1 failed to run checkconfig
INFO  - log for "bm75-try1" is "/builds/buildbot/pmoore/test1/buildbot-configs/test-output/bm75-try1-3iO45F-checkconfig.log"
INFO  - TEST-SUMMARY: 22 tested, 1 failed
INFO  - FAILED-MASTER bm75-try1, log: 'test-output/bm75-try1-3iO45F-checkconfig.log', dir: 'test-output/bm75-try1-3iO45F'
INFO  - creating "bm75-try1-universal" master
INFO  - created  "bm75-try1-universal" master, running checkconfig
ERROR - TEST-FAIL bm75-try1-universal failed to run checkconfig
INFO  - log for "bm75-try1-universal" is "/builds/buildbot/pmoore/test1/buildbot-configs/test-output/bm75-try1-universal-iKnDoN-checkconfig.log"
INFO  - TEST-SUMMARY: 22 tested, 1 failed
INFO  - FAILED-MASTER bm75-try1-universal, log: 'test-output/bm75-try1-universal-iKnDoN-checkconfig.log', dir: 'test-output/bm75-try1-universal-iKnDoN'
INFO  - creating "bm70-build1" master
INFO  - created  "bm70-build1" master, running checkconfig
ERROR - TEST-FAIL bm70-build1 failed to run checkconfig
INFO  - log for "bm70-build1" is "/builds/buildbot/pmoore/test1/buildbot-configs/test-output/bm70-build1-thqtTn-checkconfig.log"
INFO  - TEST-SUMMARY: 22 tested, 1 failed
INFO  - FAILED-MASTER bm70-build1, log: 'test-output/bm70-build1-thqtTn-checkconfig.log', dir: 'test-output/bm70-build1-thqtTn'
INFO  - creating "bm89-tests1-panda" master
INFO  - created  "bm89-tests1-panda" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm89-tests1-panda
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm89-tests1-panda-universal" master
INFO  - created  "bm89-tests1-panda-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm89-tests1-panda-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm88-tests1-tegra-universal" master
INFO  - created  "bm88-tests1-tegra-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm88-tests1-tegra-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm88-tests1-tegra" master
INFO  - created  "bm88-tests1-tegra" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm88-tests1-tegra
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm103-tests1-linux" master
INFO  - created  "bm103-tests1-linux" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm103-tests1-linux
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm103-tests1-linux-universal" master
INFO  - created  "bm103-tests1-linux-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm103-tests1-linux-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm106-tests1-macosx-universal" master
INFO  - created  "bm106-tests1-macosx-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm106-tests1-macosx-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm106-tests1-macosx" master
INFO  - created  "bm106-tests1-macosx" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm106-tests1-macosx
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm01-tests1-linux32" master
INFO  - created  "bm01-tests1-linux32" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm01-tests1-linux32
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm01-tests1-linux32-universal" master
INFO  - created  "bm01-tests1-linux32-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm01-tests1-linux32-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm109-tests1-windows-universal" master
INFO  - created  "bm109-tests1-windows-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm109-tests1-windows-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm69-tests1-windows" master
INFO  - created  "bm69-tests1-windows" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm69-tests1-windows
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm109-tests1-windows" master
INFO  - created  "bm109-tests1-windows" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm109-tests1-windows
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm69-tests1-windows-universal" master
INFO  - created  "bm69-tests1-windows-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm69-tests1-windows-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm51-tests1-linux64" master
INFO  - created  "bm51-tests1-linux64" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm51-tests1-linux64
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm51-tests1-linux64-universal" master
INFO  - created  "bm51-tests1-linux64-universal" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm51-tests1-linux64-universal
INFO  - TEST-SUMMARY: 22 tested, 0 failed
INFO  - creating "bm81-tests_scheduler" master
INFO  - created  "bm81-tests_scheduler" master, running checkconfig
INFO  - TEST-PASS checkconfig OK for bm81-tests_scheduler
INFO  - TEST-SUMMARY: 22 tested, 0 failed
*** 5 master tests failed ***
Failed masters:
  bm70-build1-universal
  bm81-build_scheduler
  bm75-try1
  bm75-try1-universal
  bm70-build1
[pmoore@dev-master1.srv.releng.scl3.mozilla.com ~]$


Each of these errors look the same, and I don't think they are related to your change, but I wanted to highlight it, just in case. Also, if you see the error in my script, please let me know! :)


[pmoore@dev-master1.srv.releng.scl3.mozilla.com ~]$ cat /builds/buildbot/pmoore/test1/buildbot-configs/test-output/bm70-build1-universal-B3wmgK-checkconfig.log
/builds/buildbot/pmoore/test1/lib/python2.6/site-packages/twisted/mail/smtp.py:10: DeprecationWarning: the MimeWriter module is deprecated; use the email package instead
  import MimeWriter, tempfile, rfc822
Traceback (most recent call last):
  File "/builds/buildbot/pmoore/test1/lib/python2.6/site-packages/buildbot-0.8.2_hg_b5878e99b911_production_0.8-py2.6.egg/buildbot/scripts/runner.py", line 1042, in doCheckConfig
    ConfigLoader(configFileName=configFileName)
  File "/builds/buildbot/pmoore/test1/lib/python2.6/site-packages/buildbot-0.8.2_hg_b5878e99b911_production_0.8-py2.6.egg/buildbot/scripts/checkconfig.py", line 31, in __init__
    self.loadConfig(configFile, check_synchronously_only=True)
  File "/builds/buildbot/pmoore/test1/lib/python2.6/site-packages/buildbot-0.8.2_hg_b5878e99b911_production_0.8-py2.6.egg/buildbot/master.py", line 652, in loadConfig
    exec f in localDict
  File "/builds/buildbot/pmoore/test1/buildbot-configs/test-output/bm70-build1-universal-B3wmgK/master.cfg", line 11, in <module>
    import config
  File "/tmp/tmp5tfpy2/config.py", line 167, in <module>
AttributeError: 'module' object has no attribute 'BUILDS_BEFORE_REBOOT'
[pmoore@dev-master1.srv.releng.scl3.mozilla.com ~]$
(Assignee)

Comment 18

3 years ago
1) gbrown is testing all changes on cedar, thus all tests are enabled on this branch

2) Yes, this looks good.

3) I reran test-masters.sh on my master (after fixing some merge conflicts) and it ran green for me
Comment on attachment 8458253 [details] [diff] [review]
bug1030753-2.patch

Review of attachment 8458253 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Kim, great job!

I think the errors I got are not at all related to your change, and since test-masters.sh is working for you ok, let's go with it!

Pete
Attachment #8458253 - Flags: review?(pmoore) → review+
(Assignee)

Updated

3 years ago
Attachment #8458253 - Flags: checked-in+

Comment 20

3 years ago
In production.
(Assignee)

Comment 21

3 years ago
Verified on tbpl
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.