Closed Bug 1030757 Opened 6 years ago Closed 6 years ago

Closed private tabs appears in recent tabs panel

Categories

(Firefox for Android :: General, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox30 --- unaffected
firefox31 --- unaffected
firefox32 --- unaffected
firefox33 --- verified
fennec 33+ ---

People

(Reporter: cos_flaviu, Assigned: bnicholson)

References

Details

Attachments

(2 files, 2 obsolete files)

Environment: 
Device: Google Nexus 10 (Android 4.4.2);
Build: Nightly 33.0a1 (2014-06-26);

Steps to reproduce:
1. Open new private tab;
2. Load a page;
3. Close the private tab;
4. Go to Recent tabs panel in about:home.

Expected result:
The closed private tab is not listed in recently closed tabs.

Actual result:
The closed private tab appears in recently closed tabs.
and it restores as a regular tab ....
Blocks: 1004850
tracking-fennec: --- → ?
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 33+
Assignee: margaret.leibovic → bnicholson
I can look into this tomorrow, since bnicholson is on PTO. We pull the recent tabs from session store, but maybe we don't separate private/regular tabs in there? I thought we did.
Flags: needinfo?(bnicholson)
Attached image screenshot.png
Also related, recent tabs will list about:privatebrowsing (new private tabs), it seems unnecessary to list and capture essentially useless entries there.
Omits any private tabs in the ClosedTabs:Data message.
Attachment #8451883 - Flags: review?(mark.finkle)
Flags: needinfo?(bnicholson)
Attachment #8451883 - Attachment is obsolete: true
Attachment #8451883 - Flags: review?(mark.finkle)
Attachment #8451885 - Flags: review?(mark.finkle)
forgot qref
Attachment #8451885 - Attachment is obsolete: true
Attachment #8451885 - Flags: review?(mark.finkle)
Attachment #8451888 - Flags: review?(mark.finkle)
Attachment #8451888 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/6a2450c41a2e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
If I open in private mode, two tabs: about:privatebrowsing and google.com, close them, they will not be listed in recently closed tabs, so:
Verified fixed on:
Device: LG Nexus 4 (Android 4.4.2)
Build: Firefox for Android 33.0a1 (2014-07-09)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.