Closed Bug 1030779 Opened 5 years ago Closed 5 years ago

Command-line help text missing -private-window flag

Categories

(Firefox :: Private Browsing, defect, trivial)

33 Branch
x86
Linux
defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Firefox 33
Tracking Status
firefox34 --- verified

People

(Reporter: rfreebern, Assigned: rfreebern)

Details

Attachments

(1 file, 3 obsolete files)

Attached patch private-window-help-output.diff (obsolete) — Splinter Review
While Firefox supports a -private-window command-line flag, it's not present in the command-line help output.

Expected: "-private-window" appears in output of "firefox -h"
Actual: "-private-window" is not present in the output of "firefox -h"
Steps to reproduce: Run "firefox -h" on the command line.
You've got a semicolon at the end of your added line where you want a +, but if I fix that it works fine locally:
https://pastebin.mozilla.org/5475946
Assignee: nobody → ryan
Component: Help Documentation → Private Browsing
If you upload a fixed version (following the instructions at https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F) this looks good to me!
Flags: needinfo?(ryan)
Attached patch Fixed patch. (obsolete) — Splinter Review
Whoops. Here's a fixed patch.
Attachment #8446572 - Attachment is obsolete: true
Flags: needinfo?(ryan)
Attached patch hg mq patch (obsolete) — Splinter Review
One more try, this time with an (I hope) properly-formatted patch.
Attachment #8446599 - Attachment is obsolete: true
Comment on attachment 8446604 [details] [diff] [review]
hg mq patch

Since jdm offered.
Attachment #8446604 - Flags: review?(josh)
Comment on attachment 8446604 [details] [diff] [review]
hg mq patch

Review of attachment 8446604 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry that I forgot about this. Could you add a "Bug 1030779 - " prefix to the commit message, as well as "r=jdm" to the end of it? It will be ready to be merged in that case; thanks!
Attachment #8446604 - Flags: review?(josh) → review+
Attached patch hg mq patchSplinter Review
Updated patch with properly-formatted commit msg.
Attachment #8446604 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/b4c300eceeff
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
Hi,

I've reproduced it on Nightly Mozilla Firefox 33.0a1 (20140626) and I can confirm it's fixed in latest Nightly Firefox/34.0 ID:20140723030202 on Linux x86_64.

Cheers,
Francesca
QA Whiteboard: [bugday-20140723]
You need to log in before you can comment on or make changes to this bug.