Support Handoff to Mobile Safari

RESOLVED DUPLICATE of bug 1085391

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 1085391
4 years ago
3 years ago

People

(Reporter: Cam, Unassigned)

Tracking

({feature, ux-efficiency})

33 Branch
x86_64
Mac OS X
feature, ux-efficiency
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature-parity with safari for desktop)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140626030201

Steps to reproduce:

I expect Firefox to maintain feature parity with desktop safari for OS X, at or close to the time of launch. None of this waiting a year to implement a feature. There are beta available today for developers for a reason. Lets not repeat the Lion scrollbar timeline this time.


Actual results:

In the past Firefox has only gotten features from the new OS a year late.


Expected results:

With handoff lets get this done quickly.

The apis for handing off TO mobile safari exist see: http://www.itworld.com/operating-systems/422463/devs-can-handoff-ios-apps-browser-based-uis-macs

The other direction might require building a website or bookmarklet to facilitate sending links back to desktop firefox, but even one directional is better than nothing.
(Reporter)

Updated

4 years ago
Component: Untriaged → Shell Integration
Keywords: feature, ux-efficiency
Hardware: x86 → x86_64
Whiteboard: feature-parity with safari for desktop
AFAIK this cannot work. Handoff only works between apps from the same developer.

See https://developer.apple.com/library/ios/documentation/UserExperience/Conceptual/Handoff/AdoptingHandoff/AdoptingHandoff.html

"User activities can be shared among apps that *are signed with the same developer team identifier* and supporting a given activity type."

This could work with a Mozilla written companion app on iOS though.
Also see https://bugzilla.mozilla.org/show_bug.cgi?id=1085391#c2 .. not saying this is impossible, but I think we would have to do some magic (read: tons of work) to get Firefox on the Mac App Store first.
(Reporter)

Comment 3

3 years ago
I'm not seeing where it says that the desktop app must be in the app store. It does have to be signed but Firefox is already signed to deal with gatekeeper.

The apis allow you to handoff from a desktop app to a website in mobile safari directly so there is no magic needed there. Yay easy.

Going from iOS to desktop is apparently also possible:

A web browser on OS X that wants to continue an activity in this way should claim the NSUserActivityTypeBrowsingWeb activity type (by entering that string in its NSUserActivityTypes array in the app's Info.plist property list file). This ensures that if the user selects that browser as their default browser, it receives the activity object instead of Safari.

Relevant section in docs: https://developer.apple.com/library/ios/documentation/UserExperience/Conceptual/Handoff/AdoptingHandoff/AdoptingHandoff.html#//apple_ref/doc/uid/TP40014338-CH2-SW21

Comment 4

3 years ago
Chrome and Opera support Handoff in one way now (iOS > Mac). http://www.macg.co/os-x/2014/11/handoff-fonctionne-avec-chrome-et-respecte-la-navigation-privee-85438
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1085391
You need to log in before you can comment on or make changes to this bug.