Closed Bug 1030820 Opened 6 years ago Closed 6 years ago

[Collection app] Retrieve more web results

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

x86
macOS
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: ranbena, Assigned: ranbena)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

Currently Smart Collections are requesting 10 web results though previous versions would request 16 and allow loading more with user interaction.

Leaving the "load more" functionality for v2.1, we should increase the number of web results loaded initially.
I'd like to experiment a bit in order to find the right balance between most results and best performance.
Assignee: nobody → ran
Blocks: 1015336
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.0?
Need a product call if this is a blocker.

My perspective is that we should fix this, but I think we should ship with this problem if push came to shove.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Flags: needinfo?(pdolanjski)
Since we had to drop load more to a future version, I do think we need to increase beyond 10 results as it is limiting usefullness.
Flags: needinfo?(pdolanjski)
We probably won't block, though.  Approval should be sufficient.
blocking-b2g: 2.0? → backlog
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking-]
Whiteboard: [systemsfe]
Blocks: vertical-home-next
No longer blocks: 1015336
Attached file Pull request
Attachment #8447978 - Flags: review?(kgrandon)
Comment on attachment 8447978 [details] [review]
Pull request

Seems good to me!
Attachment #8447978 - Flags: review?(kgrandon) → review+
Landed: https://github.com/mozilla-b2g/gaia/commit/e3c0cbe71708b1a8acfb1293e95bf085f95f7d37
Blocks: vertical-homescreen
No longer blocks: vertical-home-next
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8447978 [details] [review]
Pull request

This is needed for the vertical homescreen.
Attachment #8447978 - Flags: approval-gaia-v2.0?(bbajaj)
Flags: needinfo?(jlorenzo)
Keywords: verifyme
Attachment #8447978 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
24 suggestions are now here.
Flags: needinfo?(jlorenzo)
Verified the issue is fixed on 2.2 and 2.1 Flame

Smart collection results are extended to 22-24 results

Device: Flame 2.2 Master
BuildID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 KK
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-] → [VH-FL-blocking-][VH-FC-blocking-], [[QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-], [[QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking-], [[QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.