Use Linux desktop environment scale factors when determining devPixelsPerPx

RESOLVED FIXED

Status

()

Firefox
Untriaged
RESOLVED FIXED
4 years ago
9 months ago

People

(Reporter: Ruben, Unassigned)

Tracking

(Blocks: 1 bug)

30 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed in bug 1097897])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8446862 [details]
REDDIT.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140608211132

Steps to reproduce:

I set the org.gnome.desktop.interface scaling-factor with unity-control-center from (int)1 to (int)2:  (see: http://askubuntu.com/questions/471425/scale-title-bars-and-menu-in-ubuntu-14-04-with-gnome/486611#486611 )

(Using Ubuntu 14.04 32bit)



Actual results:

org.gnome.desktop.interface scaling-factor was set from (int)1 to (int)2
and com.ubuntu.user-interface scale-factor from {'HDMI1': 8, 'eDP1': 8} to {'HDMI1': 8, 'eDP1': 16}

so the system-wide scaling is set to (int)2, this seems to affect all form elements in firefox, but not the normal text. So the formelements become double the size as the text (only if a website has not defined the css-value for font-size) see: http://stackoverflow.com/questions/23783899/why-are-all-html-form-elements-huge-with-a-system-wide-font-scale-factor-2-0


Expected results:

Firefox should notice, that the scale-factor was changed by Ubuntu and use this scale factor for layout.css.devPixelsPerPx also (default is (int)-1, which should ere this value, but it doesn't)

If you set layout.css.devPixelsPerPx to the same value as org.gnome.desktop.interface scaling-factor (int)2 then everything looks perfect.

(There is exactly the same problem in Thunderbird also)

Updated

4 years ago
Summary: Scale settings not working corectly on Ubuntu Unity → Scale settings not working corectly on Ubuntu Unity (org.gnome.desktop.interface scaling-factor, com.ubuntu.user-interface scale-factor, layout.css.devPixelsPerPx)
I'm rewording here for simplicity (hope that's okay) and I'm going to hang this off the main Linux high dpi tracker (bug 967100).
Blocks: 967100
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Scale settings not working corectly on Ubuntu Unity (org.gnome.desktop.interface scaling-factor, com.ubuntu.user-interface scale-factor, layout.css.devPixelsPerPx) → Use Linux desktop environment scale factors when determining devPixelsPerPx
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 3

3 years ago
Hi, I was wondering why the scaling has to be an integer? I have a laptop with 1920x1080 resolution and it is 13.3 inches. So my DPI is 165.63 and my scaling factor should be something like "165.63/96 = 1.73".
Since Gnome only accepts integers for window scaling, I leave that to 1 because 2 is too large but then I change the font scaling to 1.5 which makes everything to scales nicely most of the times. For Firefox I used to set "layout.css.devPixelsPerPx" to 1.5 too and everything worked perfectly. Today I noticed when I set "layout.css.devPixelsPerPx" to -1 (which I often do because I use an external monitor and it is not hidpi) and my font scaling to 1.5, Firefox chooses to set the scaling to 2! So I was wondering while the "layout.css.devPixelsPerPx" value can be easily set to "1.5", while did you decide to round it to an integer?
P.S. I am using Arch Linux and Gnome shell.

Comment 4

9 months ago
I recently bought a 4k monitor and noticed that in windows setting font scale to "1.5" also increases the "layout.css.devPixelsPerPx" correctly.

Yet on Linux this does not happen. I set font scale to "1.5", but I have to manually set the "layout.css.devPixelsPerPx".

Does this mean the issue is not fixed?

I'm using Ubuntu 17.10 with Gnome Shell and Firefox 55.0.2 (64 bit).
You need to log in before you can comment on or make changes to this bug.