[Vertical Homescreen] Add configure button in context menu

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

unspecified
2.0 S6 (18july)
All
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 wontfix, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Assignee)

Description

4 years ago
I wanted to open this bug just because of I would like to show a new option like "Settings or Configure" in the contextmenu once that the pinch-to-zoom was removed from 2.0.

Could we have a new option in the context menu like:

----
Settings or Configure...
----
Change Wallpaper
----
Add Smart Collections

----
Cancel

When an user click on this new option an activity would be performed in order to show the setting app in the homescreen panel thought

Is a good idea? or maybe an stupid thing XD
(Assignee)

Updated

4 years ago
Blocks: 1017954
(Assignee)

Updated

4 years ago
Whiteboard: [systemsfe]
(Assignee)

Comment 1

4 years ago
What do you think? Many thanks
Flags: needinfo?(jsavory)
Flags: needinfo?(fdjabri)
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
That sounds like a great idea to me. What do you think Jacqueline?
Flags: needinfo?(fdjabri)
I think this is a great idea as well, perhaps "Homescreen Settings" would work as the option. However I don't think we can add anymore strings to 2.0. Cristian do you know if there is an existing string that we can use in this situation?
Flags: needinfo?(jsavory) → needinfo?(crdlc)
(Assignee)

Comment 4

4 years ago
Sadly I don't see any string related to "Homescreen Settings"

https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/locales/homescreen.en-US.properties

(In reply to jsavory from comment #3)
> I think this is a great idea as well, perhaps "Homescreen Settings" would
> work as the option. However I don't think we can add anymore strings to 2.0.
> Cristian do you know if there is an existing string that we can use in this
> situation?
Flags: needinfo?(crdlc) → needinfo?(jsavory)
(Assignee)

Comment 5

4 years ago
uff I added a wrong link. This is the locales that the vertical homescreen has right now

https://github.com/mozilla-b2g/gaia/blob/master/apps/verticalhome/locales/homescreen.en-US.properties
(Assignee)

Comment 6

4 years ago
Created attachment 8447853 [details]
Github pull request

Just in case you want to test the feature in the device
(Assignee)

Comment 7

4 years ago
Created attachment 8447854 [details]
Screenshots of the implementation
I think that this looks great, but you're right, I don't think we can use any of the strings listed... perhaps we can include this for 2.1?
Flags: needinfo?(jsavory)
(Assignee)

Comment 9

4 years ago
ok for 2.1
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 10

4 years ago
Comment on attachment 8447853 [details]
Github pull request

thanks Kevin
Attachment #8447853 - Flags: review?(kgrandon)
(Assignee)

Updated

4 years ago
status-b2g-v2.0: --- → wontfix
status-b2g-v2.1: --- → affected
(Assignee)

Comment 11

4 years ago
Ready for 2.1

(In reply to jsavory from comment #8)
> I think that this looks great, but you're right, I don't think we can use
> any of the strings listed... perhaps we can include this for 2.1?
Comment on attachment 8447854 [details]
Screenshots of the implementation

Let's ask for a UI review from Jacqueline first..
Attachment #8447854 - Flags: ui-review?(jsavory)
Attachment #8447853 - Flags: review?(kgrandon) → review+
Comment on attachment 8447854 [details]
Screenshots of the implementation

This looks like it works for me.
Attachment #8447854 - Flags: ui-review?(jsavory) → ui-review+
(Assignee)

Comment 14

4 years ago
Merged in master:

https://github.com/crdlc/gaia/commit/47f797c1f22ea4a6adfb1b0a4c34c657977e27b3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.0 S6 (18july)
Blocks: 989848
No longer blocks: 1017954
This issue has been successfully verified on Flame 2.1.
See attachments: verified_v2.1_1.png and verified_v2.1_2.png.
Reproduce rate: 0/5

Flame 2.1 build:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141201.034405
FW-Date         Mon Dec  1 03:44:15 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
Created attachment 8531185 [details]
verified_v2.1_1.png
Created attachment 8531186 [details]
verified_v2.1_2.png
You need to log in before you can comment on or make changes to this bug.