After the first swipe in the task manager, all subsequent swipes have weird input lag

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: cwiiis, Assigned: cwiiis)

Tracking

unspecified
2.0 S5 (4july)
All
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

4 years ago
I think removing the transition from the task cards isn't working correctly, so after the first drag/swipe, all subsequent ones lag behind the input events and feel weird. Should be a reasonable easy fix so taking it.
(Assignee)

Comment 1

4 years ago
Created attachment 8447152 [details] [review]
Fix removing transitions from cards in task manager

Two problems, applying a MozTransition style of undefined doesn't do anything, and I don't think there's any need to use this.prev/nextCard when we have the exact elements the styles were applied to in scope.
Attachment #8447152 - Flags: review?(alive)
See drive-by comments on github. I'm not saying transition: none is the wrong thing to do, just pointing out the meaning of that undefined value and how it is handled in AppWindow.prototype.applyStyle
(Assignee)

Comment 3

4 years ago
(In reply to Sam Foster [:sfoster] from comment #2)
> See drive-by comments on github. I'm not saying transition: none is the
> wrong thing to do, just pointing out the meaning of that undefined value and
> how it is handled in AppWindow.prototype.applyStyle

You're right, setting it to "" I think would have the right effect, assuming it works - I'll try that on Monday. That said, we're overriding it entirely, it'd be a bit odd to do that if we couldn't assume full control of it (so I think none is ok too, but I'll see if "" works in case things change in the future).
A video would help understand the user impact here.
Keywords: qawanted
Do we still have the open/close animation after clearing the style.transition in javascript?
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S5 (4july)
Flags: needinfo?(chrislord.net)
(Assignee)

Comment 6

4 years ago
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #5)
> Do we still have the open/close animation after clearing the
> style.transition in javascript?

Yes, these still work fine.

I've just force-pushed to replace 'none' with '', which works but also doesn't override the transition style in the stylesheet. This is ready for review.
Flags: needinfo?(chrislord.net)
Comment on attachment 8447152 [details] [review]
Fix removing transitions from cards in task manager

It's better to have a test.
Attachment #8447152 - Flags: review?(alive) → feedback+
(Assignee)

Comment 8

4 years ago
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #7)
> Comment on attachment 8447152 [details] [review]
> Fix removing transitions from cards in task manager
> 
> It's better to have a test.

Fair enough, what part would you like to test here?
Flags: needinfo?(alive)
(Assignee)

Comment 9

4 years ago
needinfo'ing myself again too to provide a video.
Flags: needinfo?(chrislord.net)
(In reply to Chris Lord [:cwiiis] from comment #8)
> (In reply to Alive Kuo [:alive][NEEDINFO!] from comment #7)
> > Comment on attachment 8447152 [details] [review]
> > Fix removing transitions from cards in task manager
> > 
> > It's better to have a test.
> 
> Fair enough, what part would you like to test here?

We have a discussion on IRC, clearing needinfo
Flags: needinfo?(alive)
(Assignee)

Comment 11

4 years ago
Comment on attachment 8447152 [details] [review]
Fix removing transitions from cards in task manager

Now with test (confirmed fails without the patch applied).
Attachment #8447152 - Flags: review?(alive)
Added video URL ( http://youtu.be/nfu4FnH8q8Y ). The input lag is most noticeable when holding a card and moving it slowly. 

Checked on 2.0:
Flame 2.0
BuildID: 20140627000201
Gaia: 8df02268fcd7e80c5fab8c1ec099772e37f8659d
Gecko: 731a5e8831e6
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Comment on attachment 8447152 [details] [review]
Fix removing transitions from cards in task manager

Please rebase your commit into only one.
Attachment #8447152 - Flags: review?(alive) → review+
(Assignee)

Comment 14

4 years ago
Created attachment 8449298 [details] [review]
Fix removing transitions from cards in task manager

Squashed commits, carrying f+/r+
Attachment #8447152 - Attachment is obsolete: true
Attachment #8449298 - Flags: review+
Attachment #8449298 - Flags: feedback+
(Assignee)

Comment 15

4 years ago
Merged into master: https://github.com/mozilla-b2g/gaia/commit/feb3e61f956d50b4e4b326f9ee32e9ae98d19629
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

4 years ago
Video: https://www.dropbox.com/s/uwicg1qkap74zkb/task-manager%20input%20lag.3gp

Note how the first swipes track quite well but after I lift my finger and replace it, there's lag.
Flags: needinfo?(chrislord.net)
(Assignee)

Comment 17

4 years ago
Comment on attachment 8449298 [details] [review]
Fix removing transitions from cards in task manager

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Laggy task manager
[User impact] if declined: See comment #15
[Testing completed]: Been on master for a day, has test coverage
[Risk to taking this patch] (and alternatives if risky): Low risk - the biggest risk is that the situation that already exists remains (but tests and manual testing show it to be fixed)
[String changes made]: None
Attachment #8449298 - Flags: approval-gaia-v2.0?

Updated

4 years ago
Attachment #8449298 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
v2.0: https://github.com/mozilla-b2g/gaia/commit/4caca2282560f1f9658e078c306d14fa0377e5e7
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: --- → fixed
This issue has been successfully verified on Flame 2.1&2.0.
See attachment: verified_v2.1.mp4
Reproducing rate: 0/5

Flame 2.1 build:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141202001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141202.034824
FW-Date         Tue Dec  2 03:48:34 EST 2014
Bootloader      L1TC00011880

Flame 2.0 build:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141202000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141202.034707
FW-Date         Tue Dec  2 03:47:18 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.