[v2.0][Flame] Sending email option is not working

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::E-Mail
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: AndreiH, Assigned: jrburke)

Tracking

({regression, smoketest})

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed, b2g-v2.1 unaffected)

Details

(Whiteboard: [fromAutomation])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8447156 [details]
Screen shot.png

# STR:

1. Open Email app
2. Add a new account or a personal account.
3. Compose a message and try sending it.

# Expected results:
Email should be send without problems.

# Actual results:
"Sending email" loading screen gets stuck and email is not send.

Build under test:
Gaia      8df02268fcd7e80c5fab8c1ec099772e37f8659d                         
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/731a5e8831e6  
BuildID   20140627000201                                                   
Version   32.0a2                                                           
ro.build.version.incremental=94                                            
ro.build.date=Tue May 20 09:29:20 CST 2014


This started to reproduce since build:
Gaia      8df02268fcd7e80c5fab8c1ec099772e37f8659d                         
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/e82b42e059af  
BuildID   20140626160324                                                   
Version   32.0a2                                                           
ro.build.version.incremental=94                                            
ro.build.date=Tue May 20 09:29:20 CST 2014

I think the commit that caused this is:
https://github.com/mozilla-b2g/gaia/commit/c80c6ae1b3214a60e8ac5b19e8206334737e3af3
(Reporter)

Updated

4 years ago
Whiteboard: [fromAutomation]
This issue occurs on the latest 2.0 on Flame.

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140627000201
Gaia: 8df02268fcd7e80c5fab8c1ec099772e37f8659d
Gecko: 731a5e8831e6
Version: 32.0a2
Firmware Version: v122
status-b2g-v2.0: --- → affected
Flags: needinfo?(pbylenga)
Keywords: qaurgent
Requesting a regression window here, reproducible manually.
blocking-b2g: --- → 2.0?
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted, smoketest
Logcat would also be helpful.
QA Contact: pcheng
Created attachment 8447260 [details]
logcat

Attaching logcat

Email information:
Used both outlook.com and gmail.com
Account type: Activsync and IMAP+SMTP
Issue does NOT repro on today's tinderbox 2.1 master build. Window will be found in 2.0 Aurora branch.
status-b2g-v2.1: --- → unaffected
Note - we need to check if this reproduces on 1.4 or 1.3.
(Assignee)

Comment 7

4 years ago
This will only happen on the 2.0 branch, I did special 1.4 and 1.3 merges for bug 1025727. I thought 2.0 had the 'evt' module already in compose.js, but obviously, based on this error it did not. So the fix is just for me to revert the changeset for bug 1025727 on v2.0, then reapply special commit similar to the 1.3 and 1.4 merges that includes the missing dependency.

Since I will be reverting that other 2.0 commit for bug 1025727, I will track the changes in that bug, and mark this one fixed after fixing the merge in that bug.
Assignee: nobody → jrburke
Status: NEW → ASSIGNED
Depends on: 1025727
My window confirms that comment 7 is true. Also I've confirmed that this issue does NOT occur on 1.4.

Tinderbox hamachi 2.0 Aurora regression window:

Last Working Environmental Variables:
Device: Buri
Build ID: 20140626060203
Gaia: d815bfbb70d0f4a3757bb9eb93956a59a103d181
Gecko: cfa9446d0960
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg

First Broken Environmental Variables:
Device: Buri
Build ID: 20140626074808
Gaia: c80c6ae1b3214a60e8ac5b19e8206334737e3af3
Gecko: 706f19a6ff2e
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg

First broken gecko & last working gaia - issue does NOT repro
Gaia: d815bfbb70d0f4a3757bb9eb93956a59a103d181
Gecko: 706f19a6ff2e

Last working gecko first broken gaia - issue DOES repro
Gaia: c80c6ae1b3214a60e8ac5b19e8206334737e3af3
Gecko: cfa9446d0960

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/d815bfbb70d0f4a3757bb9eb93956a59a103d181...c80c6ae1b3214a60e8ac5b19e8206334737e3af3
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qaurgent, regressionwindow-wanted
(Assignee)

Comment 9

4 years ago
The updated v2.0 merge for bug 1025727, described in bug 1025727 comment 16, fixes this issue:

v2.0: https://github.com/mozilla-b2g/gaia/commit/b561073ac1c5d42fd1ea4d1497c04121e8250567
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.0? → 2.0+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
status-b2g-v2.0: affected → fixed
Target Milestone: --- → 2.0 S5 (4july)
[Environment]
Gaia      2248c0367661db9332f70f37055e1a8176f5f612
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/44d31566a3a6
BuildID   20140629160202
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014

[Result]
Pass
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.