Closed Bug 1031500 Opened 5 years ago Closed 5 years ago

Expose graphic Buffer to MediaCodec

Categories

(Core :: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
blocking-b2g 2.0+
Tracking Status
firefox31 --- wontfix
firefox32 --- fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1009410 +++

WebRTC OMX H.264 decode ends up blocked on buffers; as a near-term workaround, increase the number of buffers for WebRTC.  Note that the codec can only do HVGA @30fps @700Kbps when used for encode and decode at once, so that limits the memory hit.
Attachment #8447381 - Flags: review?(sotaro.ikeda.g)
Blocks: 989945
blocking-b2g: --- → 2.0?
Whiteboard: [webrtc-uplift]
Comment on attachment 8447381 [details] [diff] [review]
Increase number of buffers for webrtc OMX H.264 decode

Review of attachment 8447381 [details] [diff] [review]:
-----------------------------------------------------------------

Rview+ if the hardcoded "10" defined in another place. Hard-code a number directly to a function's argument is not good.
Attachment #8447381 - Flags: review?(sotaro.ikeda.g) → review+
(In reply to Randell Jesup [:jesup] from comment #0)
> WebRTC OMX H.264 decode ends up blocked on buffers; as a near-term
> workaround, increase the number of buffers for WebRTC.  

Please file a bug for undoing that workaround (once this lands at the latest).
blocking-b2g: 2.0? → 2.0+
https://hg.mozilla.org/mozilla-central/rev/febfad44b731
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8447381 [details] [diff] [review]
Increase number of buffers for webrtc OMX H.264 decode

Approval Request Comment
[Feature/regressing bug #]: N/A

[User impact if declined]: Jerking/low-frame-rate in B2G Webrtc with HW H.264 (8x10/Flame)

[Describe test coverage new/current, TBPL]: On M-c since last week

[Risks and why]: Only risk is memory use; the extra buffers are only used in WebRTC H.264 OMX calls

[String/UUID change made/needed]: None
Attachment #8447381 - Flags: approval-mozilla-aurora?
Comment on attachment 8447381 [details] [diff] [review]
Increase number of buffers for webrtc OMX H.264 decode

2.0+ have auto-approval for Aurora.
Attachment #8447381 - Flags: approval-mozilla-aurora?
(In reply to Florian Bender from comment #3)
> (In reply to Randell Jesup [:jesup] from comment #0)
> > WebRTC OMX H.264 decode ends up blocked on buffers; as a near-term
> > workaround, increase the number of buffers for WebRTC.  
> 
> Please file a bug for undoing that workaround (once this lands at the
> latest).

It should be bug 1009410.
Duplicate of this bug: 1036451
Whiteboard: [webrtc-uplift]
You need to log in before you can comment on or make changes to this bug.