Closed Bug 1031935 Opened 6 years ago Closed 4 years ago

./flash.sh gecko && ./flash.sh gaia over v1.1 yields v1.x homescreen on v2.x

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, blocker)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Synper311, Unassigned)

References

Details

ZTE Open flashed to v1.1(zte) using Recovery menu
Git pull & build BRANCH=master VARIANT=userdebug

/flash.sh gecko && ./flash.sh gaia
Result:
Keep v1.x homescreen, contacts, apps, etc


Need to cd gaia and then make reset-gaia or make production to get v2.x homescreen
Summary: Graphical Corruption → ./flash.sh gecko && ./flash.sh gaia over v1.x yields v1.x homescreen on v2.x
Summary: ./flash.sh gecko && ./flash.sh gaia over v1.x yields v1.x homescreen on v2.x → ./flash.sh gecko && ./flash.sh gaia over v1.1 yields v1.x homescreen on v2.x
Summary: ./flash.sh gecko && ./flash.sh gaia over v1.1 yields v1.x homescreen on v2.x → [OPEN] Upgrading from v1.1 to master does not switch to vertical homescreen
As per discussion on IRC, it may be impact migrations from v1.0.1/v1.1 from official releases.

QA should make sure that upgrading a profile from those old ages migrates properly to the new vertical homescreen.
blocking-b2g: --- → 2.0?
STR:

ZTE Open: v1.0 US_EBAY
Flash to v1.1 using official ZTE ROM from the power+vol up Recovery menu
Boot device, step through FTU and finish it

Git pull & build BRANCH=master VARIANT=userdebug
Can't fastboot flash due to ZTE Open boot fail with non-ZTE img files

Run ./flash.sh gecko && ./flash.sh gaia to put v2.1 gecko/gaia on v1.1 ZTE Open

Result: v2.1 gecko & gaia on v1.1 Gonk with v1.1 homescreen

Notes:
If I build and ./flash.sh gecko && ./flash.sh gaia from v1.1 to v1.2, v1.3, or v1.4 and then ./flash.sh gecko && ./flash.sh gaia to v2.0 or v2.1, it will result in the same v1.x homescreen on v2.x gecko/gaia combination.

Simply put: any v1.x base paired with any v2.x ./flash.sh gecko && ./flash.sh gaia yields the v1.x homescreen on v2.x gecko/gaia combination from above.

Video: This video is intended to show a screen corruption/draw issue, but it also shows the v1.x homescreen running under v2.x gecko/gaia
https://www.youtube.com/watch?v=IZU9Fcazl1w
blocking-b2g: 2.0? → ---
Summary: [OPEN] Upgrading from v1.1 to master does not switch to vertical homescreen → ./flash.sh gecko && ./flash.sh gaia over v1.1 yields v1.x homescreen on v2.x
(In reply to Alexandre LISSY :gerard-majax from comment #1)
> As per discussion on IRC, it may be impact migrations from v1.0.1/v1.1 from
> official releases.
> 
> QA should make sure that upgrading a profile from those old ages migrates
> properly to the new vertical homescreen.

There are no plans to support a migration from 1.01 or 1.1 --> 2.1. Migrations are only planned to be supported for two releases prior to the current release.
Duplicate of this bug: 1035912
Jason, according to dupe bug 1035912 this can be triggered when upgrading from v1.4.
Flags: needinfo?(jsmith)
(In reply to Alexandre LISSY :gerard-majax from comment #5)
> Jason, according to dupe bug 1035912 this can be triggered when upgrading
> from v1.4.

True, but that bug involves the Peak. I thought there was a known bug with the old homescreen showing up with the Peak. I vaguely remember gmarty filing the bug I think.

gmarty - Do you recall a bug like what I'm describing on the Peak?
Flags: needinfo?(jsmith) → needinfo?(gmarty)
Jason, the bug is bug 1035912, it happens when a Peak is upgraded from v1.4.
Flags: needinfo?(gmarty)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.