Poor UI redraw performance on Linux.

RESOLVED DUPLICATE of bug 84920

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 84920
17 years ago
16 years ago

People

(Reporter: Ed McKenzie, Assigned: Kevin McCluskey (gone))

Tracking

({perf})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Mozilla-20011002 (and, in fact, every previous release) is quite slow at
redrawing on Linux/X11 as compared to Win32 and MacOS X.  Linked image is a
fairly grotesque screenshot taken after I dragged Mozilla around the screen for
a few seconds.

The Linux machine is an AMD K6-2/400 with 384MB RAM.  OS X testing was on an
iMac with a 500MHz G3 processor and 384MB RAM -- definitely a faster machine,
but with slower RAM.

I'm sure this bug has been reported elsewhere, but my search seems to have been
futile.

Comment 1

17 years ago
->XPapps (layout?, toolkit?)
Assignee: asa → pchen
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
QA Contact: doronr → sairuh
yes, either layout or imglib...
Assignee: pchen → attinasi
Component: XP Apps → Layout
Keywords: perf
QA Contact: sairuh → petersen
(Assignee)

Comment 3

17 years ago
Taking bug
Assignee: attinasi → kmcclusk
Target Milestone: --- → mozilla1.0.1
(Assignee)

Comment 4

17 years ago
Bulk moving Mozilla1.01 bugs to future-P1. I will pull from the future-P1 list
to schedule bugs for post Mozilla1.0 milestones
Priority: -- → P1
Target Milestone: mozilla1.0.1 → Future
(Assignee)

Updated

16 years ago
Priority: P1 → P3

Comment 5

16 years ago
I am _begging_ to get this fixed for the 1.3 version.  If it is not fixed my
company will have to continue using Netscape 4.76 on Red Hat 6.x for mail. Can
you believe it?  We are in the midst of migrating to Red Hat 8 and have really
hit a wall on this.

I believe that this bug may be the same or is very closely related to:

  Bug 84920
  Bug 89919 ?? maybe
  Bug 104176
  Bug 103241 
  Bug 136230
  Bug 163264

I am reporting the same message to these other bug nubmers.

This bug is extremely serious to those users that it affects and makes Mozilla
-- ESPECIALLY THE MAIL which does constant opening and closing of windows --
unusuable in a business/production environment.  Several reporters have stated
this, but so far -- after more than 18 months -- to no effect.

I believe that this bug has not received the proper attention because:

1) It was spread over many reports that used varying terminology. 

2) It was assigned to various people, one of whom appears to have been oblivious
about it before he become employed elsewhere. Nobody seems to have realized that
all these reports are about the same thing.

3) ***** The bug is less noticable on faster or dedicated systems that
developers and engineers are more likely to use. However, for a business user
working over a busy network, connecting to a busy server, it is a PRODUCTIVITY
KILLER.

The distillation of all the reports is:

PROBLEM:

A) Any screen redrawing resulting from window opening, closing, moving,
minimizing/maximizing, or resizing is EXTREMELY SLOW, particularly when multiple
Mozilla windows are open.  Redrawing is also very slow when focus is changed
from one mail folder to another or when the user right clicks on a mail folder
to get a context menu.

For example, when I move THIS browser window, I momentarily see FIVE (5)
duplicates of this window and I can count four seconds before all the screen
redrawing is done.  Resizing is even slower -- it take about an 8-count before
the screen is redrawn.  Closing this window also takes about an 8-count before
the screen is fully redrawn. Minimizing this window is quite bizzare; there are
about fifteen (15) momentary black-outlined rectangles getting smaller and
smaller as it minimizes; a 5-count before all redrawing is complete.

B) If you are working only in one screen typing like I am now, this is not a big
deal. However, _MAIL_ users are constantly opening message windows, changing
focus between IMAP folders, etc., etc.  As I have spent a couple days test using
the mail, I have made many mistakes because I thought all the redrawing was done
when it was not. As a result, messages have been dragged to the wrong folders,
folders have been expanded or unexpanded when I was trying to do the opposite,
etc.  (I have tons of experience using NS 4.76 doing the exact same work and
have never had any of these kinds of problems.)  This is a PRODUCTIVITY KILLER
for mail users.

C) Reporters have reported this on:
Linux X11
Linux (ver not stated) on a PC
Windows 95 PC
Windows NT4 PC
Windows NT 5.1
Windows 2000
OS X on iMac & G4 (but maybe only 10.2 or higher??)
Sun OS (version ?)
Solaris 2.8

D) All reporters seem to be reporting on reasonably (to very) fast machines with
decent to excellent amounts of RAM.

E) Several reporters have clearly stated that it is "virtually unusable" or
otherwise not useable in a business environment.  I must agree!

MY EXPERIENCE:

1) This Mozilla is running on a Red Hat 8 server to which we are migrating. Our
migration is essentially stalled until this issue is addressed.  I cannot
believe that I am going to have to keep running a Red Hat 6.x server to provide
Netscape 4.76 email to my staff!

  Red Hat 8.0 with kernel 2.4.18-18.8.0 and all but the latest (i.e. last two
weeks) updates via RH up2date. UW IMAP vers 2001a release 15 from Red Hat 
supplied RPMs (from RH install CD). 

  Mozilla 1.2.1 (Xft build) from Mozilla RPMs
  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

2) When we first saw the problem, we assumed that it was an X problem, so we
tested per the below.  The workstations are Windows 95 PCs (we hope to be
Microsoft free by the end of 2003!) running X windowing software to provide X
access to the Linux servers.

*** NOTE THAT THIS X WINDOWING (and 10 mb network in general) IS PROBABLY
PROVIDING SOME OF THE DELAY THAT MAKES THIS BUG MORE OBVIOUS.  (It is sort of
like testing an application over a 28.8 kb modem to see what is really going
on.) HOWEVER, _ALL_, I REPEAT _ALL_ OF OUR OTHER RH 6.X AND RH 8 APPLICATIONS DO
_NOT_ HAVE ANY OF THESE REDRAW SPEED ISSUES, EVEN WHEN THE NETWORK IS UNDER
HEAVY LOAD.

a) Tested through SCO's PC XVISION 7.32 running on Windows 95 running Mozilla
running on our RH 8 server.  Mozilla is the only application that shows any
redraw speed problems.  This is our oldest Xwindowing software.  The PCs tested
were 300 to 400 MHZ machines with 256 to 512 MB of RAM.

b) Tested through CYGWIN XFREE86 4.2 (the latest production release) running on
Windows 95 running Mozilla running on our RH 8 server. Mozilla is the only
application that shows any redraw speed problems.  On this newer Xwindowing
software, the redraw problem was perhaps 20% less (20% faster) than on the
XVISION. The PC tested with Cygwin (specifically installed for THIS test) is a
400 MHZ machine with 512 MB of RAM.

c) Tested directly on our Red Hat 8 server console (i.e. no network, PC, or
windowing software to slow things down) running DUAL 1 GB processors with 3
(three) _GB_ of RAM.  Redraw is noticable, but would not bother anybody. When
moving one Mozilla browswer window around on top of another, I get momentary
duplication of the chrome -- about five to six copies of the window. By
comparison, similar window movements of other application windows on this
machine do NOT show this delay -- for other applications, redraw is
instantaneous. However, as I said, it is perfectly usable -- BUT not every staff
member (none, in fact) can use the server as a workstation!

Please help!

Jay

Comment 6

16 years ago
Dupe.

*** This bug has been marked as a duplicate of 84920 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.