Closed Bug 1032446 Opened 6 years ago Closed 6 years ago

ContentClientIncremental::BeginPaintBuffer can return with|result.mClip| uninitialized

Categories

(Core :: Graphics: Layers, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1032440

People

(Reporter: erahm, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, Whiteboard: [CID 1157298])

Similar to bug 1032440, in various error/early return paths we return a PaintState that has an uninitialized |mClip| member. It's possible that calling code will then use this value.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1032440
You need to log in before you can comment on or make changes to this bug.