Invalid CalDAV calendar is not deleted on error

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: nicolas.golubovic+bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8448333 [details]
Python 3 implementation of a fake CalDAV server reproducing the issue.

When creating a new CalDAV calendar, an incomplete response of the CalDAV endpoint will leave the app in a strange state: The calendar is visible on the /advanced-settings/ view, but not in the /settings/. Additionally, it cannot be selected when choosing a calendar for an event.

I've attached a Python 3 implementation of a CalDAV server which does only respond to the first two CalDAV messages. It accepts any username/password combination and listens to port 5000. When trying to reproduce this bug, the app will drop back into the "Add new CalDAV calendar" view when trying to synchronize with this server. However, the calendar is already visible in the /advanced-settings/ then.

Another way to reproduce the bug is with Radicale [1]. If a username with URL special chars is chosen (e.g. "#"), the same bug appears. The reason for this is that they will be included in the URL without any encoding which leads to a invalid path on Radicale's side. However, I don't think this is the app's fault as Radicale suggests this improperly encoded URL itself and the app merely choses to follow it.


[1] http://radicale.org/

Comment 1

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.