Closed Bug 1032725 Opened 5 years ago Closed 5 years ago

Facebook contact infos are not reflected in call screen

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v1.3 unaffected, b2g-v1.4 affected, b2g-v2.0 verified, b2g-v2.1 verified)

RESOLVED FIXED
2.0 S6 (18july)
blocking-b2g 2.0+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- affected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: lolimartinezcr, Assigned: rik)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Tested
Hamachi
2.1
Gecko-deb9478
Gaia-c086196

Reproducible:100%

Pre-requisites: Contacts imported of FB (with phone number)

STRs:
1. Tap dialer aplication.
2. Write first digits of phone number (contact imported of FB).
3. When user sees list of suggestions, tap in an suggested contact.

Actual result:
User sees only phone number, *without* name and surname.

Expected result:
User sees name, surname and phone number.
Changing to the dialer component, since dialer needs to pick up the info from the Datastore where we save the contacts info.

If the info is not there, please just forward this to the contacts component.
Component: Gaia::Contacts → Gaia::Dialer
QA Wanted for branch checks.
Keywords: qawanted
QA Contact: ckreinbring
The bug repros on Flame 2.1, Flame 2.0, Flame 1.4 and Buri 2.1

Flame 2.1
Build ID: 20140709070635
Gaia: c394b7b4205b6f1a6ca44915fc08650f3ad127ec
Gecko: 2d88803a0b9c
Platform Version: 33.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 2.0
Build ID: 20140709085028
Gaia: 3316542e36084a8d1f6a5446abe9bf199765f3d7
Gecko: 394b7c158cf0
Platform Version: 32.0a2
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4
Build ID: 20140709000201
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Platform Version: 30.0
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 2.1
Build ID: 20140709070635
Gaia: c394b7b4205b6f1a6ca44915fc08650f3ad127ec
Gecko: 2d88803a0b9c
Platform Version: 33.0a1
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Actual result:  After dialing a partial number and tapping a suggestion from a Facebook contact, the call header will only show the phone number.  The contact's name and any associated picture will not be shown.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Tested in 1.3 and NOT reproducible:
Hamachi
1.3
Gecko-ff9cd48
Gaia-23f55be

Tested in 1.4 and reproducible:
Hamachi
1.4
Gecko-ff9cd48
Gaia-23f55be
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Assignee: nobody → jmcf
noming as 2.0+ as this is a regression from many versions ago
blocking-b2g: --- → 2.0?
Attached file 21816.html (obsolete) —
Etienne,

Please could you provide feedback on this? After a f+ I will deal with unit tests

thanks
Attachment #8456831 - Flags: feedback?(etienne)
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8456831 [details]
21816.html

shared/js/dialer/contacts.js already does the facebook look up in Contacts.findByNumber. Shouldn't the patch just add the Facebook datastore to the manifest? Why do you need to duplicate code in calls_handler.js and handled_call.js?
OK, the root cause here is that shared/js/dialer/contacts.js lookup tokenData in asyncStorage before trying to access the facebook. But callscreen never sets that tokenData. I don't know how this is done, I need to find out now.

Locally, I commented all the bailout code when the token is not set and it works for me.
Attachment #8456831 - Flags: feedback?(etienne) → feedback-
Summary: When user selects a contact (imported of FB) in list of suggestions, user can't see name when device is calling → Facebook contact infos are not reflected in call screen
It will probably be easier to review with https://github.com/mozilla-b2g/gaia/pull/21830/files?w=1

I have not written unit tests because there are none at the moment. I've opened bug 1039643 so we can start writing some in the next sprint.
Assignee: jmcf → anthony
Attachment #8456831 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8457050 - Flags: review?(drs+bugzilla)
Attachment #8457050 - Flags: review?(drs+bugzilla) → review+
Target Milestone: --- → 2.0 S6 (18july)
thanks Anthony for fixing. I didn't realize that the shared/dialer/contacts was already taking care of FB Contacts
Tested and working
Flame
2.1
Gecko-d2e992a
Gaia-bbcf53d

2.0
Gecko-f5e1264
Gaia-bf3fb88

Pending 1.4
Flags: in-testsuite?
Flags: in-testsuite? → in-qa-testsuite?(jlorenzo)
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+][lead-review+][fxosqa-auto-backlog?]
Flags: in-qa-testsuite?(jlorenzo)
Plussing, but the Facebook contact dependency might be an issue in the short term.
QA Whiteboard: [QAnalyst-Triage+][lead-review+][fxosqa-auto-backlog?] → [QAnalyst-Triage+][lead-review+][fxosqa-auto-backlog+]
You need to log in before you can comment on or make changes to this bug.