Closed Bug 103274 Opened 22 years ago Closed 19 years ago

Site Navigation Bar incorrect if viewing a bug not in the list

Categories

(Bugzilla :: Query/Bug List, defect, P2)

2.15

Tracking

()

RESOLVED FIXED
Bugzilla 2.20

People

(Reporter: bugzilla, Assigned: bugzilla)

Details

Attachments

(1 file, 1 obsolete file)

I like the great new 'Site Navigation Bar' - thanks to all involved at Mozilla
for that, and also the way that Bugzilla uses it, but I notice that sometimes it
(and also the old buglist navigation bar) get confused...

i.e.

If you have a buglist open, but then visit a bug not in the list (e.g. from a
bookmark, or by clicking on a link in an email etc.), then the navigation bar
and the links in the 'Site Navigation Bar' try and work, and
next/prev/first/last links are displayed, but you are not really still in the
buglist are you, so I don't think the links should exist, should they?

2 possible solutions are:

1) Add a 'nav-buglist' parameter to all the URLs in a buglist, and to all the
URLs in the navigation bars, and only use the buglist navigation bar + site
navigation bar if this parameter exists. (And in so doing stop using the buglist
cookie, and so maybe allowing multiple buglists to work?)

2) In showbug.cgi, check when generating the buglist navigation bar and the Site
Navigation Bar links if the bug being shown is actually part of the list, and
don't show or enable the links if it isn't.
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18
Assignee: endico → nobody
nobody@bugzilla.org cares about these poor bugs and they haven't been touched in
nearly 2 months.  No way they'll hit 2.18 unless something changes.  --> 2.20
If someone adopts them, they can pull them back in.
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Slightly morphing this bug from it's original, because some things are fixed, but I think there are still 
issues with the SIte Navigation Bar links. Specifically, if you are viewing a bug not in your list, thenthe 
'first' link does not appear, when it could do, and does in the navigation bar, and also the previous link 
is shown, when it should not be.

patch to follow.....
Summary: Buglist Navigation Bar & new <link> tags incorrect if viewing a bug not in the list → Site Navigation Bar incorrect if viewing a bug not in the list
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #150307 - Flags: review?
Comment on attachment 150307 [details] [diff] [review]
Patch which hopefully should fix the Site Navigation Bar links

Looks pretty good and seems to work, but it's a diff -w and a -c; I'm just not
going to read that ;-) Repatch with -u and let's see again then.
Attachment #150307 - Flags: review? → review-
Attachment #150307 - Attachment is obsolete: true
Attachment #152793 - Flags: review?(jouni)
Comment on attachment 152793 [details] [diff] [review]
fix navigation bar links (with correct path options)

r=jouni
Attachment #152793 - Flags: review?(jouni) → review+
Dave: Do you want this for 2.18? I think this is trunk stuff, but it's also a
zero-risk fix to a known (albeit non-critical) bug. It changes templates, but
only the technical html where no natural language exists, so it shouldn't break
localizations.
Severity: normal → minor
Flags: approval?
Flags: approval2.18?
Hmm, I need to understand what's going on here a little better...  What am I
looking for on landfill if I were to take a look at this?  (What's the site
navigation bar?)
(In reply to comment #8)
> Hmm, I need to understand what's going on here a little better...  What am I
> looking for on landfill if I were to take a look at this?  (What's the site
> navigation bar?)

Try Mozilla/Seamonkey and enable SNB through View menu. Bring up a bug query and
surf along; you'll note your browser has prev/next/first/last buttons on its
status bar. For Firefox, <http://extensionroom.mozdev.org/more-info/linktoolbar>
is the best bet. 

After that, the reproduction instructions in comment 0 probably make sense.
Oh, *that* site navigation bar.  Yeah, I use it all the time, just slipped my
brain because you didn't include "toolbar" in the description. :)

Nah, this is a convenience issue, and though it's low risk, it is touching a
template, and it's not mitigating any dataloss or major regressions.  2.20 will
be here before we know it.  (freeze in 2 months)
Flags: approval?
Flags: approval2.18?
Flags: approval2.18-
Flags: approval+
Checked in on trunk. Thanks for the patch!

Checking in template/en/default/global/site-navigation.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/site-navigation.html.tmpl,v
 <--  site-navigation.html.tmpl
new revision: 1.11; previous revision: 1.10
done
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
No longer blocks: 888655
You need to log in before you can comment on or make changes to this bug.