"Jump to the Stars" launches to a white screen on Firefox (32.0+)

RESOLVED WONTFIX

Status

()

Firefox for Android
Web Apps
P1
major
RESOLVED WONTFIX
4 years ago
a year ago

People

(Reporter: aaronmt, Assigned: myk)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox32 affected, firefox33 affected, firefox34 affected)

Details

(Whiteboard: [WebRuntime], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
https://marketplace.firefox.com/app/jump-to-the-stars?src=featured

{
	"name": "Jump to the Stars",
	"description": "Blast off and fly high into the sky! Put on your jetpack, wave goodbye to loved ones, and jump into the stars. Can you make it through the floating mines as you reach for your dreams?",
	"launch_path": "/index.html?dst=A0008&moregames=https%3A%2F%2Fmarketplace.firefox.com%2Fsearch%3Fq%3Dtresensa",
	"icons": {
		"32": "http://jumptothestars.tresensa.com/icons/32x32.png",
		"60": "http://jumptothestars.tresensa.com/icons/60x60.png",
		"90": "http://jumptothestars.tresensa.com/icons/90x90.png",
		"120": "http://jumptothestars.tresensa.com/icons/120x120.png",
		"256": "http://jumptothestars.tresensa.com/icons/256x256.png"
	},
	"developer": {
		"name": "TreSensa",
		"url": "http://www.tresensa.com"
	},
	"default_locale": "en",
	"orientation": ["portrait"],
	"fullscreen": "true",
	"appcache_path": "/cache.manifest",
    "chrome": { "navigation": true }
}

20140702030201
https://hg.mozilla.org/mozilla-central/rev/7075808c3306

Reproducible on my LG Nexus 5 (Android 4.4.4)

Steps to Reproduce

  Visit bug URL
  Install application
  Launch application from Marketplace

On install of interest:

W/InstallFlowAnalytics(14001): Failed to hash APK contents
W/InstallFlowAnalytics(14001): java.io.FileNotFoundException: /storage/emulated/0/Download/httpjumptothestarstresensacommanifestwebapp.apk: open failed: ENOENT (No such file or directory)
W/InstallFlowAnalytics(14001): 	at libcore.io.IoBridge.open(IoBridge.java:409)
W/InstallFlowAnalytics(14001): 	at java.io.FileInputStream.<init>(FileInputStream.java:78)
W/InstallFlowAnalytics(14001): 	at com.android.packageinstaller.InstallFlowAnalytics.getSha256ContentsDigest(InstallFlowAnalytics.java:593)
W/InstallFlowAnalytics(14001): 	at com.android.packageinstaller.InstallFlowAnalytics.getPackageContentsDigest(InstallFlowAnalytics.java:576)
W/InstallFlowAnalytics(14001): 	at com.android.packageinstaller.InstallFlowAnalytics.access$000(InstallFlowAnalytics.java:48)
W/InstallFlowAnalytics(14001): 	at com.android.packageinstaller.InstallFlowAnalytics$2.run(InstallFlowAnalytics.java:462)
W/InstallFlowAnalytics(14001): 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1112)
W/InstallFlowAnalytics(14001): 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:587)
W/InstallFlowAnalytics(14001): 	at java.lang.Thread.run(Thread.java:841)
W/InstallFlowAnalytics(14001): Caused by: libcore.io.ErrnoException: open failed: ENOENT (No such file or directory)
W/InstallFlowAnalytics(14001): 	at libcore.io.Posix.open(Native Method)
W/InstallFlowAnalytics(14001): 	at libcore.io.BlockGuardOs.open(BlockGuardOs.java:110)
W/InstallFlowAnalytics(14001): 	at libcore.io.IoBridge.open(IoBridge.java:393)
W/InstallFlowAnalytics(14001): 	... 8 more
(Reporter)

Comment 1

4 years ago
Thinking this might be bug 1003962.
(Reporter)

Comment 2

4 years ago
Still reproducible on Nightly (07/08) on my Samsung Galaxy SV (Android 4.4.4)
(Assignee)

Updated

4 years ago
Severity: normal → major
Priority: -- → P1
Whiteboard: [WebRuntime]
(Reporter)

Comment 3

4 years ago
I'm concerned that this will soon be on Beta. I am confirming that Aurora (32.0a2) is affected.
status-firefox32: ? → affected
(Reporter)

Comment 4

4 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> Thinking this might be bug 1003962.

Still reproducible on Nightly (07/16) with that fix on trunk.
(Assignee)

Comment 5

4 years ago
I'll take a look at this.
Assignee: nobody → myk
Status: NEW → ASSIGNED
(Assignee)

Comment 6

4 years ago
Hmm, I can't reproduce this on my Nexus 5 w/Android 4.4.4 and the latest Nightly build, nor can I reproduce it on my Nexus 4 w/Android 4.4.4 and a custom build from the tip of Central.  I do see the same InstallFlowAnalytics warning messages in my log, but they don't seem to prevent the app from launching and running as expected.

aaronmt: Can you attach a log from before you press the Free button in Marketplace until after the white screen of sorrow appears?
Flags: needinfo?(aaron.train)
(Reporter)

Comment 7

4 years ago
Created attachment 8457427 [details]
gecko-logcat.log
Flags: needinfo?(aaron.train)
(Reporter)

Updated

4 years ago
Attachment #8457427 - Attachment mime type: text/x-log → text/plain
(Reporter)

Comment 8

4 years ago
Created attachment 8457437 [details]
raw-logcat.log
(Reporter)

Comment 9

3 years ago
This is still broken on trunk.
status-firefox34: --- → affected
(Reporter)

Updated

3 years ago
Summary: "Jump to the Stars" launches to a white screen on Nightly (33.0a1) → "Jump to the Stars" launches to a white screen on Firefox (32.0+)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1122315
(Assignee)

Comment 11

2 years ago
Per bug 1235869, we're going to disable the Android web runtime, so we won't fix this bug in it.

(This is part of a bulk resolution of bugs in the Firefox for Android::Web Apps component, from which I attempted to exclude bugs that are not specific to the runtime, but it's possible that I included one accidentally.  If so, I'm sorry, and please reopen the bug!)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.