[Vertical Homescreen] Icons become semi-transparent while scrolling

RESOLVED DUPLICATE of bug 1038416

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1038416
4 years ago
3 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [2.0-VH-bug-bash][systemsfe])

(Reporter)

Description

4 years ago
Build Information
Device: Flame
Gaia      3bfe47c58c959c42f5ffe0309b5380ea514ccd69
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/f40e767ea283
BuildID   20140702000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

Steps to Reproduce
1. Install 70 more apps
2. Add 12 more Smart Collections
3. Scroll from the top to the bottom and vice-versa

Actual Results
Icon are often semi-transparent until the scoll move is finished.

Other Notes
I encountered it with less apps than noted in the STR but I was able to hit it more often with that amount.
(Reporter)

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Component: Gaia::Homescreen → Graphics
Product: Firefox OS → Core
Kats/Chris - Could one of you guys check if this is related to progressive paint?
Flags: needinfo?(chrislord.net)
Flags: needinfo?(bugmail.mozilla)
This is likely a result of the changes made in bug 1020778. We reduced the opacity of low-res content by 50% so that low-res text looks better and less jarring. It's a bit of a tradeoff because now images look more transparent. You can try adjusting the layers.low-precision-opacity pref to somewhere between 0.5 and 1.0 to see where you get the best results between images and text.
Blocks: 1020778
Flags: needinfo?(chrislord.net)
Flags: needinfo?(bugmail.mozilla)
Doing a ni? on UX to see if they are happy with this behavior. To reproduce this one, you will likely need to install a few dozen apps from the marketplace onto the device, then scroll.

Eventually you will notice the icons have some opacity to them before they res-in.
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 4

4 years ago
Flagging Gordon since we have Jacqueline and Peter out this week.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(gbrander)
Going to block bug 1017954 instead as this is implemented as intended. We'll see if we need to improve the UX here though.
Blocks: 1017954
No longer blocks: 1015336
QA Wanted for a video.
Keywords: qawanted

Updated

4 years ago
blocking-b2g: --- → backlog
(Reporter)

Comment 7

4 years ago
Video link: http://mzl.la/1mooaBB
It's very subtle on the video. You can see the transparent icons in the middle of the scrolling.
Keywords: qawanted
This is working as intended. It's a side-effect of a workaround for low-res tiling:

- Low res tiling causes text to look darker and fatter because the text is rendered at a low quality.
- This "fat text" causes a noticeable visual jump when transitioning from low-res to hi-res tile.
  It's pretty bad.
- As a workaround, we decided to reduce the opacity of the low res tile. This prevents the tile jump
  from being noticed in nearly all cases.

For cases where the background follows the content scroll, you can't tell the difference. For this case, you can.

Options available to us:

- Investigate other workarounds (may be difficult)
- Tune the opacity to try to find a sweet spot between not not noticing fat text and not noticing opacity.

Needsinfo Rob MacDonald. Let's review and come up with a course of action.
Flags: needinfo?(gbrander) → needinfo?(rmacdonald)
(In reply to Gordon Brander :gordonb from comment #8)
> - Tune the opacity to try to find a sweet spot between not not noticing fat
> text and not noticing opacity.

The opacity is a pref, layers.low-precision-opacity. It currently defaults to "0.5" on B2G, which is 50% opacity. You can adjust it upwards to reduce the transparency. Note that it is a float value pref, so it needs to be entered as a string when using edit-prefs.sh.
The patches on bug 1038416 make the icons opaque again. Clearing ni flag as we seem to be ok here.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(rmacdonald)
Resolution: --- → DUPLICATE
Duplicate of bug: 1038416
No longer blocks: 1017954
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.