Open Bug 1033622 Opened 5 years ago Updated 11 months ago

[geckoview] localStorage fails to load on pages loaded from the Assets using jar:file protocol

Categories

(GeckoView :: General, defect, P5)

All
Android
defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: dpupek, Unassigned, NeedInfo)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

Created an app with a GeckoView and the following prefs:
PrefsHelper.setPref("dom.storage.enabled", true);

A page is loaded into the view from the Assets directory. The page attempts to use localStorage and tries obtaining a reference to localStorage.


Actual results:

the following error is thrown:
[Exception... "Component is not available"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: debugger eval code :: <TOP_LEVEL> :: line 1"  data: no]

No errors appear in logcat


Expected results:

The localStorage object should be available for storing items.
Blocks: geckoview
OS: Windows 7 → Android
Hardware: x86_64 → x86
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think this is due to the profile missing.
We'd need to set the storage location to some app-private directory.
Summary: localStorage fails to load in GeckoView → localStorage fails to load in GeckoView on pages loaded from the Assets using jar:file protocol
Title change: Ah, so localStorage works for http pages. Just not for assets under jar:file: protocol.

That also means that comment 1 is wrong.

FWIW, I'm affected by this, too.
This probably a good case for fixing Bug 948465

That would allow us to not have to use the jar:file protocol
Hardware: x86 → All
Summary: localStorage fails to load in GeckoView on pages loaded from the Assets using jar:file protocol → [geckoview] localStorage fails to load on pages loaded from the Assets using jar:file protocol
Mass change of bugs in the "Embedding: GRE Core" component in preparation for archiving it. I believe that these are no longer relevant; but if they are, they should be reopened and moved into a component relevant to the code in question.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
Product: Core → Core Graveyard
Reopening and moving to Core::Embedding: APIs, where we'll continue to triage and track GeckoView issues, but this might be wontfix if it isn't useful now that bug 948465 has been fixed.
Status: RESOLVED → REOPENED
Component: Embedding: GRE Core → Embedding: APIs
Product: Core Graveyard → Core
Resolution: INCOMPLETE → ---
Component: Embedding: APIs → GeckoView
Product: Core → Firefox for Android
Kevin, can you see if this still happens?
Flags: needinfo?(kbrosnan)
Temporary p5 until I get a chance to investigate.
Priority: -- → P5
Product: Firefox for Android → GeckoView
You need to log in before you can comment on or make changes to this bug.