TwoWayView crashes in Android L

VERIFIED FIXED in Firefox 32

Status

()

defect
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: lucasr, Assigned: lucasr)

Tracking

(Blocks 1 bug)

unspecified
Firefox 33
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox32+ verified, firefox33 verified, firefox34 verified, fennec32+)

Details

Attachments

(2 attachments)

Upstream ticket: https://github.com/lucasr/twoway-view/issues/70

E/AndroidRuntime( 6162): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2255)
E/AndroidRuntime( 6162): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2317)
E/AndroidRuntime( 6162): at android.app.ActivityThread.access$800(ActivityThread.java:143)
E/AndroidRuntime( 6162): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1258)
E/AndroidRuntime( 6162): at android.os.Handler.dispatchMessage(Handler.java:102)
E/AndroidRuntime( 6162): at android.os.Looper.loop(Looper.java:135)
E/AndroidRuntime( 6162): at android.app.ActivityThread.main(ActivityThread.java:5070)
E/AndroidRuntime( 6162): at java.lang.reflect.Method.invoke(Native Method)
E/AndroidRuntime( 6162): at java.lang.reflect.Method.invoke(Method.java:372)
E/AndroidRuntime( 6162): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:836)
E/AndroidRuntime( 6162): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:631)
E/AndroidRuntime( 6162): Caused by: android.view.InflateException: Binary XML file line #16: Error inflating class org.lucasr.twowayview.TwoWayView
E/AndroidRuntime( 6162): at android.view.LayoutInflater.createView(LayoutInflater.java:629)
E/AndroidRuntime( 6162): at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:739)
E/AndroidRuntime( 6162): at android.view.LayoutInflater.rInflate(LayoutInflater.java:802)
E/AndroidRuntime( 6162): at android.view.LayoutInflater.rInflate(LayoutInflater.java:805)
E/AndroidRuntime( 6162): at android.view.LayoutInflater.inflate(LayoutInflater.java:500)
E/AndroidRuntime( 6162): at android.view.LayoutInflater.inflate(LayoutInflater.java:410)
E/AndroidRuntime( 6162): at com.checkthis.frontback.fragments.DiscoverFragment.onCreateView(DiscoverFragment.java:99)
E/AndroidRuntime( 6162): at android.support.v4.app.Fragment.performCreateView(Fragment.java:1478)
E/AndroidRuntime( 6162): at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:927)
E/AndroidRuntime( 6162): at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1104)
E/AndroidRuntime( 6162): at android.support.v4.app.BackStackRecord.run(BackStackRecord.java:682)
E/AndroidRuntime( 6162): at android.support.v4.app.FragmentManagerImpl.execPendingActions(FragmentManager.java:1460)
E/AndroidRuntime( 6162): at android.support.v4.app.FragmentActivity.onStart(FragmentActivity.java:556)
E/AndroidRuntime( 6162): at android.app.Instrumentation.callActivityOnStart(Instrumentation.java:1217)
E/AndroidRuntime( 6162): at android.app.Activity.performStart(Activity.java:5736)
E/AndroidRuntime( 6162): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2218)
E/AndroidRuntime( 6162): ... 10 more
E/AndroidRuntime( 6162): Caused by: java.lang.reflect.InvocationTargetException
E/AndroidRuntime( 6162): at java.lang.reflect.Constructor.newInstance(Native Method)
E/AndroidRuntime( 6162): at java.lang.reflect.Constructor.newInstance(Constructor.java:288)
E/AndroidRuntime( 6162): at android.view.LayoutInflater.createView(LayoutInflater.java:603)
E/AndroidRuntime( 6162): ... 25 more
E/AndroidRuntime( 6162): Caused by: java.lang.UnsupportedOperationException: Can't convert to dimension: type=0x3
E/AndroidRuntime( 6162): at android.content.res.TypedArray.getDimensionPixelSize(TypedArray.java:562)
E/AndroidRuntime( 6162): at android.view.View.initializeScrollbars(View.java:4357)
E/AndroidRuntime( 6162): at org.lucasr.twowayview.TwoWayView.(TwoWayView.java:389)
E/AndroidRuntime( 6162): at org.lucasr.twowayview.TwoWayView.(TwoWayView.java:313)
E/AndroidRuntime( 6162): ... 28 more
tracking-fennec: --- → 32+
Not 31+?
I thought 32 is our first release on L? blassey?
Flags: needinfo?(blassey.bugs)
Comment on attachment 8453751 [details] [diff] [review]
Part 1: Update TwoWayView from upstream (r=mfinkle)

Mostly a bunch of refactorings + scrollbar code changes that fix the crasher in L.
Attachment #8453751 - Flags: review?(mark.finkle)
Comment on attachment 8453752 [details] [diff] [review]
Part 2: Explicit set scrollbars in TabsTray (r=mfinkle)

Scrollbars now need to be explicitly set.
Attachment #8453752 - Flags: review?(mark.finkle)
32 will be released on 9/2. We expect Andoid L sometime in October, so tracking for 32 is right.
Flags: needinfo?(blassey.bugs)
Attachment #8453751 - Flags: review?(mark.finkle) → review+
Comment on attachment 8453752 [details] [diff] [review]
Part 2: Explicit set scrollbars in TabsTray (r=mfinkle)

I missed this request somehow...
Attachment #8453752 - Flags: review?(mark.finkle) → review+
Comment on attachment 8453751 [details] [diff] [review]
Part 1: Update TwoWayView from upstream (r=mfinkle)

Approval Request Comment
[Feature/regressing bug #]: The upcoming Android L release.
[User impact if declined]: Crash on startup.
[Describe test coverage new/current, TBPL]: Local testing with the upstream sample app.
[Risks and why]: Low, we're removing code that explicit sets the default scrollbar behaviour in the widget. 
[String/UUID change made/needed]: n/a
Attachment #8453751 - Flags: approval-mozilla-aurora?
Comment on attachment 8453752 [details] [diff] [review]
Part 2: Explicit set scrollbars in TabsTray (r=mfinkle)

Approval Request Comment
[Feature/regressing bug #]: The upcoming Android L release.
[User impact if declined]: Crash on startup.
[Describe test coverage new/current, TBPL]: Local testing with the upstream sample app.
[Risks and why]: Low, we're removing code that explicit sets the default scrollbar behaviour in the widget. 
[String/UUID change made/needed]: n/a
Attachment #8453752 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ee57ae5dc806
https://hg.mozilla.org/mozilla-central/rev/fc0750213b61
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Part 1 is a fairly big change, even if it is low risk. I'd like to give this another day to bake on Nightly before considering for uplift.
(In reply to Lawrence Mandel [:lmandel] from comment #13)
> Part 1 is a fairly big change, even if it is low risk. I'd like to give this
> another day to bake on Nightly before considering for uplift.

Ping
Attachment #8453752 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8453751 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Taking it to make sure it is part of the first beta of 32.
No crashing on my Nexus 7 on L Preview
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.