Make slow script debugging work in e10s

RESOLVED DUPLICATE of bug 1118618

Status

defect
RESOLVED DUPLICATE of bug 1118618
5 years ago
Last year

People

(Reporter: shu, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [e10s-m7])

Currently the slow script debug button is hooked up via an XPCom service (nsISlowScriptDebug) during initialization code for the debugger.

In e10s, there will be 2 copies of this service for the content and chrome processes. The current way won't work, as the debugger initialization code is in the chrome process and needs to hook up to the service in the content process.
Blocks: dte10s
tracking-e10s: --- → +
These DevTools bugs should probably block e10s from riding to Aurora.
devtools bugs will block the e10s merge to Aurora, but blassey would like them to be tracked by dte10s meta bug 875871, not the tracking-e10s=m6+ flag.
Whiteboard: [e10s-m6]
Whiteboard: [e10s-m6] → [e10s-m7]
This will be fixed in bug 1118618.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118618
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.