Closed Bug 1034254 Opened 5 years ago Closed 5 years ago

crash in OOM | small (generic out of memory case, only solvable with general memory usage reductions)

Categories

(Firefox :: General, defect, critical)

All
Windows
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox30 - wontfix
firefox31 + wontfix
firefox32 + wontfix
firefox33 + wontfix

People

(Reporter: guigs, Unassigned)

References

()

Details

(Keywords: crash, topcrash-win, Whiteboard: [unactionable][please file reproducible cases in separate bugs, dupe non-reproducible ones here])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-dcbe53c4-9d14-4cbe-a195-86ba12140701.
=============================================================
From user reporting this in the support forum: 
Thread: [https://support.mozilla.org/en-US/questions/1008953]

Hardware: Intel HD Graphics Family chipset, 
Driver version 9.18.10.3272. 

Hardware 2: Lenovo Ultrabook quad core Core i5 with 8GB RAM running 
Memory: Intel HD Graphics 3000 chipset 
OS: Win 7 SP 
Driver: driver version 9.17.10.2043.

On two computers and currently asking form memory reports
This is our #1 topcrash in Beta accounting for over 9% of our crashes. I think this is expected though given our recent OOM reporting changes in Socorro. Nominating to track so someone can double check this.
This is just indicating that we are running out of memory, without the actual location of the crash being directly relevant to that. There is nothing we can do about the concrete cases here. The only thing we can do is to work towards using less memory overall, which we are doing, but the bug itself is not actionable.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
(In reply to Mario Rossi from comment #4)
> "wontfix" is no good... :-( 

Hi Mario,

WONTFIX in this case does not mean we aren't going to fix OOM crashes. OOM|Small is a catch-all for several different crashes under the OOM umbrella and we don't intend to fix *all* of them in this bug report. Many of these crashes are being tracked and investigated in other bug reports.

I can only speculate that these might occur more frequently in some cases in Firefox because we don't provide official support of win64 builds just yet. Win32 builds have a great limiting factor in the memory they can address compared to win64 builds, no matter how much ram your system has.

I hope this clarifies your concerns.
That said, there is an issue here. My latest crash:
bp-2babfb22-6400-4aa1-aee3-b980f2140806	06/08/2014	10:13

0 	xul.dll 	NS_ABORT_OOM(unsigned int) 	xpcom/base/nsDebugImpl.cpp

How is it out of memory?
Available Virtual Memory 	181190656
Available Page File 	3240423424
Available Physical Memory 	1056993280
Maybe interesting for the followers of this bug:
Bug 1045588 - FireFox Crash due to CSS Animations
This bug have also the crash signature [@ OOM | small ].
See Also: → 1045588, 1047871
See Also: → 1048619
Bug 1048619 have crash signature [@ OOM | small] and seems to be reproducible with opening an URL.
(In reply to Tobias B. Besemer from comment #9)
> Bug 1048619 have crash signature [@ OOM | small] and seems to be
> reproducible with opening an URL.

(In reply to Tobias B. Besemer from comment #8)
> Maybe interesting for the followers of this bug:
> Bug 1045588 - FireFox Crash due to CSS Animations
> This bug have also the crash signature [@ OOM | small ].

All of those should have specific bugs, and reproducible cases deserve to be worked on, but please do not turn this into a tracker. The majority of those cases are just unactionable and do not need to be tracked in any way.
See Also: 1045588, 1047871, 1048619
(In reply to Robert Kaiser (:kairo@mozilla.com, slow reaction due to vacation backlog) from comment #10)
> (In reply to Tobias B. Besemer from comment #9)
> > Bug 1048619 have crash signature [@ OOM | small] and seems to be
> > reproducible with opening an URL.
> 
> (In reply to Tobias B. Besemer from comment #8)
> > Maybe interesting for the followers of this bug:
> > Bug 1045588 - FireFox Crash due to CSS Animations
> > This bug have also the crash signature [@ OOM | small ].
> 
> All of those should have specific bugs, and reproducible cases deserve to be
> worked on, but please do not turn this into a tracker. The majority of those
> cases are just unactionable and do not need to be tracked in any way.

It was just intended for the followers of this bug to see that there are other bugs with this crash signature they can have a look on.
Was in replay to:

(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #5)
> (In reply to Mario Rossi from comment #4)
> > "wontfix" is no good... :-( 
> 
> Hi Mario,
> 
> WONTFIX in this case does not mean we aren't going to fix OOM crashes.
> OOM|Small is a catch-all for several different crashes under the OOM
> umbrella and we don't intend to fix *all* of them in this bug report. Many
> of these crashes are being tracked and investigated in other bug reports.
Summary: crash in OOM | small → crash in OOM | small (generic out of memory case, not sdolvable)
Whiteboard: [unactionable][please file reproducible cases in separate bugs, dupe non-reproducible ones here]
Summary: crash in OOM | small (generic out of memory case, not sdolvable) → crash in OOM | small (generic out of memory case, only solvable with general memory usage reductions)
I have a reproducible OOM | Small test-case on Android.

LG Nexus 5 (Android 4.4.4)

Visit: http://www.reddit.com/r/askscience/comments/28vajr/if_i_had_a_sealed_room_filled_with_butane_gas_and/ and pinch-zoom in.

Crashes 100%
Duplicate of this bug: 1047871
Duplicate of this bug: 1065416
Duplicate of this bug: 1067604
Since updating to Firefox 32 (and the .x releases), I've been getting OOM freezes and eventually crashes.  I think it may be related to the Java 7 plugin since it seems to occur once I use that.  Even without Java though, Firefox's memory grows at a very fast rate, making me think there's a memory leak in the Firefox 32 branch.
Blocks: 1096831
Duplicate of this bug: 1105888
(In reply to Seb A from comment #6)
> You need to start supporting win64 builds. On my 64-bit Windows laptop, I
> got bored of memory problems and switched to using Waterfox and performance
> was increased, crashes were reduced, the maximum memory that the browser
> process could use and still be responsive was also much increased.

(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #5)
> (In reply to Mario Rossi from comment #4)
> > "wontfix" is no good... :-( 
> 
> Hi Mario,
> 
> WONTFIX in this case does not mean we aren't going to fix OOM crashes.
> OOM|Small is a catch-all for several different crashes under the OOM
> umbrella and we don't intend to fix *all* of them in this bug report. Many
> of these crashes are being tracked and investigated in other bug reports.
> 
> I can only speculate that these might occur more frequently in some cases in
> Firefox because we don't provide official support of win64 builds just yet.
> Win32 builds have a great limiting factor in the memory they can address
> compared to win64 builds, no matter how much ram your system has.
> 
> I hope this clarifies your concerns.

I have enough memory free on my Windows 7 Pro 32 Bits and Firefox is crashing all the time with this error :
bp-ec4dff98-2b65-4e8e-83ed-bd2252150128	28-01-2015	07:27
bp-b7c2d40e-d509-45da-94ae-cb7cb2150127	27-01-2015	15:49
bp-9dcf821b-4bd8-4580-aeff-31edd2150127	27-01-2015	14:06
bp-83728659-ecc5-48b7-8a9c-6ac152150127	27-01-2015	07:24
bp-9bcfa475-6468-42e0-a31b-0725a2150127	26-01-2015	19:45
bp-261f11ea-364d-4b08-bc20-0de182150126	26-01-2015	16:24
bp-438b99e7-efd1-4090-bf5d-9fcc82150126	26-01-2015	15:05
bp-1ef5ea40-fff3-4048-945c-243e22150126	26-01-2015	13:58
bp-a680251d-9f0a-49d7-ac21-878e62150126	26-01-2015	13:10
bp-7665cf01-5145-4dba-8840-bf2c32150126	26-01-2015	12:38
bp-18c0e756-8011-4324-849b-3b8292150126	26-01-2015	06:28
Flags: needinfo?(nobody)
Flags: needinfo?(nobody)
(In reply to Le Troll from comment #18)
> I have enough memory free on my Windows 7 Pro 32 Bits and Firefox is crashing all the time with this error.

Thanks for letting us know. Could you please file a new bug report explaining the circumstances that lead up to these crashes? It seems like it's happening several times a day and not a whole lot of people will be paying attention to this bug report since it's closed.

I also recommend you post your issue to support.mozilla.org to see if someone on our Support team can help you troubleshooting and work around this issue.
Duplicate of this bug: 1182793
¡Hola Kairo!

Could something be done in Socorro, Crash Pad or somewhere else so [@ OOM | small ] crashed produced a bit more information?

[@ OOM | small ] is my wife's top #1 crash and doesn't really help the case of me wasting my afternoons poking at Firefox bugs =)

Report ID 	Date Submitted
bp-ca775dcf-26cb-429c-8a2b-b21542151217
	17/12/2015	02:39 p.m.
bp-f44a40c0-940d-4260-b0ce-6a4d22151217
	17/12/2015	12:27 p.m.
bp-9a811e8f-fa97-4eae-b2ee-ca3442151216
	16/12/2015	01:05 p.m.
bp-df6dafbd-be96-482f-840b-fb3302151216
	16/12/2015	10:11 a.m.
bp-a6536fad-10aa-4f28-9266-025b92151214
	14/12/2015	12:05 p.m.
bp-d2dbb354-0f0b-40e3-8684-87ff52151211
	11/12/2015	10:32 a.m.
bp-45a41f75-1dc5-4511-b2e9-c7e622151209
	09/12/2015	04:06 p.m.
bp-981bb668-8666-494d-9ae1-02c4b2151209
	09/12/2015	09:24 a.m.
bp-20ca137b-c7c0-4bbd-b367-2a3bb2151207
	07/12/2015	12:48 p.m.
bp-95ce8741-a64e-4057-ab99-bf9ee2151204
	04/12/2015	12:35 p.m.

¡Gracias!
Flags: needinfo?(kairo)
OOM|small intentionally has no more details as signature as it means that we ran out of memory on just trying to use a very little more, so the fault lies in whatever filled the memory, not in the exact place the crash occurred in.
Flags: needinfo?(kairo)
I experienced this bug last year and the problem was related to my BIOS config. My processor was configured as turbo mode (not overclocked) and my system was a lot instable (even if the processor was not overheating). I changed the setting to "normal mode" in the BIOS and this error never triggered again after. My system is now stable since 6 months. In my case, it was cause by hardware. I suppose that bad processor or bad memory can produce this bug.

If your system is unstable and you get a lot of "WHEA-Logger" errors in your Event Log, you are probably able to fix this bug in your BIOS.
Win7, 64bit, FF49.0a2:
"Update Missing Favicons" with the Xmarks-Extension
https://crash-stats.mozilla.com/report/index/b09a305e-b177-49e3-81da-3d6e32160802
OS: Windows NT → Windows
Hardware: x86 → All
Version: 30 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.