flame v2.0 does not wake for line app push notifications

RESOLVED WORKSFORME

Status

()

Core
DOM: Push Notifications
P3
normal
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: bkelly, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [dogfood2.0])

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1025926 +++

As originally reported in bug 1025926 I had a lot of problems with push notifications on my flame.  QA in that bug showed, however, that notifications would occur as long as Line is running, but even in the background.  They did this on devices other than a flame.

I also just saw that on my open c I could get the phone woken up with Line running in the background for a push notification.

On my flame v2.0, though, I would never get notifications until I manually brought Line to the foreground.  It seems there is some device specific problem here.  Something in the RIL?
(Reporter)

Comment 1

4 years ago
Can you QA test line push notifications on the flame v2.0?  Specifically with the app running, but in the background and the screen locked.
Keywords: qawanted
Component: General → DOM: Push Notifications
Product: Firefox OS → Core

Updated

4 years ago
blocking-b2g: --- → backlog
Is it possible that the device is switching off cellular data? In which case push could be delayed for several minutes (upto 30min) depending on what the TCP stack decides to tell us about failure.

Is it possible to get a logcat log without having the phone connected to a computer? (because receiving power over USB means it won't sleep).
Hi, 

Do we have any update on this issue? 

Thanks!
David

Comment 4

4 years ago
David, this bug is specific to the push notification issue on Flame devices. There is another bug (https://bugzilla.mozilla.org/show_bug.cgi?id=1025926) which LINE provided a fix with their version 1.3 currently available in the marketplace. So in short, that bug is fixed.
(In reply to Ben Kelly [:bkelly] from comment #1)
> Can you QA test line push notifications on the flame v2.0?  Specifically
> with the app running, but in the background and the screen locked.

Issue is reproducible on latest Flame 2.0.

STR:
Pre-requisites:
Flame is connected via Wifi. USB is unplugged. DUT and another device both have LINE installed and are friends with each other.

1) Launch Line
2) Hit Home button to put Line in background
3) Press power button to put device to sleep
4) Wait for 10+ minutes
5) On another device send a LINE message to DUT

- Observe that DUT will not receive a notification until LINE app is accessed again on DUT.

Repro rate: 3/3.

For step 4, I've tried waiting for 5 minutes and it didn't repro for 5-min (tried twice and both times received notifications fine). I've not tested using Data connection, since it was not specified.

Tested on:
Device: Flame
Build ID: 20140801133546
Gaia: 7681c18524b50c9d3a760c876c222578e6e13eef
Gecko: 040d2ba2210b
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Can we also do branch checks here?
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
QA Contact: pcheng
Issue is reproducible on Flame 1.4, Flame 2.1, and Buri 2.0.

Device fails to receive push notification from LINE after letting it sleep for 10 minutes. I waited 5 minutes for the push notification before determining it a fail.

Tested on:
Device: Flame
Build ID: 20140804095929
Gaia: 9377274b17200a60cebcd2427d489a7756c4cc72
Gecko: 60d3725443a5
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Device: Flame
Build ID: 20140804041427
Gaia: af9a0a24fb9f4c5ced3602bc14053bd49b136344
Gecko: 71497ed2e0db
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Buri
Build ID: 20140804060132
Gaia: 4ab7384db7aee130be165a699472cc19405a4456
Gecko: 5e94ab16ec71
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Reporter)

Comment 8

4 years ago
So this seems to be working better for me ever since I moved to v123 base software.  Can you do a test run with v123 and v2.0 gecko/gaia?
Keywords: qawanted
(In reply to Ben Kelly [:bkelly] from comment #8)
> So this seems to be working better for me ever since I moved to v123 base
> software.  Can you do a test run with v123 and v2.0 gecko/gaia?

Issue still reproduces in v123 base + latest 2.0.
Device does not receive a push notification while sleeping without charging for 10+ minutes. 

Tested on:
Device: Flame
Build ID: 20140805093658
Gaia: 92d2815f3ec3bd9b35c0e2de8dc34cdf5a3bda19
Gecko: b0a276a774bb
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review-]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][lead-review-] → [QAnalyst-Triage+][lead-review-]
Flags: needinfo?(jmitchell)
(Reporter)

Comment 10

4 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #9)
> Issue still reproduces in v123 base + latest 2.0.
> Device does not receive a push notification while sleeping without charging
> for 10+ minutes. 

All I can say is my v123 device with v2.0 is working correctly.  It is waking up to deliver LINE notifications even after sitting untouched, with the screen off, for over an hour.

When you ran this test, did you perform a full device wipe?  I wonder if there is something stale left in the profile or IDB from old LINE installs.
(In reply to Ben Kelly [:bkelly] from comment #10)
> All I can say is my v123 device with v2.0 is working correctly.  It is
> waking up to deliver LINE notifications even after sitting untouched, with
> the screen off, for over an hour.
> 
> When you ran this test, did you perform a full device wipe?  I wonder if
> there is something stale left in the profile or IDB from old LINE installs.

I flash Gaia & Gecko on top of v123 Gonk. I don't know what's different between your configuration and mine. Feel free to close the bug since it is working for you.

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][lead-review-] → [QAnalyst-Triage+][lead-review+]
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
Closing this bug as reporter was not able to reproduce it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.