Tabbing through a web page no longer focuses on anchor tags

RESOLVED DUPLICATE of bug 239175

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 239175
4 years ago
4 years ago

People

(Reporter: peter_novack, Unassigned)

Tracking

30 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

I was using on a web page and tabbing was working fine. The next day perhaps after a FF update I can no longer tab to anchor tags on any website. I reset FF, FF preferences and reinstalled but still cannot tab to an anchor tag. OS is OS X 10.9.3


Actual results:

I can tab to input fields etc. but anchor tags are skipped while tabbing on every web site I visit despite resetting FF to default settings.


Expected results:

Anchor tags should not be skipped while tabbing.

Comment 1

4 years ago
In your Mac's System Preferences > Keyboard > Shortcuts, do you have "Full Keyboard Access" toggled to "Text boxes and lists only" instead of "All controls" ?
Flags: needinfo?(peter_novack)
(Reporter)

Comment 2

4 years ago
Setting Full Keyboard Access to All controls does fix the problem. That setting did not affect other browsers such as Chrome/Safari. Thanks!
Flags: needinfo?(peter_novack)

Comment 3

4 years ago
(In reply to peter_novack from comment #2)
> Setting Full Keyboard Access to All controls does fix the problem. That
> setting did not affect other browsers such as Chrome/Safari. Thanks!

This is because they have their own pref (or Safari does, at least) rather than honoring the system option. I don't think we want to follow suit. Marco?
Flags: needinfo?(marco.zehe)

Comment 4

4 years ago
Well, sometimes I wish we would, and enable tabbing to all focusable elements by default, since this is off by default when you install OS X, and the fact that we honor that setting is a point of confusion for many web developrs and users, especially when they know about the separate setting in Safari.

But I also believe in tight system integration, and am leaning towards leaving our behavior as is.
Flags: needinfo?(marco.zehe)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 239175
You need to log in before you can comment on or make changes to this bug.