Closed Bug 1034493 Opened 6 years ago Closed 3 years ago

Usage app shows no user feedback while loading data

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: gerard-majax, Unassigned)

References

Details

(Keywords: feature, foxfood, Whiteboard: [NaBfT])

As reported in bug 1034490, when loading the data that takes 30+secs, I have no user feedback informing me that it's doing something.
Adding qawanted to check this on branches and confirm the regression.
Keywords: qawanted
Marina is checking in bug 1034490 if there is a problem regarding a big amount of data stored
As tested and stated in https://bugzilla.mozilla.org/show_bug.cgi?id=1034490#c7 , QA Wanted is unable to reproduce this issue.

Since a night has passed, I tested the Usage app on Flame 2.0 in a 2-day-span and it still displays both wifi and data correctly & immediately upon accessing the app.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
(In reply to Pi Wei Cheng (piwei) from comment #3)
> As tested and stated in
> https://bugzilla.mozilla.org/show_bug.cgi?id=1034490#c7 , QA Wanted is
> unable to reproduce this issue.
> 
> Since a night has passed, I tested the Usage app on Flame 2.0 in a
> 2-day-span and it still displays both wifi and data correctly & immediately
> upon accessing the app.

A night VS profile dating from v1.0.1 ? I'm not sure you are comparing the same amount of data.
(In reply to Alexandre LISSY :gerard-majax from comment #4)
> A night VS profile dating from v1.0.1 ? I'm not sure you are comparing the
> same amount of data.

It was never mentioned in your STR (if there is one) that your 'profile' is from v1.0.1.
I wasn't aware that Firefox accounts are supported earlier than v2.0 either, but then someone else pointed out to me that by 'profile', it's not firefox accounts that you're referring to.
This could be nice improvement to have in future releases, not something we would blockship a release for.
blocking-b2g: 2.0? → backlog
(In reply to bhavana bajaj [:bajaj] [NOT reading Bugmail, needInfo please] from comment #1)
> Adding qawanted to check this on branches and confirm the regression.

There seems to be something specific about the data being used for the Usage App. QA-Wanted is currently unable to repro this. Once the particulars are hammered out we can re-visit the branch-check request.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Whiteboard: [NaBfT]
blocking-b2g: backlog → ---
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.