Closed Bug 1035529 Opened 9 years ago Closed 8 years ago

crash in mscorlib.ni.dll@0x180284 with Bandoo datamngr/safetynut (Movies Toolbar)

Categories

(Core :: General, defect)

31 Branch
x86
Windows NT
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Tracking Status
firefox31 + wontfix
firefox32 --- ?

People

(Reporter: u279076, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-989dc9d2-9be3-4972-89c7-b6e7f2140701.
=============================================================
0 	mscorlib.ni.dll 	mscorlib.ni.dll@0x180284 	
1 	mscorwks.dll 	mscorwks.dll@0x18f7a 	
2 	mscorwks.dll 	mscorwks.dll@0x255fc 	
3 	mscorwks.dll 	mscorwks.dll@0x2562f 	
4 	mscorwks.dll 	mscorwks.dll@0x2564d 	
5 	mscorwks.dll 	mscorwks.dll@0x8b757 	
6 	mscorwks.dll 	mscorwks.dll@0x8b5c4 	
7 	mscorwks.dll 	mscorwks.dll@0xf5a86 	
8 	mscorwks.dll 	mscorwks.dll@0xf5b2a 	
9 	mscorwks.dll 	mscorwks.dll@0xf5b4e 	
10 	mscorwks.dll 	mscorwks.dll@0x8b41c 	
11 	mscorwks.dll 	mscorwks.dll@0x1c183e 	
12 	mscorwks.dll 	mscorwks.dll@0x1b9e55 	
13 	mscorwks.dll 	mscorwks.dll@0xa1b25 	
14 	mscoreei.dll 	DllGetClassObject 	
15 	mscoree.dll 	ShellShim_DllGetClassObject 	
16 	combase.dll 	CClassCache::CDllPathEntry::DllGetClassObject(_GUID const &,_GUID const &,IUnknown * *,int) 	d:\win8_gdr\com\combase\objact\dllcache.cxx:3883
17 	combase.dll 	CClassCache::GetClassObject(ACTIVATION_PROPERTIES const &) 	
18 	combase.dll 	CClassCache::GetClassObject(ACTIVATION_PROPERTIES const &) 	d:\win8_gdr\com\combase\objact\dllcache.cxx:5633
19 	combase.dll 	CServerContextActivator::CreateInstance(IUnknown *,IActivationPropertiesIn *,IActivationPropertiesOut * *) 	d:\win8_gdr\com\combase\objact\actvator.cxx:999
20 	combase.dll 	ActivationPropertiesIn::DelegateCreateInstance(IUnknown *,IActivationPropertiesOut * *) 	
21 	combase.dll 	combase.dll@0x27610 	
22 	combase.dll 	CProcessActivator::CCICallback(unsigned long,IUnknown *,ActivationPropertiesIn *,IActivationPropertiesIn *,IActivationPropertiesOut * *) 	d:\win8_gdr\com\combase\objact\actvator.cxx:1765
23 	combase.dll 	CProcessActivator::ActivateByContext(ActivationPropertiesIn *,IUnknown *,IActivationPropertiesIn *,IActivationPropertiesOut * *,long ( CProcessActivator::*)(unsigned long,IUnknown *,ActivationPropertiesIn *,IActivationPropertiesIn *,IActivationPropertiesOut * *)) 	
24 	combase.dll 	combase.dll@0x272cf 	
25 	combase.dll 	combase.dll@0x273a9 	
26 	combase.dll 	ActivationPropertiesIn::DelegateCreateInstance(IUnknown *,IActivationPropertiesOut * *) 	
27 	combase.dll 	combase.dll@0x250d7 	
28 	combase.dll 	ActivationPropertiesIn::DelegateCreateInstance(IUnknown *,IActivationPropertiesOut * *) 	
29 	combase.dll 	combase.dll@0x25ba6 	
30 	combase.dll 	CoCreateInstance 	d:\win8_gdr\com\combase\objact\actapi.cxx:110
31 	shell32.dll 	shell32.dll@0x20c07a 	
32 	shell32.dll 	shell32.dll@0x20c96e 	
33 	shell32.dll 	shell32.dll@0xa1d8d 	
34 	shell32.dll 	shell32.dll@0xa125a 	
35 	shell32.dll 	shell32.dll@0x337f35 	
36 	shell32.dll 	shell32.dll@0x337ce9 	
37 	explorerframe.dll 	UIItemsView::ShowContextMenu(tagPOINT const *) 	
38 	explorerframe.dll 	CItemsView::ShowContextMenu(tagPOINT const *) 	
39 	shell32.dll 	shell32.dll@0x337da8 	
40 	shell32.dll 	shell32.dll@0x33290c 	
41 	shell32.dll 	shell32.dll@0x5c5ddd 	
42 	shell32.dll 	shell32.dll@0x137c7 	
43 	user32.dll 	InternalCallWinProc 	
44 	user32.dll 	UserCallWinProcCheckWow 	
45 	user32.dll 	CallWindowProcAorW 	
46 	user32.dll 	CallWindowProcW 	
47 	duser.dll 	DeferredMsgQueue::DeferMessage(tagGMSG *,DuEventGadget *,HROOTGADGET__ *,unsigned int,MsgObject *) 	
48 	user32.dll 	InternalCallWinProc 	
49 	user32.dll 	UserCallWinProcCheckWow 	
50 	user32.dll 	DispatchClientMessage 	
51 	user32.dll 	__fnDWORD 	
52 	ntdll.dll 	KiUserCallbackDispatcher 	
53 	ntdll.dll 	KiUserApcDispatcher 	
54 	user32.dll 	RealDefWindowProcW 	
55 	uxtheme.dll 	uxtheme.dll@0x1701 	
56 	uxtheme.dll 	uxtheme.dll@0x17af 	
57 	user32.dll 	NtUserMessageCall 	
58 	explorerframe.dll 	floor 	
59 	user32.dll 	InternalCallWinProc 	
60 	user32.dll 	UserCallWinProcCheckWow 	
61 	user32.dll 	CallWindowProcAorW 	
62 	user32.dll 	CallWindowProcW 	
63 	duser.dll 	ExtraInfoWndProc(HWND__ *,unsigned int,unsigned int,long) 	
64 	user32.dll 	InternalCallWinProc 	
65 	user32.dll 	UserCallWinProcCheckWow 	
66 	user32.dll 	CallWindowProcAorW 	
67 	user32.dll 	CallWindowProcW 	
68 	comctl32.dll 	CallOriginalWndProc 	
69 	comctl32.dll 	MasterSubclassProc 	
70 	comctl32.dll 	DefSubclassProc 	
71 	explorerframe.dll 	UIItemsView::_UIItemsViewSubclassProc(HWND__ *,unsigned int,unsigned int,long,unsigned int) 	
72 	explorerframe.dll 	UIItemsView::s_UIItemsViewSubclassProc(HWND__ *,unsigned int,unsigned int,long,unsigned int,unsigned long) 	
73 	comctl32.dll 	MasterSubclassProc 	
74 	comctl32.dll 	DefSubclassProc 	
75 	explorerframe.dll 	CToolTipManager::_PropertyToolTipSubclassProc(HWND__ *,unsigned int,unsigned int,long,unsigned int) 	
76 	explorerframe.dll 	CToolTipManager::s_PropertyToolTipSubclassProc(HWND__ *,unsigned int,unsigned int,long,unsigned int,unsigned long) 	
77 	comctl32.dll 	MasterSubclassProc 	
78 	comctl32.dll 	TTSubclassProc(HWND__ *,unsigned int,unsigned int,long,unsigned int,unsigned long) 	
79 	comctl32.dll 	MasterSubclassProc 	
80 	comctl32.dll 	MasterSubclassProc 	
81 	user32.dll 	InternalCallWinProc 	
82 	user32.dll 	UserCallWinProcCheckWow 	
83 	user32.dll 	DispatchMessageWorker 	
84 	user32.dll 	IsDialogMessageW 	
85 	user32.dll 	IsDialogMessageW 	
86 	user32.dll 	InternalDialogBox 	
87 	user32.dll 	DialogBoxIndirectParamAorW 	
88 	user32.dll 	DialogBoxIndirectParamW 	
89 	comdlg32.dll 	CFileOpenSave::Show(HWND__ *) 	
99 	xul.dll 	nsBaseAppShell::Run() 	widget/xpwidgets/nsBaseAppShell.cpp
100 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
101 	nss3.dll 	nss3.dll@0x7930 	
102 	xul.dll 	NS_InitXPCOM2 	xpcom/build/nsXPComInit.cpp
103 	mozalloc.dll 	moz_free 	memory/mozalloc/mozalloc.cpp
104 	xul.dll 	nsComponentManagerImpl::QueryInterface(nsID const &,void * *) 	xpcom/components/nsComponentManager.cpp
105 	xul.dll 	nsCOMPtr_base::assign_from_qi(nsQueryInterface,nsID const &) 	xpcom/glue/nsCOMPtr.cpp
106 	xul.dll 	mozilla::dom::workers::WorkerPrivateParent<mozilla::dom::workers::WorkerPrivate>::LocationInfo::LocationInfo() 	
107 	xul.dll 	XREMain::XRE_main(int,char * * const,nsXREAppData const *) 	toolkit/xre/nsAppRunner.cpp
108 	xul.dll 	xul.dll@0x14f8f88 
=============================================================
More Reports:
https://crash-stats.mozilla.com/report/list?product=Firefox&signature=mscorlib.ni.dll%400x180284

This crash has been around in low volume for a long time (reports go back to Firefox 4). However, something seems to be causing a spike recently in Beta.

Firefox 29.0.1 has 68 crashes per 59 installs (1.15:1)
Firefox 30 has 1058 crashes per 840 installs (1.26:1)
Firefox 31b7 has 279 crashes per 87 installs (3.21:1)

Based on the following report, it seems to have started to climb significantly on July 4 (this correlates to the release of Firefox 31.0b7):
https://crash-analysis.mozilla.com/rkaiser/2014-07-06/2014-07-06.firefox.beta.explosiveness.html
Nominating for tracking because of the escalating volume, but this isn't a topcrash. I'm not sure what to do about this one. Does anyone know what product this DLL belongs to?
> Does anyone know what product this DLL belongs to?
mscorlib is part of the Microsoft .NET framework, but it's likely not at fault here.

This is likely the same as bug 1035534 and bug 1035537. Since this is now the third such bug that I've seen, maybe we combine them and see whether the total volume meets Sylvestre's thresholds.

     69% (33/48) vs.   2% (2598/105725) Datamngr.dll
     69% (33/48) vs.   3% (2686/105725) mgrldr.dll
     67% (32/48) vs.   2% (1665/105725) DatamngrHlpFF30.dll
     58% (28/48) vs.   2% (2504/105725) apcrtldr.dll(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #1)
(In reply to David Major [:dmajor] from comment #2)
> This is likely the same as bug 1035534 and bug 1035537. Since this is now
> the third such bug that I've seen, maybe we combine them and see whether the
> total volume meets Sylvestre's thresholds.

Here are the 7-day combined signature stats for Beta:
* 1323 crashes for bug 1035537
* 1364 crashes for bug 1035534
* 1038 crashes for bug 1035529
Total: 3725 crashes

This is the #10 topcrash on Beta if we combine all signatures. If this is being caused by an add-on then perhaps we can block it and see if what impact it has on these signatures?
Sylvestre, what do you think?
Flags: needinfo?(sledru)
If we can merge those three bug reports and it makes it a topcrash, tracking it.

Do we know enough about this add-on to be able to block it?
Flags: needinfo?(sledru)
Flags: needinfo?(dmajor)
We should at least reach out to Bandoo once again, they have been receptive in the past and correcting crashes seen with DataMngr (even though we're seeing them too often in our crash stats for my taste).
Yes, Bandoo were helpful last time. Let's see if they can push out a fix for this.
Flags: needinfo?(dmajor)
Summary: crash in mscorlib.ni.dll@0x180284 → crash in mscorlib.ni.dll@0x180284 with Bandoo datamngr/safetynut (Movies Toolbar)
Hi all, I'm passing this to my team right now. I will keep you updated.
We see that very similar issue was already fixed and released but probably not distributed enough yet. Please provide datamngr.dll version number that cause this problem so we could see if this is old or new issue. Thanks.
In this signature, we are seeing crashes from 5.0.0.13251, 5.0.0.13277, and 5.0.0.13350.

However, in other signatures, we are still getting crash reports from older versions like 5.0.0.13001. Does that mean your app is not auto-updating?
Flags: needinfo?(michael)
If this requires a fix in Firefox itself, it is too late for 31.
Benjamin, would it make sense to plan to turn experiments like this off around Beta 8 so we can know what the release is going to look like?  Or, do the various experiments need to run for absolutely the entire beta cycle? Thanks!
Flags: needinfo?(benjamin)
(In reply to Sylvestre Ledru [:sylvestre] from comment #11)
> If this requires a fix in Firefox itself, it is too late for 31.

Michael, see also bug 1035537 and bug 1035534. These are also crashing with safetynut which I believe is Bandoo. In total volume this is our #7 topcrash in Firefox 31.

Sylvestre, do you think it would be possible to prepare a block for this in case it explodes in release and cannot be addressed by Bandoo?
(In reply to Liz Henry :lizzard from comment #12)
> Benjamin, would it make sense to plan to turn experiments like this off
> around Beta 8 so we can know what the release is going to look like?  Or, do
> the various experiments need to run for absolutely the entire beta cycle?
> Thanks!

I think you want bug 944873, not this one.
Flags: needinfo?(benjamin)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #14)
>> (In reply to Liz Henry :lizzard from comment #12)
> I think you want bug 944873, not this one.

Actually, from Crashkill, the bug you want is bug 1012924.
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #13)
> (In reply to Sylvestre Ledru [:sylvestre] from comment #11)
> Sylvestre, do you think it would be possible to prepare a block for this in
> case it explodes in release and cannot be addressed by Bandoo?
Are you proposing a dot release or a hot fix?
(In reply to Sylvestre Ledru [:sylvestre] from comment #16)
> (In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #13)
> > (In reply to Sylvestre Ledru [:sylvestre] from comment #11)
> > Sylvestre, do you think it would be possible to prepare a block for this in
> > case it explodes in release and cannot be addressed by Bandoo?
>
> Are you proposing a dot release or a hot fix?

If possible, I think a hotfix would be the least disruptive to our users. However I don't know the technical possibilities of either approach. FWIW, I have no evidence to indicate we *need* to do this yet -- it's merely a preventative proposal (ie. so we have something ready if we need it).
(In reply to Sylvestre Ledru [:sylvestre] from comment #16)
> Are you proposing a dot release or a hot fix?

If this can be blocked by add-on blocklisting, we don't need either, we just need to ship and add-on blocklist update, which we always can do dynamically.
If we'd need to do DLL blocklisting, that only can be done with a new build, so would need a dot.release.
According to DMajor, bug 1041581 may be another Bandoo related crash.
Hi. I am stepping in for Michael from Bandoo, who is on vacation. Just wanted to update that we are currently working on a fix which will be released in a few days.
(In reply to Alex Romanov from comment #20)
> Hi. I am stepping in for Michael from Bandoo, who is on vacation. Just
> wanted to update that we are currently working on a fix which will be
> released in a few days.

Thanks Alex! Please keep us updated.
We have released the potential fix for the problem. Please update if you are still seeing the problem and in which versions. Thanks Alex
Thanks Alex. I am not seeing these crash signatures after version 5.0.0.13350, and volume in general has gone down.
Flags: needinfo?(michael)
I'm marking this fixed based on volume. As with David, I see no crashes with the new DLL version.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.