Closed Bug 1035557 Opened 6 years ago Closed 6 years ago

about:sessionrestore shows instead of about:welcomeback after a reset

Categories

(Firefox :: Session Restore, defect)

29 Branch
defect
Not set
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 34
Iteration:
34.3
Tracking Status
firefox30 --- wontfix
firefox31 --- wontfix
firefox32 --- verified
firefox33 + verified
firefox34 --- verified
firefox-esr31 --- wontfix

People

(Reporter: MattN, Assigned: smacleod)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(3 files)

After a reset, "Well. this is embarrasing" is shown instead of "Welcome Back!".

Could somebody find a regression range so we know which versions to track the regression for?
Flags: firefox-backlog?
Iteration: --- → 33.3
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/316466d0b962
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140117114854
Bad:
http://hg.mozilla.org/mozilla-central/rev/fad7172d4542
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140117115833
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=316466d0b962&tochange=fad7172d4542

Regression window(fx)
Good:
http://hg.mozilla.org/integration/fx-team/rev/af860898eb79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140116153922
Bad:
http://hg.mozilla.org/integration/fx-team/rev/10256adb9f9e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140117024217
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=af860898eb79&tochange=10256adb9f9e

Suspect:
10256adb9f9e	Steven MacLeod — Bug 887780 - Stop writing state immediately after startup and switch to CrashMonitor for crash detection. r=Yoric, r=ttaubert X-Git-Commit-ID: bb02f51399059295041176769438b0f451f983bf
Depends on: 887780
Version: unspecified → 29 Branch
Thanks Alice
Blocks: 887780
No longer depends on: 887780
Good catch, we assume that no CrashMonitor data == big crash, but in fact, this could also mean fresh profile.
Hrmpf. *raises guilty hand*

If only I'd spent more time chasing bug 888624... :-\
Assignee: nobody → dteller
This version of the patch should be upliftable. We might wish for something a little more robust for FF33 as bug 883609 introduces more data that may be used to know with certainly that there is no sessionstore.js.
Attachment #8452270 - Flags: review?(smacleod)
Attachment #8452270 - Flags: review?(smacleod) → review+
Iteration: 33.3 → ---
https://hg.mozilla.org/mozilla-central/rev/77728b5c5d7d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
Iteration: --- → 33.3
QA Whiteboard: [qa?]
Flags: firefox-backlog? → firefox-backlog+
You don't need tracking on this any longer do you?
Flags: needinfo?(dteller)
QA Whiteboard: [qa?] → [qa+]
QA Contact: cornel.ionce
Benjamin: How do I determine that? I have never been involved in tracking flags so far.
Flags: needinfo?(dteller)
Reproduced the bug on Firefox 31 RC.
Verified the bug on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.7.5 using latest Nightly 33.0a1 (buildID: 20140717030339) and the following mentions should be done: 
- the page which is displayed after resetting Firefox is "Thank you for using Firefox Nightly" (which is the page displayed when opening Firefox with a new profile)
- after resetting Firefox, the actual profile is replaced with a new profile (e.g: default-14056...)
- after resetting Firefox, a new folder named "Old Firefox Data" is created on Desktop

Any thoughts?
Flags: needinfo?(dteller)
QA Contact: cornel.ionce → camelia.badau
Well, my thought is that we clearly need to uplift this.
Flags: needinfo?(dteller)
Comment on attachment 8452270 [details] [diff] [review]
Empty crash file != crash

Approval Request Comment
[Feature/regressing bug #]: bug 887780
[User impact if declined]: Firefox Reset causes the "Oops" welcome page to be displayed instead of the First Use
[Describe test coverage new/current, TBPL]: This has been on m-c for ~1 week, + QAed
[Risks and why]: None that I can think of.
[String/UUID change made/needed]: None.
Attachment #8452270 - Flags: approval-mozilla-beta?
Attachment #8452270 - Flags: approval-mozilla-aurora?
David, you will learn more about tracking flags here:
https://wiki.mozilla.org/Release_Management/Tracking_rules

Too late for 31. Too bad, I would have take this :/
Attachment #8452270 - Flags: approval-mozilla-beta?
Attachment #8452270 - Flags: approval-mozilla-beta-
Attachment #8452270 - Flags: approval-mozilla-aurora?
Attachment #8452270 - Flags: approval-mozilla-aurora+
(In reply to Camelia Badau, QA [:cbadau] from comment #11)
> Reproduced the bug on Firefox 31 RC.
> Verified the bug on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.7.5
> using latest Nightly 33.0a1 (buildID: 20140717030339) and the following
> mentions should be done: 
> - the page which is displayed after resetting Firefox is "Thank you for
> using Firefox Nightly" (which is the page displayed when opening Firefox
> with a new profile)
> - after resetting Firefox, the actual profile is replaced with a new profile
> (e.g: default-14056...)
> - after resetting Firefox, a new folder named "Old Firefox Data" is created
> on Desktop


Is this the behaviour intended? Or those are bugs?
Flags: needinfo?(dteller)
This looks correct.
Flags: needinfo?(dteller)
Iteration: 33.3 → 34.1
(In reply to Camelia Badau, QA [:cbadau] from comment #16)
> (In reply to Camelia Badau, QA [:cbadau] from comment #11)
> > Reproduced the bug on Firefox 31 RC.
> > Verified the bug on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.7.5
> > using latest Nightly 33.0a1 (buildID: 20140717030339) and the following
> > mentions should be done: 
> > - the page which is displayed after resetting Firefox is "Thank you for
> > using Firefox Nightly" (which is the page displayed when opening Firefox
> > with a new profile)

Err, unless I'm missing something, this doesn't look correct. If you:

- open 3 pages in tabs before resetting (e.g. www.mozilla.org, bugzilla, about:mozilla);
- then open about:support in another tab and click the reset button

you should see the "about:welcomeback" page which lists the 3 or 4 tabs, shouldn't you?
Flags: needinfo?(dteller)
Flags: needinfo?(camelia.badau)
Oh. In that case, I am clearly the wrong interlocutor for this. Someone else who knows Firefox Reset better than me should answer Camelia.
Flags: needinfo?(dteller)
(In reply to :Gijs Kruitbosch (Gone July 26 - August 3) from comment #18)
> (In reply to Camelia Badau, QA [:cbadau] from comment #16)
> > (In reply to Camelia Badau, QA [:cbadau] from comment #11)
> > > Reproduced the bug on Firefox 31 RC.
> > > Verified the bug on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.7.5
> > > using latest Nightly 33.0a1 (buildID: 20140717030339) and the following
> > > mentions should be done: 
> > > - the page which is displayed after resetting Firefox is "Thank you for
> > > using Firefox Nightly" (which is the page displayed when opening Firefox
> > > with a new profile)
> 
> Err, unless I'm missing something, this doesn't look correct. If you:
> 
> - open 3 pages in tabs before resetting (e.g. www.mozilla.org, bugzilla,
> about:mozilla);
> - then open about:support in another tab and click the reset button
> 
> you should see the "about:welcomeback" page which lists the 3 or 4 tabs,
> shouldn't you?

Matt, can you clarify per comment #19?
Flags: needinfo?(MattN+bmo)
Looks like we're just waiting for an update from Matt on this one.
Flags: needinfo?(camelia.badau)
(In reply to :Gijs Kruitbosch (Gone July 26 - August 3) from comment #20)
> (In reply to :Gijs Kruitbosch (Gone July 26 - August 3) from comment #18)
> > (In reply to Camelia Badau, QA [:cbadau] from comment #16)
> > > (In reply to Camelia Badau, QA [:cbadau] from comment #11)
> > > > Reproduced the bug on Firefox 31 RC.
> > > > Verified the bug on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.7.5
> > > > using latest Nightly 33.0a1 (buildID: 20140717030339) and the following
> > > > mentions should be done: 
> > > > - the page which is displayed after resetting Firefox is "Thank you for
> > > > using Firefox Nightly" (which is the page displayed when opening Firefox
> > > > with a new profile)
> > 
> > Err, unless I'm missing something, this doesn't look correct. If you:
> > 
> > - open 3 pages in tabs before resetting (e.g. www.mozilla.org, bugzilla,
> > about:mozilla);
> > - then open about:support in another tab and click the reset button
> > 
> > you should see the "about:welcomeback" page which lists the 3 or 4 tabs,
> > shouldn't you?
> 
> Matt, can you clarify per comment #19?

You should see about:welcomeback and the firstrun tab that Camelia described. Unfortunately the firstrun tab  will be the selected one since that firstrun code knows nothing about sessionrestore. This has been a known issue for a while as it interacts poorly with some other startup stuff but I'm not sure it's filed so it should be.

Comment 11 wasn't explicit about whether there was more than one tab. If about:welcomeback wasn't opened then that is definitely a problem which needs a bug.
Flags: needinfo?(MattN+bmo)
(In reply to Camelia Badau, QA [:cbadau] from comment #11)
> Reproduced the bug on Firefox 31 RC.
> Verified the bug on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.7.5
> using latest Nightly 33.0a1 (buildID: 20140717030339) and the following
> mentions should be done: 
> - the page which is displayed after resetting Firefox is "Thank you for
> using Firefox Nightly" (which is the page displayed when opening Firefox
> with a new profile)

Camelia, can you doublecheck this bit wrt comment #22 ? Thank you!
Flags: needinfo?(camelia.badau)
I double checked this and here are the steps and the conclusions: 

1. Open 3 pages in tabs(e.g. www.mozilla.org, bugzilla, about:mozilla)
2. Open about:support in another tab and click the Reset button.
3. a) Select to import data from Firefox (on "Import Settings and Data" dialog). 
   b) Select "don't import anything" (on "Import Settings and Data" dialog). 

-> After step 3 a), the "Restore Session" page is opened (with "Well, this is embarrassing"). See screenshot "import.PNG"
-> After step 3 b), the "Nightly Start Page" and the firstrun tab are opened. See screenshot "don't import.PNG".
Flags: needinfo?(camelia.badau)
Ok, so it sounds like there is still a bug.

I am in a wrong position to handle this bug at the moment, as I'll be on PTO in two days. Steve, any chance you could take a look at this? I believe that the best way to fix this is to patch SessionFile.read to add a field to `result` that tells us if at least one of the files of `loadOrder` exists.
Flags: needinfo?(smacleod)
Status: RESOLVED → REOPENED
Iteration: 34.1 → ---
Resolution: FIXED → ---
(In reply to Camelia Badau, QA [:cbadau] from comment #24)
>    b) Select "don't import anything" (on "Import Settings and Data" dialog). 

Note that "don't import anything" isn't really a valid choice for this dialog after a reset. That page of the wizard isn't even supposed to be shown. That's bug 1032958.

It sounds 3A which is valid is still incorrect though.
(In reply to David Rajchenbach Teller [:Yoric] from comment #26)
> I believe that
> the best way to fix this is to patch SessionFile.read to add a field to
> `result` that tells us if at least one of the files of `loadOrder` exists.

That is what bug 1036341 is about, right?
(In reply to Tim Taubert [:ttaubert] from comment #28)
> (In reply to David Rajchenbach Teller [:Yoric] from comment #26)
> > I believe that
> > the best way to fix this is to patch SessionFile.read to add a field to
> > `result` that tells us if at least one of the files of `loadOrder` exists.
> 
> That is what bug 1036341 is about, right?

For the most part yeah. I'll take care of Bug 1036341 and this one.
Assignee: dteller → smacleod
Iteration: --- → 34.1
Points: --- → 3
Flags: needinfo?(smacleod)
Added to Iteration 34.1
Status: REOPENED → ASSIGNED
Iteration: 34.1 → 34.2
Attachment #8471081 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/mozilla-central/rev/07e19701c947
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Iteration: 34.2 → 34.3
QA Whiteboard: [qa+]
Flags: qe-verify+
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.8.5 using latest Nightly 34.0a1 (buildID: 20140819030202). 

Changing the Target Milestone and the status flags to reflect the current situation.
Status: RESOLVED → VERIFIED
Target Milestone: Firefox 33 → Firefox 34
Can we try to uplift the second patch for 32/33 still, Steven?
Flags: needinfo?(smacleod)
Comment on attachment 8471081 [details] [diff] [review]
Patch - Migrate crash checkpoints with the session so that we don't appear to crash during reset

Approval Request Comment
[Feature/regressing bug #]: Regressed by Bug 887780
[User impact if declined]: Successful resets will show the "Well. this is embarrasing" crash page instead of the "Welcome back!" page.
[Describe test coverage new/current, TBPL]: No automated test coverage.
[Risks and why]: Should be low risk, just copying one more file from the old profile when migrating.
[String/UUID change made/needed]: None
Attachment #8471081 - Flags: approval-mozilla-beta?
Attachment #8471081 - Flags: approval-mozilla-aurora?
Flags: needinfo?(smacleod)
Attachment #8471081 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8471081 [details] [diff] [review]
Patch - Migrate crash checkpoints with the session so that we don't appear to crash during reset

I'm going to take this for the final 32 beta as it looks to be very low risk and a user visible reward.
Attachment #8471081 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified fixed on:
- Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.4 using latest Aurora 33.0a2 (buildID: 20140821004002)
- Ubuntu 13.10 32bit and Mac OSX 10.9.4 using Firefox 32 Beta 9 (buildID: 20140822024446)
Verified on Win7 using Fx32b9(build1) with the steps in comment #24. I get a "Welcome Back!" page after reset.
This doesn't meet ESR landing criteria, without an ESR community request there's no need to take this.
You need to log in before you can comment on or make changes to this bug.