Closed Bug 1035646 Opened 5 years ago Closed 5 years ago

[Collection App] Drag icons over edit header like vertical home

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1 verified)

RESOLVED FIXED
2.0 S6 (18july)
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- verified

People

(Reporter: crdlc, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Whiteboard: [systemsfe]
Attached file Github pull request
Thanks for the review
Attachment #8452174 - Flags: review?(kgrandon)
Comment on attachment 8452174 [details]
Github pull request

Hey Cristian,

I am noticing some strange behavior where the icon y-axis shifts way up on the page (instead of tracking your finger), when dragging over the header. It's more noticeable the closer you get to the top edge of the phone. Could you take a look?
Attachment #8452174 - Flags: review?(kgrandon)
Is it because of bug 1033444?

(In reply to Kevin Grandon :kgrandon from comment #2)
> Comment on attachment 8452174 [details]
> Github pull request
> 
> Hey Cristian,
> 
> I am noticing some strange behavior where the icon y-axis shifts way up on
> the page (instead of tracking your finger), when dragging over the header.
> It's more noticeable the closer you get to the top edge of the phone. Could
> you take a look?
I can confirm that it works fine with bug 1033444
Flags: needinfo?(kgrandon)
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Sounds good. I took a look with that patch applied and the dragging does seem to work. I can't leave R+ yet though, because I noticed that there is a regression in the opacity animation, which seems unintended. Can you check it?
Flags: needinfo?(kgrandon)
Comment on attachment 8452174 [details]
Github pull request

Addressed comments, thanks
Attachment #8452174 - Flags: review?(kgrandon)
Comment on attachment 8452174 [details]
Github pull request

Seems to work for me, thanks!
Attachment #8452174 - Flags: review?(kgrandon) → review+
Merged in master:

https://github.com/crdlc/gaia/commit/218d44185863f6b8286365860cf71d76be85b885
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S6 (18july)
Attached video video
This issue has been verified successfully on Flame 2.1.
According to bug 1033444 comment 5, both collections and vertical homescreen have the same behavior now. See attachment: Verify_1035646.MP4
Reproducing rate: 0/5

Flame2.1 build:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
You need to log in before you can comment on or make changes to this bug.