[B2G][First Time User] support 24 hour time format

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: hochang, Unassigned)

Tracking

unspecified
2.1 S3 (29aug)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.1)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

5 years ago
There will be a setting toggle to let user choose between 12/24 hour time format in v2.1. User story and settings spec: Bug 903683

For each app, the tasks to do after toggle is added would be:
1.Read/listen to the time format toggle value/change event.

2.Input the corresponding time format to existing mozL10n.DateTimeFormat() function. Currently the input time format should be a fixed 12 hour 
shortTimeFormat = %I:%M %p , line 201 of http://goo.gl/DR4CNe. There will be a 24 hour time format added.

3.Show the return of the function as it's doing now.
Whiteboard: [systemsfe]
Duplicate of this bug: 1042753
I check a little bit of FTU and does not find any place to show date time.
If its right we could close this issue.
Flags: needinfo?(francisco)
Target Milestone: --- → 2.1 S3 (29aug)
(In reply to Fred Lin [:gasolin] from comment #2)
> I check a little bit of FTU and does not find any place to show date time.
> If its right we could close this issue.

Yes,

that's true :)
Flags: needinfo?(francisco)
\o/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.