ToS notice in Loop popup window points to wrong URL

RESOLVED FIXED in Firefox 34

Status

Hello (Loop)
Client
P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: RT, Assigned: standard8)

Tracking

unspecified
mozilla35
Points:
1
Dependency tree / graph
Bug Flags:
in-moztrap +
qe-verify -

Firefox Tracking Flags

(firefox34 fixed, firefox35 fixed)

Details

(Whiteboard: [loop-uplift])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
The current ToS notice points to https://accounts.firefox.com/en-us/legal/terms
The Loop ToS are on https://github.com/mozilla/legal-docs/blob/master/WebRTC_ToS/en-US.md

ALthough we're awaiting confirmation about the URL to use.

This bug is to track:
* Confirmation of URL pointing to Loop ToS
* Implementation on the Loop desktop client
(Reporter)

Comment 1

4 years ago
Shell please confirm the URL when you get the info.
Flags: needinfo?(sescalante)

Updated

4 years ago
Whiteboard: --do_not_change-- [mozilla33 carry over]
Target Milestone: mozilla33 → mozilla34

Updated

4 years ago
Whiteboard: --do_not_change-- [mozilla33 carry over] → [mozilla33 carry over]

Updated

4 years ago
Flags: needinfo?(sescalante)
Whiteboard: [mozilla33 carry over] → [p=1, mozilla33 carry over]

Comment 2

4 years ago
What is the status of the TOS URL? Has it been implemented? It is hard to know from the actions/comments in this bug and just following up to make sure we get this done asap.
Geoff, this is to be handled in bug 1044411. We need to know where we should host this still.
Flags: needinfo?(sescalante)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1046034
Alexis -- Do you need any client work on this bug, or can I close this as a dup of bug 1044411 if that's where all the work for this is being done?
Flags: needinfo?(alexis+bugs)
We don't know where this will be stored yet. bug 1044411 is the one where this decision will be done, and then client needs to be updated with this url after that.
Flags: needinfo?(alexis+bugs)
Alexis -- So, all the work will be done on bug 1044411 and then this bug is just for updating the URL.  Am I correct?
Flags: needinfo?(alexis+bugs)
This is correct, yes.
Flags: needinfo?(alexis+bugs)
Whiteboard: [p=1, mozilla33 carry over] → [p=1, mozilla33 carry over][qa+]
Duplicate of this bug: 1046039

Comment 10

4 years ago
Arcadio approved URL, so confirming this is unblocked to use https://hello.firefox.com/legal/terms as the ToS URL.
Flags: needinfo?(sescalante)
Adam is handling this over on bug 1044411
Assignee: nobody → adam

Updated

4 years ago
Whiteboard: [p=1, mozilla33 carry over][qa+] → [p=1, mozilla33 carry over][qa+][loop-uplift]
Target Milestone: mozilla34 → mozilla35
(Assignee)

Comment 12

4 years ago
Created attachment 8490763 [details] [diff] [review]
Update the ToS link for the Loop standalone UI.

Now bug 1044411 has landed, this updates the ToS link for the standlone client. I'm proposing we change the desktop one separately, once bug 1044411 has been pushed to production.
Attachment #8490763 - Flags: review?(dmose)
(Assignee)

Updated

4 years ago
Assignee: adam → standard8
Iteration: --- → 35.2
Comment on attachment 8490763 [details] [diff] [review]
Update the ToS link for the Loop standalone UI.

Review of attachment 8490763 [details] [diff] [review]:
-----------------------------------------------------------------

r=dmose
Attachment #8490763 - Flags: review?(dmose) → review+
(Assignee)

Comment 14

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/711a0c039ced
Points: --- → 1
Keywords: leave-open
Whiteboard: [p=1, mozilla33 carry over][qa+][loop-uplift] → [qa+][loop-uplift][fix desktop when bug 1044411 is on production]

Updated

4 years ago
QA Contact: anthony.s.hughes
Flags: qe-verify+
Whiteboard: [qa+][loop-uplift][fix desktop when bug 1044411 is on production] → [loop-uplift][fix desktop when bug 1044411 is on production]
Mark -- can we mark this as resolved now?
Flags: needinfo?(standard8)
(Assignee)

Comment 17

4 years ago
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #16)
> Mark -- can we mark this as resolved now?

No, we need to desktop once production is live.
Flags: needinfo?(standard8)
(Assignee)

Comment 18

4 years ago
I had to push a follow-up fix so that the standalone client works correctly with the ToS on the staging server:

https://hg.mozilla.org/integration/fx-team/rev/56e6f150cd6c
(Assignee)

Comment 20

3 years ago
Created attachment 8495351 [details] [diff] [review]
Update the ToS link for the Loop panel.

Now we've got the page live, here's the link change for the panel.
Attachment #8495351 - Flags: review?(adam)

Comment 21

3 years ago
Comment on attachment 8495351 [details] [diff] [review]
Update the ToS link for the Loop panel.

Review of attachment 8495351 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8495351 - Flags: review?(adam) → review+
(Assignee)

Comment 22

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/c6355e364936
Keywords: leave-open
Whiteboard: [loop-uplift][fix desktop when bug 1044411 is on production] → [loop-uplift]
https://hg.mozilla.org/mozilla-central/rev/c6355e364936
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
I'm untracking this for verification. This will be covered through smoketesting.
Flags: qe-verify+ → qe-verify-
Comment on attachment 8490763 [details] [diff] [review]
Update the ToS link for the Loop standalone UI.

Approval Request Comment
Uplift request for patches staged and tested on Fig
Attachment #8490763 - Flags: approval-mozilla-aurora?

Updated

3 years ago
Attachment #8495351 - Flags: approval-mozilla-aurora?

Updated

3 years ago
status-firefox34: --- → fixed
status-firefox35: --- → fixed
Comment on attachment 8490763 [details] [diff] [review]
Update the ToS link for the Loop standalone UI.

I worked with Randell and Maire on uplifting a large number of Loop bugs at once. All of the bugs have been staged on Fig and tested by QE before uplift to Aurora. As well, all of the bugs are isolated to the Loop client. Randell handled the uplift with my approval. I am adding approval to the bug after the fact for bookkeeping.
Attachment #8490763 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8495351 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
We have a Moztrap smokestest for ToS/Privacy in the Hello panel and Standalone page.
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.