Closed Bug 1035863 Opened 8 years ago Closed 8 years ago

Add two new Linux64 masters to accommodate new emulator slaves

Categories

(Release Engineering :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kmoir, Assigned: kmoir)

References

Details

Attachments

(8 files, 1 obsolete file)

See bug 1011488 for an example
Assignee: nobody → kmoir
disabled new masters for now
Attachment #8452525 - Flags: review?(rail)
Attachment #8453066 - Flags: review?(rail)
Attachment #8452525 - Flags: review?(rail) → review+
Attachment #8453066 - Flags: review?(rail) → review+
Attachment #8452525 - Flags: checked-in+
Attachment #8453066 - Flags: checked-in+
Comment on attachment 8453332 [details] [diff] [review]
bug1035863toolsfix.patch

fix typos
Attachment #8453332 - Flags: review?(rail)
Comment on attachment 8453332 [details] [diff] [review]
bug1035863toolsfix.patch

Ooops, I missed those as well.
Attachment #8453332 - Flags: review?(rail) → review+
Attached file linux64masters (obsolete) —
add new linux master to slavealloc
Attachment #8453350 - Flags: review?(rail)
Attachment #8453332 - Flags: checked-in+
Comment on attachment 8453350 [details]
linux64masters

I'm not sure if masterid will work... I see only odd IDs in the database and I've seen this behaviour before.

Can you create a file without numerical IDs, the import script will handle those for you. As an example you can use this template:

nickname,fqdn,http_port,pb_port,datacenter,pool
bm113-tests1-linux64,buildbot-master113.srv.releng.use1.mozilla.com,8201,9201,us-east-1,tests-use1-linux64
Attachment #8453350 - Flags: review?(rail) → review-
Attached file linux64masters
Attachment #8453350 - Attachment is obsolete: true
Attachment #8453759 - Flags: review?(rail)
Comment on attachment 8453759 [details]
linux64masters

Ship it!
Attachment #8453759 - Flags: review?(rail) → review+
Comment on attachment 8453759 [details]
linux64masters

imported to slavealloc
Going through the steps in https://wiki.mozilla.org/ReleaseEngineering/AWS_Master_Setup to setup the masters in AWS
new hostname as per dustin
Attachment #8453956 - Flags: review?(rail)
new hostnames as per dustin
Attachment #8453958 - Flags: review?(rail)
Attachment #8453956 - Flags: review?(rail) → review+
Attachment #8453958 - Flags: review?(rail) → review+
Blocks: 1037150
Depends on: 1037159
Depends on: 1037176
Rail I recreated the instances and they still don't have their hostnames set.  Anyways, I'll look at it again tomorrow.
It turns out that "type" used in configs/master-linux64 doesn't match the file name. I renamed it in https://hg.mozilla.org/build/cloud-tools/rev/e5586f6e05ed. Can you recreate the masters passing the new name of config (-c configs/buildbot-master).
Sure I'll do that now
puppet hosts for new aws masters
Attachment #8454446 - Flags: review?(rail)
enable masters once netflow issues are sorted
Attachment #8454449 - Flags: review?(rail)
Attachment #8454446 - Flags: review?(rail) → review+
Attachment #8454449 - Flags: review?(rail) → review+
Attachment #8454446 - Flags: checked-in+
Attachment #8453958 - Flags: checked-in+
Attachment #8453956 - Flags: checked-in+
Attachment #8454449 - Flags: checked-in+
In production
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.