Closed Bug 1035933 Opened 5 years ago Closed 5 years ago

TEST-UNEXPECTED-FAIL | /builds/slave/test/gaia/apps/verticalhome/test/marionette/app_retry_icon_fetch_test.js | Vertical Home - Hosted app failed icon fetch shows icon after a restart

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: julienw, Assigned: kgrandon)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=43324274&tree=Gaia-Try&full=1


02:15:38     INFO -    2) Vertical Home - Hosted app failed icon fetch shows icon after a restart:
02:15:38     INFO -    Error: timeout exceeded!
02:15:38     INFO -        at Object.Client.waitForSync (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:682:16)
02:15:38     INFO -        at Object.Client.waitFor (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:650:60)
02:15:38     INFO -        at Context.<anonymous> (/builds/slave/test/gaia/apps/verticalhome/test/marionette/app_retry_icon_fetch_test.js:77:12)
Blocks: 1035939
Seems like our node.js server may be acting up?
See Also: → 1035638
Depends on: 1036143
So, is this caused by bug 903291?
If yes, I think bug 903291 should definitely be backed out for test failures. And this proves once more that we need unhidden Gi in TBPL :)
(In reply to Julien Wajsberg [:julienw] from comment #2)
> So, is this caused by bug 903291?
> If yes, I think bug 903291 should definitely be backed out for test
> failures. And this proves once more that we need unhidden Gi in TBPL :)

Yup, we have at least two homescreen test failures due to platform bugs, I think there's possibly 1-2 more that are due to platform bugs, but I'm investigating. It looks like bug 903291 is causing at least one other problem as well so I'm sure we'll get it backed out today.
Since bug 903291 has landed, I think this is no longer intermittent. Marking as fixed.
Assignee: nobody → kgrandon
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.