Touching the status bar while in Browser makes the screen unresponsive

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: pdol, Assigned: daleharvey)

Tracking

unspecified
2.0 S6 (18july)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

(Whiteboard: [systemsfe], URL)

(Reporter)

Description

4 years ago
Device: Flame
Build ID: 20140708000322

STR:

1. Open the Browser
2. Touch anywhere on the status bar
3. Try interacting with the screen

Expected:

Nothing happens when you touch the status bar.  Interacting with the screen works as normal.

Actual:

Touching the status bar shows the date (which is what is shown when you open the Utility tray).  The screen no longer responds to input anywhere other than the status bar.

The home button will still work, but the screen remains unresponsive on the homescreen.

I believe that this is severe enough to block on.
Dale, can you take a look?
blocking-b2g: 2.0? → 2.0+
Flags: needinfo?(dale)
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S6 (18july)
(Assignee)

Comment 2

4 years ago
can do
Assignee: nobody → dale
Flags: needinfo?(dale)
Adding QA Wanted for branch checks.
Keywords: qawanted
(Assignee)

Comment 4

4 years ago
wow I can reproduce, this is fairly bad, I assume there has been a change to some event handling and the status bar is being invoked, the browser is somehow capturing the mouse up event and the status bar never completes, this wont happen with other applications as the browser is in process
(Assignee)

Comment 5

4 years ago
So I bricked my device, had to reflash latest base image, now on latest gecko / gaia I cant reproduce
(Assignee)

Comment 6

4 years ago
Ok, flashed with both aurora and central on the latest base image and I believe this bug is fixed, possibly an outdated base image (although quite surprised that could cause this bug, I still see the bug on my dogfood device 

Closing as WFM, would be nice to have QA confirm
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.