gSubDialog._onLoad assumes docEl.style is not null

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: MattN, Unassigned, Mentored)

Tracking

unspecified
Points:
1
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=js][good first bug], URL)

If there is no style attribute on the dialog then an exception with be raised.
Points: --- → 1
QA Whiteboard: [qa-]
Flags: firefox-backlog+

Comment 1

5 years ago
Explain, please, how to reproduce this problem?
To reproduce the problem follow these steps:
1) Open browser/components/preferences/selectBookmark.xul in an editor
2) Remove the 'style="width: 32em;"' attribute altogether (don't just empty it).
3) Rebuild: ./mach build browser/components/preferences/
4) Run the build: ./mach run
5) Open preferences/options > General tab (in-content version)
6) Click the "Use Bookmark…" button
7) There used to be an error in the Browser Console

It didn't make sense to me that the style was missing so maybe I misunderstood where the error was coming from. I can't reproduce anymore.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Iteration: --- → 33.3
You need to log in before you can comment on or make changes to this bug.